Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google search option missing in 68.0.2

  • 5 replies
  • 7 have this problem
  • Last reply by Tommy

more options

When Firefox updated to 68.0.2 it removed google from my list of search options and the only option I am given for search engine is Yahoo. When searching for google in the add ons all it gives me is google translate and google images. How to I get google back?

All Replies (5)

more options

Chinese: 您好,我是来自中国大陆的志愿者。 你在地址栏输入“about:preferences#search”,然后点击“恢复默认搜索引擎”试试? English: Hello, I am a volunteer from mainland China. You type "about:preferences#search" in the address bar, then click "Restore default search engine" to try?

more options

This did not work. The option to choose google still doesn't show up.

more options

Your System Details list shows all default search engines as you can see on the "Help -> Troubleshooting Information" (about:support) page, so if you only have Yahoo available then you either have an extension that hides the other search engines or you have malware or there is a problem with the file that stores the search engine configuration


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can rename/remove search.json.mozlz4 (and possible search.json, search-metadata.json, search.sqlite) in the Firefox profile folder with Firefox closed to rebuild the search engines registry.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Firefox will rebuild the search.json.mozlz4 file from the builtin search engines.

more options

I wonder whether this could be a side effect of the "Norton Safe Search" extension? Hopefully cor-el's reply will help you determine that. Shame on them if they are hiding all the built-in search engines.

more options

Thanks cor-el. That suggestion of removing search.json.mozlz4 worked for me