X
Tap here to go to the mobile version of the site.

Support Forum

My add-on icons no longer appear in the toolbar. How do I get them back?

Posted

I had to re-install Windows and after re-installing Firefox and some extensions, the icons no longer appear in the toolbar. I've tried re-installing Firefox again, still the same. I tried adding more space on the right side of the search box to allow more room for the icons, but still nothing. The extensions I added are AdBlock, Ant Video Downloader, Facebook Container, FVD Video Downloader, Ghostery, and YouTube HD. Only the icon for FVD appears, none of the others, which did before.

I had to re-install Windows and after re-installing Firefox and some extensions, the icons no longer appear in the toolbar. I've tried re-installing Firefox again, still the same. I tried adding more space on the right side of the search box to allow more room for the icons, but still nothing. The extensions I added are AdBlock, Ant Video Downloader, Facebook Container, FVD Video Downloader, Ghostery, and YouTube HD. Only the icon for FVD appears, none of the others, which did before.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

FredMcD
  • Top 10 Contributor
4225 solutions 58988 answers

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

It’s possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder '''Linux: ''' Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Directory. ''' To its right press the button '''Open Directory. ''' Delete all '''extensions*''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons +++++++++++++++++++++++++++ You will have to approve the updating one last time.
Was this helpful to you?
Quote
WMagicModel
  • Top 25 Contributor
  • Administrator
6 solutions 114 answers

Hi Animal81369,

I understand you are having issues adding icons for your extensions to the toolbar.

Here are some similar solutions in relation to yours from our valued contributors: Add on icons not showing next to the search bar.

If you haven't already, you can further customize Firefox by dragging your favorite extensions to the toolbar or overflow menu.

This is done by:

  1. Clicking the top right menu in the browser.
  2. Click customize.
  3. Dragging individual extensions in the list to either side of the toolbar.
  4. Check if any of your extensions are in the overflow menu

Supporting article: Customize Firefox controls, buttons and toolbars

Let me know if this helps.

Hi Animal81369, I understand you are having issues adding icons for your extensions to the toolbar. Here are some similar solutions in relation to yours from our valued contributors: [https://support.mozilla.org/en-US/questions/1171875 Add on icons not showing next to the search bar.] If you haven't already, you can further customize Firefox by dragging your favorite extensions to the '''toolbar''' or '''overflow menu'''. This is done by: # Clicking the top right '''menu''' in the browser. # Click '''customize'''. # Dragging individual extensions in the list to either side of the toolbar. # Check if any of your extensions are in the overflow menu Supporting article: [https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars Customize Firefox controls, buttons and toolbars] Let me know if this helps.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17418 solutions 157376 answers

Do you still see these extensions listed on the about:addons page (Add-ons -> Extensions)?

You can try Restore Defaults on the customize page.

You can also try to disable and re-enable one of the extensions to see if that restores the toolbar button and try a new window.

Do you still see these extensions listed on the about:addons page (Add-ons -> Extensions)? You can try <u>Restore Defaults</u> on the customize page. You can also try to disable and re-enable one of the extensions to see if that restores the toolbar button and try a new window.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.