X
Tap here to go to the mobile version of the site.

Support Forum

firefox keeps deleting cookies eventhough i have allowed all

Posted

I have Firefox on Windows 10 (latest build) and i am logged in with my firefoxaccount. I have in settings "Delete cookies and site data when Firefox is closed" NOT checked. However, when i close all windows of Firefox and start the browser again, all the cookies are gone. I have uninstalled Firefox and reinstalled it again, but that didnt help. I don't have any plugins that delete cookies.

Thank you in advance for your help.

I have Firefox on Windows 10 (latest build) and i am logged in with my firefoxaccount. I have in settings "Delete cookies and site data when Firefox is closed" NOT checked. However, when i close all windows of Firefox and start the browser again, all the cookies are gone. I have uninstalled Firefox and reinstalled it again, but that didnt help. I don't have any plugins that delete cookies. Thank you in advance for your help.

Chosen solution

tomvdheuvel said

It was allready set to remember history

When it's set to "Remember history" - would you please click on the little black down arrow to the right ? You will then get a dropdown where you can choose the "Use custom settings for history" that I was talking about in my first post ...... Then, please check the settings I mentioned, and if/when those settings are correct, you can choose "Remember history" again.

Read this answer in context 0
Quote
McCoy
  • Top 10 Contributor
488 solutions 4493 answers

Hello Tom,

Just to make sure; would you check this please :

Options => Privacy & Security => History

Click the little down arrow next to "Remember history" and choose "Use custom settings for history"

If "Clear history when Firefox closes" is checked, then click "Settings" and make sure that cookies are unchecked.



You say "I don't have any plugins that delete cookies " :

You probably meant "extensions" instead of "plugins" - when you go to Options => Add-ons, you will see what I mean .....

Hello Tom, Just to make sure; would you check this please : Options => Privacy & Security => History Click the little down arrow next to "Remember history" and choose "Use custom settings for history" If "Clear history when Firefox closes" is checked, then click "Settings" and make sure that cookies are '''un'''checked. ------------------------------------------------------------------------------------------------<BR> You say "''I don't have any plugins that delete cookies'' " : You probably meant "extensions" instead of "plugins" - when you go to Options => Add-ons, you will see what I mean .....
Was this helpful to you?
Quote

Question owner

Options => Privacy & Security => History | This is set to "remember history"

McCoy said

Hello Tom, Just to make sure; would you check this please : Options => Privacy & Security => History Click the little down arrow next to "Remember history" and choose "Use custom settings for history" If "Clear history when Firefox closes" is checked, then click "Settings" and make sure that cookies are unchecked.

You say "I don't have any plugins that delete cookies " :

You probably meant "extensions" instead of "plugins" - when you go to Options => Add-ons, you will see what I mean .....

I did, you are right.

Options => Privacy & Security => History | This is set to "remember history" ''McCoy [[#answer-1243755|said]]'' <blockquote> Hello Tom, Just to make sure; would you check this please : Options => Privacy & Security => History Click the little down arrow next to "Remember history" and choose "Use custom settings for history" If "Clear history when Firefox closes" is checked, then click "Settings" and make sure that cookies are '''un'''checked. ------------------------------------------------------------------------------------------------<BR> You say "''I don't have any plugins that delete cookies'' " : You probably meant "extensions" instead of "plugins" - when you go to Options => Add-ons, you will see what I mean ..... </blockquote> I did, you are right.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
488 solutions 4493 answers

Hello again Tom,

You say " This is set to "Remember history " - did you do what I asked you to do ?

Hello again Tom, You say "'' This is set to "Remember history'' " - did you do what I asked you to do ?
Was this helpful to you?
Quote

Question owner

It was allready set to remember history

It was allready set to remember history
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
488 solutions 4493 answers

Chosen Solution

tomvdheuvel said

It was allready set to remember history

When it's set to "Remember history" - would you please click on the little black down arrow to the right ? You will then get a dropdown where you can choose the "Use custom settings for history" that I was talking about in my first post ...... Then, please check the settings I mentioned, and if/when those settings are correct, you can choose "Remember history" again.

''tomvdheuvel [[#answer-1243772|said]]'' <blockquote> It was allready set to remember history </blockquote> When it's set to "Remember history" - would you please click on the little black down arrow to the right ? You will then get a dropdown where you can choose the "Use custom settings for history" that I was talking about in my first post ...... Then, please check the settings I mentioned, and if/when those settings are correct, you can choose "Remember history" again.
Was this helpful to you?
Quote

Question owner

This solved it, thank you. It feels weird though when it is set to remember, but actually... it is not.

Thank you again!

This solved it, thank you. It feels weird though when it is set to remember, but actually... it is not. Thank you again!
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
488 solutions 4493 answers

tomvdheuvel said

This solved it, thank you. It feels weird though when it is set to remember, but actually... it is not.

I know what you mean - when I first saw that feature, I was puzzled too ....

Thank you again!

My pleasure - have a nice day !

''tomvdheuvel [[#answer-1243775|said]]'' <blockquote> This solved it, thank you. It feels weird though when it is set to remember, but actually... it is not. </blockquote> I know what you mean - when I first saw that feature, I was puzzled too .... <blockquote> Thank you again! </blockquote> My pleasure - have a nice day !
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.