Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

<ondemandkorea.com> won't let me play videos, citing "AdBlock"

  • 2 replies
  • 1 has this problem
  • 258 views
  • Last reply by DL

more options

I tried to play videos on <ondemandkorea.com> on Firefox - I got their usual "AdBlock detected, buy our membership!" message. So I disabled my uBlock Origin - still the same message. I uninstalled the extension completely - STILL the same message!!! I tried the same webpage with Chrome - it runs, even with uBO installed, but with ads, even with uBO installed. The only thing I could think of that has any bearing on this phenomenon is that terrifying expose that was published a few weeks ago about how ad-friendly and overtly data-hungry Chrome has become in comparison to most other web browsers. I would be loathe to change how Firefox handles my private data, but I'd like to at least know HOW to get videos to play on <ondemandkorea.com> so I can have some options. Can anyone help please?

p.s. Googling uBO subreddit and forums and trying to make sense of their code with my limited knowledge was ineffective - in my experience, ondemandkorea devs update their code pretty frequently whenever someone publishes a workaround code for their aggressive adblock-blocking. And so I haven't really seen any recent updates that deals with <ondemandkorea.com>... at least none that I've found.

Chosen solution

Hello DL,

This could be down to Content Blocking - would you please check your settings in Options => Privay & Security => Content Blocking.

See : https://support.mozilla.org/en-US/kb/content-blocking

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hello DL,

This could be down to Content Blocking - would you please check your settings in Options => Privay & Security => Content Blocking.

See : https://support.mozilla.org/en-US/kb/content-blocking

more options

It worked! I switched from my previously set custom settings to "standard" and it played the video, ads and all! Thank you, I totally forgot where this setting was or even what it looked like :)