Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"The address wasn't understood"

  • 7 replies
  • 2 have this problem
  • 743 views
  • Last reply by FredMcD

more options

Sharepoint offers links of the form ms-word:ofe|u|https://somebusinessname.sharepoint.com/sites/somesitename/somefilename.docx and firefox responds with the subject error message and cannot open the file in MS Word. IE, Edge and Chrome all behave correctly for this same sharepoint link on the same machine.

Attached screenshots

All Replies (7)

more options

https://somebusinessname.sharepoint.com/sites/somesitename/somefilename.docx

I get: Server not found

Note: Everything before ' https ' is not understood as part of a weblink.

more options
more options

Respectfully, of course the server is not found! I removed the stuff that identifies our sharepoint site, ie I generalized the link. The exact same link (with the actual server name and filename) works fine on IE, Edge and Chrome, but not on FF.

more options

For Firefox 71:

You could try creating a new preference for ms-word and see whether that helps. Here's how:

(0) Select (triple-click is fastest) and copy this new preference name

network.protocol-handler.external.ms-word

(1) In a new tab, type about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, paste the new preference name

If this is already set up, Firefox should show a bar for the preference with either true or false. If it is false double-click it to switch it to true. If you don't see that bar:

(3) Firefox should show a bar with the choices Boolean, Number, and String. Click Boolean then click the + button at the right end of that bar.

(4) If Firefox doesn't set the value to true automatically, double-click the new preference to switch the value to true

Does Firefox handle the links any better now?


For Firefox 70 and earlier:

Hi alabamatoy, I don't know if I have any links like that to test on.

Firefox comes with certain preference for novel protocols (the part to the left of the :// in a URL). For example:

network.protocol-handler.external.ms-windows-store

You could try creating a new preference for ms-word and see whether that helps. Here's how:

(0) Select (triple-click is fastest) and copy this new preference name

network.protocol-handler.external.ms-word

(1) In a new tab, type about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste ms- and pause while the list is filtered

(3) Right-click a blank area of the page, click New, then click Boolean

(4) In the dialog that pops up, paste the new preference name, then click OK, then select true, then click OK

network.protocol-handler.external.ms-word should now appear in the list bolded with a value of true.

Does Firefox handle the links any better now?

Modified by jscher2000

more options

This fixed the problem. I expect to have to replicate this for the other Micro$oft products since they work same way. Thanks!

more options

This did not resolve my issue - sad...

more options

Romy Fitschen Please go to the top of any support.mozilla.org web page and use the Get Community Support link: https://support.mozilla.org/en-US/questions/new

Select the product for what the problem is (Firefox or whatever). Now select the category for the problem. At the bottom is Other.

Describe the problem in brief (one line). Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.