X
Tap here to go to the mobile version of the site.

Support Forum

After many hours of struggling with installation of account for my Gmail in Thunderbird, I have not been able to succeed. Connection with Gmail fails.

Posted

After many hours of struggling with installation of an account for my Gmail in Thunderbird, I have not been able to succeed. Connection with Gmail fails. Error message: "User name or password invalid" and "Configuration can not be verified. Is the user name or password not correct?"

I assume it concerns authentication.

According to “Google-account Help” I can set an App-password for Thunderbird to make a two-step authentication to connect Thunderbird with Gmail. This does not work as there appears no option "App-passwords". So how do I generate a two-step authentication in order to be able to connect Thunderbird with Gmail? In the server settings for my Gmail-account in Thunderbird, under authentication "OAuth2" is mentioned for both incoming (IMAP; imap.gmail,com; port 993) and outgoing (SMTP; smtp.gmail,com; port 465). How can I connect thunderbird with Gmail???

After many hours of struggling with installation of an account for my Gmail in Thunderbird, I have not been able to succeed. Connection with Gmail fails. Error message: "User name or password invalid" and "Configuration can not be verified. Is the user name or password not correct?" I assume it concerns authentication. According to “Google-account Help” I can set an App-password for Thunderbird to make a two-step authentication to connect Thunderbird with Gmail. This does not work as there appears no option "App-passwords". So how do I generate a two-step authentication in order to be able to connect Thunderbird with Gmail? In the server settings for my Gmail-account in Thunderbird, under authentication "OAuth2" is mentioned for both incoming (IMAP; imap.gmail,com; port 993) and outgoing (SMTP; smtp.gmail,com; port 465). How can I connect thunderbird with Gmail???

Chosen solution

Did you enable access by 'less-secure apps' in the gmail settings? With that enabled and using OAuth authentication, enter your normal account password and allow the OAuth process to complete and set a token on your computer.

http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite

Read this answer in context 1
Quote
Matt
  • Top 10 Contributor
  • Moderator
3215 solutions 21996 answers

Helpful Reply

Using Norton's or other net nanny anti virus? They have a habit of getting in the way of the account wizard and preventing new accounts being set up.

Restart the operating system in safe mode with Networking. This loads only the very basics needed to start your computer while enabling an Internet connection. Click on your operating system for instructions on how to start in safe mode: Windows 10, Windows 8, Windows 7, Windows Vista, Windows XP, OSX

Now try to set up the account. If the setup works it will have been other software on your computer that was the issue. Most likely anti virus products.

Using Norton's or other net nanny anti virus? They have a habit of getting in the way of the account wizard and preventing new accounts being set up. Restart the operating system in '''[http://en.wikipedia.org/wiki/Safe_mode safe mode with Networking]'''. This loads only the very basics needed to start your computer while enabling an Internet connection. Click on your operating system for instructions on how to start in safe mode: [https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode Windows 10], [http://windows.microsoft.com/en-us/windows-8/windows-startup-settings-safe-mode Windows 8], [http://windows.microsoft.com/en-us/windows/start-computer-safe-mode#start-computer-safe-mode=windows-7 Windows 7], [http://windows.microsoft.com/en-us/windows/start-computer-safe-mode#start-computer-safe-mode=windows-vista Windows Vista], [http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx?mfr=true" Windows XP], [http://support.apple.com/kb/ht1564 OSX] Now try to set up the account. If the setup works it will have been other software on your computer that was the issue. Most likely anti virus products.
Was this helpful to you? 1
Quote
sfhowes 2 solutions 3 answers

Chosen Solution

Did you enable access by 'less-secure apps' in the gmail settings? With that enabled and using OAuth authentication, enter your normal account password and allow the OAuth process to complete and set a token on your computer.

http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite

Did you enable access by 'less-secure apps' in the gmail settings? With that enabled and using OAuth authentication, enter your normal account password and allow the OAuth process to complete and set a token on your computer. http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite
Was this helpful to you? 1
Quote

Question owner

Reply to Matt

There has been no need to apply your suggestion, as I solved the problem having read the texts provided by sfhowes.

Reply to sfhowes

I did enable “less-secure apps” in the Gmail settings. Having read the texts you provided, I again started to create a new account for my Gmail in Thunderbird. In the third step, the screen shows:

Server host name Port SSL Authentication Incoming IMAP imap.gmail.com 993 SSL/TLS OAuth2 Outgoing SMTP smtp.gmail.com 465 SSL/TLS OAuth2

In the last column (Authentication), there are actually six choices:

- autodetection; - normal password; - encrypted password; - Kerberos/GSSAPI; - NTML; - OAuth2.

For both “incoming” and “outgoing”, I changed “OAuth2” into “normal password” and the connection was made. Problem solved. (Previously, I did not dare to change anything in the column Authentication.)

Reply to Matt There has been no need to apply your suggestion, as I solved the problem having read the texts provided by sfhowes. Reply to sfhowes I did enable “less-secure apps” in the Gmail settings. Having read the texts you provided, I again started to create a new account for my Gmail in Thunderbird. In the third step, the screen shows: Server host name Port SSL Authentication Incoming IMAP imap.gmail.com 993 SSL/TLS OAuth2 Outgoing SMTP smtp.gmail.com 465 SSL/TLS OAuth2 In the last column (Authentication), there are actually six choices: - autodetection; - normal password; - encrypted password; - Kerberos/GSSAPI; - NTML; - OAuth2. For both “incoming” and “outgoing”, I changed “OAuth2” into “normal password” and the connection was made. Problem solved. (Previously, I did not dare to change anything in the column Authentication.)
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3215 solutions 21996 answers

I am glad you have it working. It is not google preferred method. Google opinion is not relevant, until you consider they are determined to make everyone use oAuth. Normal password is as far as Google is concerned "deprecated" and it will only work until they finally say they have had enough and refuse to allow you to set the "allow less secure apps" setting on their web site.

Also make sure you don't accidentally turn it off in one of their security checks. they auto set the setting to off in the security check so just clicking ok will turn it off and suddenly your mail will not download and you will get obscure error messages that will not leave you thinking you have messed up the security settings.

I am glad you have it working. It is not google preferred method. Google opinion is not relevant, until you consider they are determined to make everyone use oAuth. Normal password is as far as Google is concerned "deprecated" and it will only work until they finally say they have had enough and refuse to allow you to set the "allow less secure apps" setting on their web site. Also make sure you don't accidentally turn it off in one of their security checks. they auto set the setting to off in the security check so just clicking ok will turn it off and suddenly your mail will not download and you will get obscure error messages that will not leave you thinking you have messed up the security settings.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.