X
Tap here to go to the mobile version of the site.

Support Forum

How do I make Thunderbird open in existing Firefox window?

Posted

I have the most current Firefox installed - as of this writing, Firefox Quantum 67.0.4.

Since the last update, Thunderbird email links open a new Firefox window instead of opening in the existing window I have open. Previously, Thunderbird links opened in existing window. It almost acts like I have two iterations of Firefox installed, but I checked that.

I noticed that when I am using Dreamweaver to design a web page, it now also opens a new window.

I've tried various things to fix this. Yes, Firefox is set to default.

Very annoying.

I have the most current Firefox installed - as of this writing, Firefox Quantum 67.0.4. Since the last update, Thunderbird email links open a new Firefox window instead of opening in the existing window I have open. Previously, Thunderbird links opened in existing window. It almost acts like I have two iterations of Firefox installed, but I checked that. I noticed that when I am using Dreamweaver to design a web page, it now also opens a new window. I've tried various things to fix this. Yes, Firefox is set to default. Very annoying.

Chosen solution

Hi Cynthia, sorry about the inconvenience.

Firefox 67 changed how external links and locally saved documents are handled: instead of opening in whatever Firefox profile (settings file) is currently running, they will open in the default profile. So possibly your regular profile and the one marked as default might be out of alignment.

Next time you use an external link and get an unfamiliar Firefox, try this:

Profile Manager Page

Type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile, and possibly several. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile the current Firefox window is currently using will have this:

This is the profile in use and it cannot be deleted.

If another profile is running it will have this longer text:

This profile is in use in another application and it cannot be deleted.

If you see that, does that profile have a button labeled Set as default profile? If so, please click that to align the external link behavior with your preferred settings.

Any luck?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

jscher2000
  • Top 10 Contributor
8635 solutions 70637 answers

Chosen Solution

Hi Cynthia, sorry about the inconvenience.

Firefox 67 changed how external links and locally saved documents are handled: instead of opening in whatever Firefox profile (settings file) is currently running, they will open in the default profile. So possibly your regular profile and the one marked as default might be out of alignment.

Next time you use an external link and get an unfamiliar Firefox, try this:

Profile Manager Page

Type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile, and possibly several. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile the current Firefox window is currently using will have this:

This is the profile in use and it cannot be deleted.

If another profile is running it will have this longer text:

This profile is in use in another application and it cannot be deleted.

If you see that, does that profile have a button labeled Set as default profile? If so, please click that to align the external link behavior with your preferred settings.

Any luck?

Hi Cynthia, sorry about the inconvenience. Firefox 67 changed how external links and locally saved documents are handled: instead of opening in whatever Firefox profile (settings file) is currently running, they will open in the default profile. So possibly your regular profile and the one marked as default might be out of alignment. Next time you use an external link and get an unfamiliar Firefox, try this: '''Profile Manager Page''' Type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. This page should list at least one profile, and possibly several. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!) The profile the current Firefox window is currently using will have this: '''This is the profile in use and it cannot be deleted.''' If another profile is running it will have this longer text: '''This profile is in use in another application and it cannot be deleted.''' If you see that, does ''that'' profile have a button labeled '''Set as default profile'''? If so, please click that to align the external link behavior with your preferred settings. Any luck?
Was this helpful to you? 1
Quote

Question owner

That worked, yes. You're wonderful!! Thank you.

In the process of trying to find a solution on my own, I now have Thunderbird asking each time what browser I want to use to open the link. I keep selecting Firefox thinking the next time all will be OK, but next time, I am asked again.  :(

Thoughts?

That worked, yes. You're wonderful!! Thank you. In the process of trying to find a solution on my own, I now have Thunderbird asking each time what browser I want to use to open the link. I keep selecting Firefox thinking the next time all will be OK, but next time, I am asked again. :( Thoughts?
Was this helpful to you?
Quote

Question owner

Now I've really messed up. When that Thunderbird message came up, instead of choosing the generic looking Firefox shown, I went out to my hard drive and chose Firefox.exe. As soon as I did that, a new window opened again. Back to the original problem. Argh!!

So, I went back to about:profiles and now I have two profiles with "This profile is in use in another application and it cannot be deleted." See screenshot below.

Now I've really messed up. When that Thunderbird message came up, instead of choosing the generic looking Firefox shown, I went out to my hard drive and chose Firefox.exe. As soon as I did that, a new window opened again. Back to the original problem. Argh!! So, I went back to about:profiles and now I have two profiles with "This profile is in use in another application and it cannot be deleted." See screenshot below.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8635 solutions 70637 answers

Sorry, I know these messages are a little confusing.

This is the profile in use and it cannot be deleted.

This appears under the profile that the current Firefox window is using.

This profile is in use in another application and it cannot be deleted.

This message about "another application" appears under the profile that a different Firefox window is using.

Can you go back to Thunderbird and undo the last change?

Sorry, I know these messages are a little confusing. '''This is the profile in use and it cannot be deleted.''' This appears under the profile that the ''current'' Firefox window is using. '''This profile is in use in another application and it cannot be deleted.''' This message about "another application" appears under the profile that a ''different'' Firefox window is using. Can you go back to Thunderbird and undo the last change?
Was this helpful to you?
Quote

Question owner

I have no idea how to undo my selection. But, now Thunderbird is showing both Firefox options when I try to open a link. See screenshot.

Can't I just make default-1479249876240 the default profile?

I have no idea how to undo my selection. But, now Thunderbird is showing both Firefox options when I try to open a link. See screenshot. Can't I just make default-1479249876240 the default profile?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8635 solutions 70637 answers

Okay, can you use the first Firefox in the box?

Cynthia said

Can't I just make default-1479249876240 the default profile?

If it has a button to "Set as Default Profile" then yes, you can.

Okay, can you use the first Firefox in the box? ''Cynthia [[#answer-1235835|said]]'' <blockquote> Can't I just make default-1479249876240 the default profile? </blockquote> If it has a button to "Set as Default Profile" then yes, you can.
Was this helpful to you?
Quote

Question owner

Ok, now I'm back to emails opening in existing window since I set default-1479249876240 as default. Wonderful.

But, Thunderbird still continues to ask every time for a browser choice. The first choice does open in the currently open Firefox and does not open a new window. How do I get it to stop asking please?

Ok, now I'm back to emails opening in existing window since I set default-1479249876240 as default. Wonderful. But, Thunderbird still continues to ask every time for a browser choice. The first choice does open in the currently open Firefox and does not open a new window. How do I get it to stop asking please?
Was this helpful to you?
Quote

Question owner

Oops, now I see where there is a checkbox to remember my choice. Call me blind. Sorry. Now all seems to be working correctly. Phew!

Thanks!

Oops, now I see where there is a checkbox to remember my choice. Call me blind. Sorry. Now all seems to be working correctly. Phew! Thanks!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.