X
Tap here to go to the mobile version of the site.

Support Forum

Firefox appends www before random words in URL bar

Posted

The problem is that: 1. I copy random word. 2. Press CTRL+T and CTRL+V and press ENTER. Last time it happened it was a word "homography". 3. I end up on the website "http://www.homography/" 4. Why?

It is random, pasting it again in the URL bar does search in Google. I have these settings changed in `about:config`: browser.fixup.alternate.enabled = false browser.fixup.alternate.prefix = (empty) browser.fixup.alternate.suffix = (empty)

What's wrong?

The problem is that: 1. I copy random word. 2. Press CTRL+T and CTRL+V and press ENTER. Last time it happened it was a word "homography". 3. I end up on the website "http://www.homography/" 4. Why? It is random, pasting it again in the URL bar does search in Google. I have these settings changed in `about:config`: browser.fixup.alternate.enabled = false browser.fixup.alternate.prefix = (empty) browser.fixup.alternate.suffix = (empty) What's wrong?
Attached screenshots

Chosen solution

Unfortunately, Firefox doesn't have a feature to disable or reassign built-in keyboard shortcuts. An add-on can intercept many of them by injecting code into the current web page, but I don't think they can do it on the new tab page.

So I think for the time being, you'll have to take it a little bit slower so you don't have the Ctrl key down when you hit Enter. Or use the context menu command when applicable.

Solution to disable the shortcut: see cor-el's reply below.

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Hmm, that's a strange result. If you were going so fast that Firefox thought you were still holding down the Ctrl key when pressing Enter, then you should get both www. and the beginning and .com at the end. I don't know how you could get only www. at the beginning. ??

If you are trying to search a word or phrase selected in a page in Firefox, consider

right-click > Search [site] for [selected text]

as a workaround or possible time-saver.

Hmm, that's a strange result. If you were going so fast that Firefox thought you were still holding down the Ctrl key when pressing Enter, then you should get both www. and the beginning and .com at the end. I don't know how you could get only www. at the beginning. ?? If you are trying to search a word or phrase selected in a page in Firefox, consider right-click > Search [site] for [selected text] as a workaround or possible time-saver.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Helpful Reply

jscher2000 said

I don't know how you could get only www. at the beginning. ??

Actually, Ctrl+Enter plus these settings --

Ekci said

I have these settings changed in `about:config`: browser.fixup.alternate.prefix = (empty)
browser.fixup.alternate.suffix = (empty)

-- gives me just the extra www. and not .com. Odd.

''jscher2000 [[#answer-1233313|said]]'' <blockquote> I don't know how you could get only www. at the beginning. ??</blockquote> Actually, Ctrl+Enter plus these settings -- ''Ekci [[#question-1263333|said]]'' <blockquote>I have these settings changed in `about:config`: browser.fixup.alternate.prefix = (empty)<br> browser.fixup.alternate.suffix = (empty)</blockquote> -- gives me just the extra www. and not .com. Odd.

Modified by jscher2000

Was this helpful to you? 1
Quote

Question owner

Oh, that's it! So it looks like Ctrl+Enter forces fixup that's bugged and respects suffix setting but ignores prefix?

A fix for me would be turning the shortcut off but I cannot find a way to do this. Thank you for your answer!

Oh, that's it! So it looks like Ctrl+Enter forces fixup that's bugged and respects suffix setting but ignores prefix? A fix for me would be turning the shortcut off but I cannot find a way to do this. Thank you for your answer!
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Chosen Solution

Unfortunately, Firefox doesn't have a feature to disable or reassign built-in keyboard shortcuts. An add-on can intercept many of them by injecting code into the current web page, but I don't think they can do it on the new tab page.

So I think for the time being, you'll have to take it a little bit slower so you don't have the Ctrl key down when you hit Enter. Or use the context menu command when applicable.

Solution to disable the shortcut: see cor-el's reply below.

Unfortunately, Firefox doesn't have a feature to disable or reassign built-in keyboard shortcuts. An add-on can intercept many of them by injecting code into the current web page, but I don't think they can do it on the new tab page. So I think for the time being, you'll have to take it a ''little bit'' slower so you don't have the Ctrl key down when you hit Enter. Or use the context menu command when applicable. '''Solution to disable the shortcut:''' see cor-el's reply [[#answer-1233336|below]].

Modified by jscher2000

Was this helpful to you?
Quote

Question owner

jscher2000 said

Unfortunately, Firefox doesn't have a feature to disable or reassign built-in keyboard shortcuts. An add-on can intercept many of them by injecting code into the current web page, but I don't think they can do it on the new tab page. So I think for the time being, you'll have to take it a little bit slower so you don't have the Ctrl key down when you hit Enter. Or use the context menu command when applicable.

Ok, I will but shouldn't it be reported as a bug of a fixup? :)

''jscher2000 [[#answer-1233328|said]]'' <blockquote> Unfortunately, Firefox doesn't have a feature to disable or reassign built-in keyboard shortcuts. An add-on can intercept many of them by injecting code into the current web page, but I don't think they can do it on the new tab page. So I think for the time being, you'll have to take it a ''little bit'' slower so you don't have the Ctrl key down when you hit Enter. Or use the context menu command when applicable. </blockquote> Ok, I will but shouldn't it be reported as a bug of a fixup? :)
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Helpful Reply

Ekci said

Ok, I will but shouldn't it be reported as a bug of a fixup? :)

I thought about that, but the quick fix of making the prefix correctly blank doesn't help you bypass fixup:

Ctrl+Enter: if prefix = "" and suffix = "" then => http://word/

You need new logic:

Ctrl+Enter: if prefix = "" and suffix = "" then => DO NOT FIXUP

Or a new preference:

browser.fixup_shortcut.enabled = (true|false)

Solution to disable the shortcut: see cor-el's reply below.

''Ekci [[#answer-1233329|said]]'' <blockquote> Ok, I will but shouldn't it be reported as a bug of a fixup? :) </blockquote> I thought about that, but the quick fix of making the prefix correctly blank doesn't help you bypass fixup: Ctrl+Enter: if prefix = "" and suffix = "" then => http://word/ You need new logic: Ctrl+Enter: if prefix = "" and suffix = "" then => DO NOT FIXUP Or a new preference: browser.fixup_shortcut.enabled = (true|false) '''Solution to disable the shortcut:''' see cor-el's reply [[#answer-1233336|below]].

Modified by jscher2000

Was this helpful to you? 1
Quote

Question owner

Ok, thank you! I will solve this problem but still hope that there will be an option to disable the shortcut. It seems that I think faster than my fingers can move :)

Ok, thank you! I will solve this problem but still hope that there will be an option to disable the shortcut. It seems that I think faster than my fingers can move :)

Modified by Ekci

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Possibly you discovered it already but just in case, here's the bug tracker: https://bugzilla.mozilla.org/

Possibly you discovered it already but just in case, here's the bug tracker: https://bugzilla.mozilla.org/
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17519 solutions 158412 answers

Maybe:

  • browser.urlbar.ctrlCanonizesURLs = false
Maybe: *browser.urlbar.ctrlCanonizesURLs = false
Was this helpful to you? 1
Quote

Question owner

Yes! It did work, thank you @cor-el!

Yes! It did work, thank you @cor-el!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.