X
Tap here to go to the mobile version of the site.

Support Forum

Facebook won't load properly. Windows 10, Firefox Quantum.

Posted

Only the top two posts on News Feed load, and notifications, Messenger, Friend Requests and Help will not load at all. I also cannot post anything. This only happens on Firefox, only on Facebook. I have tried clearing my cache and clearing Facebook cookies, and disabling all plugins, and running in Safe Mode. Nothing makes any difference.

Only the top two posts on News Feed load, and notifications, Messenger, Friend Requests and Help will not load at all. I also cannot post anything. This only happens on Firefox, only on Facebook. I have tried clearing my cache and clearing Facebook cookies, and disabling all plugins, and running in Safe Mode. Nothing makes any difference.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Kaspersky Total Security (added Facebook to whitelist), OneTab, ShareX, uBlock

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

jscher2000
  • Top 10 Contributor
8505 solutions 69466 answers

Hi naznomad, has there been any improvement with this problem?

I think you have tried the logical things so far. Perhaps there is some less obvious setting causing the issue.

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? That may indicate Firefox's Content Blocking feature is modifying the page. More info on managing Tracking Protection in this article: Content blocking.

(B) Are there any custom permissions applied to the site? When you click the green lock, Firefox should list site information including whether any permissions have been granted or blocked for FB that are different from your default settings. Anything unusual there?


To see whether it is specific to your current profile settings, you could try:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like June2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (June2019 will remain available for future testing.)

Hi naznomad, has there been any improvement with this problem? I think you have tried the logical things so far. Perhaps there is some less obvious setting causing the issue. (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? That may indicate Firefox's Content Blocking feature is modifying the page. More info on managing Tracking Protection in this article: [[Content Blocking]]. (B) Are there any custom permissions applied to the site? When you click the green lock, Firefox should list site information including whether any permissions have been granted or blocked for FB that are different from your default settings. Anything unusual there? ---- To see whether it is specific to your current profile settings, you could try: '''New Profile Test''' This takes about 3 minutes, plus the time to test your problem site(s). Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. Click the "Create a New Profile" button, then click Next. Assign a name like June2019, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Launch profile in new browser''' button. Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test. ''Do the problem site(s) work any better in the new profile?'' When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (June2019 will remain available for future testing.)
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17267 solutions 156072 answers

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.