Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

home page not starting correctly

  • 3 replies
  • 2 have this problem
  • 24 views
  • Last reply by hamiheim

more options

When opening Firefox on a desktop or PC, my homepage does not load, instead it opens a blank tab. It does this on every desktop version of Firefox across multiple PCs, but does not affect my mobile browser. I have tried changing my homepage to a different site, and toggling the setting between opening blank tab and opening with my homepage. I have also modified the settings in the config (see attached screenshot) to try and get it to open with my homepage to no avail. Has anyone else had this issue, and if so how did you resolve it?

Attached screenshots

Modified by hamiheim

Chosen solution

Hello hamiheim,

This is a bug that involves a change in how Firefox 67 clears history.

Could it be that you're using "Delete cookies and site data when Firefox is closed" and/or "Clear history when Firefox closes" ?

Options => Privacy & Security :

Cookies and Site Data: "Delete cookies and site data when Firefox is closed"

Options => Privacy & Security :

Firefox will : "Use custom settings for history" : "Clear history when Firefox closes" => Settings

In case you do use one of these (or both); would you disable at least one of them  ?

See this bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1554167

Read this answer in context 👍 1

All Replies (3)

more options

Forgot to attach the screenshot to the original post

more options

Chosen Solution

Hello hamiheim,

This is a bug that involves a change in how Firefox 67 clears history.

Could it be that you're using "Delete cookies and site data when Firefox is closed" and/or "Clear history when Firefox closes" ?

Options => Privacy & Security :

Cookies and Site Data: "Delete cookies and site data when Firefox is closed"

Options => Privacy & Security :

Firefox will : "Use custom settings for history" : "Clear history when Firefox closes" => Settings

In case you do use one of these (or both); would you disable at least one of them  ?

See this bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1554167

more options

McCoy,

Thank that definitely is the issue. I noticed in my case it is only an issue when BOTH Clear history and Delete Cookies is enabled. If I disable one (either one doesn't matter which I tried it both ways) my homepage comes up correctly. Here's to hoping 67.0.2 will resolve.