X
Tap here to go to the mobile version of the site.

Support Forum

Blank white window

Posted

So I recently updated my Firefox on multiple devices (Windows, Linux, Mac). Recently with the update to 67, periodically when I launch the browser it will just show a blank white page and the address bar just says "search with Google or enter address." I can hit the home button and it takes me to my home page. Other times when I launch Firefox it works without issue and takes me directly to my home page. I have browser.startup.blankWindow set to "false" in "about:config," but issue still randomly occurs. Again, this is multiple computers and multiple OSes all encountering this issue. Yes, some have some add-ons/extensions, but others do not and there doesn't seem to be any pattern that I can discern. Anyone else encountering this? Any fix short of uninstalling/reinstalling Firefox. Worked just fine up through 66 (would prefer not to revert back). -Thanks

So I recently updated my Firefox on multiple devices (Windows, Linux, Mac). Recently with the update to 67, periodically when I launch the browser it will just show a blank white page and the address bar just says "search with Google or enter address." I can hit the home button and it takes me to my home page. Other times when I launch Firefox it works without issue and takes me directly to my home page. I have browser.startup.blankWindow set to "false" in "about:config," but issue still randomly occurs. Again, this is multiple computers and multiple OSes all encountering this issue. Yes, some have some add-ons/extensions, but others do not and there doesn't seem to be any pattern that I can discern. Anyone else encountering this? Any fix short of uninstalling/reinstalling Firefox. Worked just fine up through 66 (would prefer not to revert back). -Thanks

Chosen solution

Hi soupermanmsu, it could be this:

There is a bug in Firefox 67 related to clearing data at shutdown. If you use BOTH of the following features, some of the cleaning may carry over to the beginning of your next session, and that seems to preempt showing a custom home page or external link at startup. A fix should be in Firefox 68, and maybe in an interim update to Firefox 67.

Here is the problem combination:

(1) "Delete cookies and site data when Firefox is closed"

  • set in Preferences > Privacy & Security > Cookies section

  • about:config => network.cookie.lifetimePolicy => 2 (modified)

(2) "Clear history when Firefox closes"

  • set in Preferences > Privacy & Security > History section, with "Firefox will: Use custom settings for history" selected to show detailed options

  • about config => privacy.sanitize.sanitizeOnShutdown => true (modified)

If you set either of those red-boxed preference back to its default value (unchecked), the problem should not occur.

If you do not want to change settings, this should be fixed in Firefox 68, or:

  • for home page problem, you'll have to click the Home button to launch the home page when you get a blank tab at startup
  • for external link problem, you can keep Firefox running, since the problem doesn't occur when adding a new tab once the browser is started
Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

rp108 1 solutions 14 answers

Hi,

I have same problem. I even get blank page when I try to load a very simple, plain vanilla html page that is sitting on my HD. I have posted my question just now. Hope we get an answer.

Regards, rp108

Hi, I have same problem. I even get blank page when I try to load a very simple, plain vanilla html page that is sitting on my HD. I have posted my question just now. Hope we get an answer. Regards, rp108
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8568 solutions 70051 answers

Chosen Solution

Hi soupermanmsu, it could be this:

There is a bug in Firefox 67 related to clearing data at shutdown. If you use BOTH of the following features, some of the cleaning may carry over to the beginning of your next session, and that seems to preempt showing a custom home page or external link at startup. A fix should be in Firefox 68, and maybe in an interim update to Firefox 67.

Here is the problem combination:

(1) "Delete cookies and site data when Firefox is closed"

  • set in Preferences > Privacy & Security > Cookies section

  • about:config => network.cookie.lifetimePolicy => 2 (modified)

(2) "Clear history when Firefox closes"

  • set in Preferences > Privacy & Security > History section, with "Firefox will: Use custom settings for history" selected to show detailed options

  • about config => privacy.sanitize.sanitizeOnShutdown => true (modified)

If you set either of those red-boxed preference back to its default value (unchecked), the problem should not occur.

If you do not want to change settings, this should be fixed in Firefox 68, or:

  • for home page problem, you'll have to click the Home button to launch the home page when you get a blank tab at startup
  • for external link problem, you can keep Firefox running, since the problem doesn't occur when adding a new tab once the browser is started
Hi soupermanmsu, it could be this: There is a bug in Firefox 67 related to clearing data at shutdown. If you use BOTH of the following features, some of the cleaning may carry over to the beginning of your next session, and that seems to preempt showing a custom home page or external link at startup. A fix should be in Firefox 68, and maybe in an interim update to Firefox 67. Here is the problem combination: (1) "Delete cookies and site data when Firefox is closed" * set in Preferences > Privacy & Security > Cookies section<br><br><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-28-15-03-50-21661b.png" width="400"> * '''about:config''' => network.cookie.lifetimePolicy => 2 (modified) (2) "Clear history when Firefox closes" * set in Preferences > Privacy & Security > History section, with "Firefox will: Use custom settings for history" selected to show detailed options<br><br><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-28-15-03-56-8b9d89.png" width="400"> * '''about config''' => privacy.sanitize.sanitizeOnShutdown => true (modified) If you set ''either'' of those red-boxed preference back to its default value (unchecked), the problem should not occur. If you do not want to change settings, this should be fixed in Firefox 68, or: * for home page problem, you'll have to click the Home button to launch the home page when you get a blank tab at startup * for external link problem, you can keep Firefox running, since the problem doesn't occur when adding a new tab once the browser is started
Was this helpful to you? 1
Quote

Question owner

jscher2000, Thank you so much for that explanation. I do indeed have those two settings enabled on my devices. It's just a minor annoyance for now. Here's hoping 68 does fix this. Again, thank you.

jscher2000, Thank you so much for that explanation. I do indeed have those two settings enabled on my devices. It's just a minor annoyance for now. Here's hoping 68 does fix this. Again, thank you.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.