X
Tap here to go to the mobile version of the site.

Support Forum

Cannot sign on to Suntrust Online Banking

Posted

I have not been able to sign on to Suntrust Online Banking for a couple of days. I get error message 'HTTP Status 400 – Bad Request'. I have cleared cache, updated Firefox, restarted browser, rebooted computer.

I can sign onto my account with Chrome and Edge.

I am using Firefox 67.0.1 64-bit under Windows 10.

I contacted Suntrust and they say it is a Firefox issue, not their issue.

I have not been able to sign on to Suntrust Online Banking for a couple of days. I get error message 'HTTP Status 400 – Bad Request'. I have cleared cache, updated Firefox, restarted browser, rebooted computer. I can sign onto my account with Chrome and Edge. I am using Firefox 67.0.1 64-bit under Windows 10. I contacted Suntrust and they say it is a Firefox issue, not their issue.

Chosen solution

Hi raebc, I think that could also be caused by Firefox sending the site cookies it previously set but which it no longer likes for one reason or another. Here's how to clear those:

While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?


You also could try testing in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Chosen Solution

Hi raebc, I think that could also be caused by Firefox sending the site cookies it previously set but which it no longer likes for one reason or another. Here's how to clear those:

While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?


You also could try testing in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi raebc, I think that could also be caused by Firefox sending the site cookies it previously set but which it no longer likes for one reason or another. Here's how to clear those: While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data" * (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data" In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? ---- You also could try testing in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you? 1
Quote
McCoy
  • Top 10 Contributor
491 solutions 4521 answers

Helpful Reply

In addition to the above, please see : https://www.lifewire.com/how-to-fix-a-400-bad-request-error-2617988
Was this helpful to you? 1
Quote

Question owner

Thank you so much for your quick response! The first solution, "Clear Cookies and Site Data" worked!!

Thank you so much for your quick response! The first solution, "Clear Cookies and Site Data" worked!!
Was this helpful to you?
Quote

Question owner

The same solution also worked for an issue I'd been having with the Cox Communications site for MONTHS. Thank you again!

The same solution also worked for an issue I'd been having with the Cox Communications site for MONTHS. Thank you again!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.