X
Tap here to go to the mobile version of the site.

Support Forum

All my extensions stopped today. All are allowed in private windows.

Posted

All my extensions stopped today. All are allowed in private windows, in their extension settings. My FireFox version is "up to date".

The instructions here (https://support.mozilla.org/en-US/kb/extensions-private-browsing?as=u&utm_source=inproduct) therefore don't solve this problem.

I just tried uploading a screenshot showing extension card have private windows "allowed", but upload doesn't complete (a related issue??).

How can I get my extensions working again?

All my extensions stopped today. All are allowed in private windows, in their extension settings. My FireFox version is "up to date". The instructions here (https://support.mozilla.org/en-US/kb/extensions-private-browsing?as=u&utm_source=inproduct) therefore don't solve this problem. I just tried uploading a screenshot showing extension card have private windows "allowed", but upload doesn't complete (a related issue??). How can I get my extensions working again?

Chosen solution

Whuup. Spoke too soon. About 5 min. after restarting FireFox the extensions started working again.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

FredMcD
  • Top 10 Contributor
4146 solutions 57852 answers

Helpful Reply

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

It’s possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder '''Linux: ''' Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Directory. ''' To its right press the button '''Open Directory. ''' Delete all '''extensions*''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons +++++++++++++++++++++++++++ You will have to approve the updating one last time.
Was this helpful to you? 1
Quote

Question owner

That didn't help.

There was one extentions.json file that I deleted, plus compatibility.ini. There were some extension* files (with no S before the filename extension), and I didn't delete those since they didn't match you instructions.

What should try now?

That didn't help. There was one extentions.json file that I deleted, plus compatibility.ini. There were some extension* files (with no S before the filename extension), and I didn't delete those since they didn't match you instructions. What should try now?
Was this helpful to you?
Quote

Chosen Solution

Whuup. Spoke too soon. About 5 min. after restarting FireFox the extensions started working again.

Whuup. Spoke too soon. About 5 min. after restarting FireFox the extensions started working again.
Was this helpful to you?
Quote

Question owner

Thanks for your help.

Thanks for your help.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17266 solutions 156032 answers

Are the extensions still installed in the profile you use if you check this on the about:addons page in case you switched profiles?

Firefox 67 and later can use a dedicated profile for each of the Firefox update channels and will lock the profile, so it can only be used by Firefox in a specific installation folder. For Release versions this profile would be a xxxxxxxx.default-release profile, profiles used in older Firefox versions usually used a xxxxxxxx.default profile (a refresh adds a time stamp). See the about:profiles page for info about registered extensions.

Are the extensions still installed in the profile you use if you check this on the about:addons page in case you switched profiles? Firefox 67 and later can use a dedicated profile for each of the Firefox update channels and will lock the profile, so it can only be used by Firefox in a specific installation folder. For Release versions this profile would be a xxxxxxxx.default-release profile, profiles used in older Firefox versions usually used a xxxxxxxx.default profile (a refresh adds a time stamp). See the <b>about:profiles</b> page for info about registered extensions. *https://support.mozilla.org/en-US/kb/dedicated-profiles-firefox-installation
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17266 solutions 156032 answers

OK, I see that you got it working again a few minutes ago.

OK, I see that you got it working again a few minutes ago.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4146 solutions 57852 answers

SE-Tundra said

Thanks for your help.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

''SE-Tundra [[#answer-1226754|said]]'' <blockquote> Thanks for your help. </blockquote> I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.