X
Tap here to go to the mobile version of the site.

Support Forum

Tabs resetting on their own

Posted

I've been getting tabs resetting when I click on them. This can often lead to a loss of form data and such. What could be causing this? It just started randomly happening when I've navigated to another tab and then come back, sometimes this happens within seconds.

I've been getting tabs resetting when I click on them. This can often lead to a loss of form data and such. What could be causing this? It just started randomly happening when I've navigated to another tab and then come back, sometimes this happens within seconds.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17529 solutions 158489 answers

Firefox will now detect if your computer’s memory is running low, which is defined as lower than 400MB, and suspend unused tabs that you haven’t used or looked at in a while. The new tab unload feature is controlled on the about:config page with a preference that you can set to false to disable this feature.

  • browser.tabs.unloadOnLowMemory = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Firefox will now detect if your computer’s memory is running low, which is defined as lower than 400MB, and suspend unused tabs that you haven’t used or looked at in a while. The new tab unload feature is controlled on the about:config page with a preference that you can set to false to disable this feature. *browser.tabs.unloadOnLowMemory = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config ---- *http://www.ghacks.net/2019/03/01/firefox-67-automatically-unload-unused-tabs-to-improve-memory/ *https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Helpful Reply

Hello FireFoxFan1,

This sounds like one of the new features that came with the update to Firefox 67.0 :

See under "New" - suspending unused tabs

And also :

https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/

See especially the section :

Suspend Idle Tabs: You shouldn’t feel guilty about opening a zillion tabs, but keeping all those tabs open uses your computer’s memory and slows down its performance. Firefox will now detect if your computer’s memory is running low, which we define as lower than 400MB, and suspend unused tabs that you haven’t used or looked at in a while. Rest assured if you decide you want to review that webpage, simply click on the tab, and it will reload where you left off.

If you want to disable this feature :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.tabs.unloadOnLowMemory

and set its value to false

Then close and restart Firefox.

Hello FireFoxFan1, This sounds like one of the new features that came with the update to Firefox 67.0 : [https://www.mozilla.org/en-US/firefox/67.0/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew See under "New" - suspending unused tabs] And also : https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/ See especially the section : ''Suspend Idle Tabs: You shouldn’t feel guilty about opening a zillion tabs, but keeping all those tabs open uses your computer’s memory and slows down its performance. Firefox will now detect if your computer’s memory is running low, which we define as lower than 400MB, and suspend unused tabs that you haven’t used or looked at in a while. Rest assured if you decide you want to review that webpage, simply click on the tab, and it will reload where you left off.'' If you want to disable this feature : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''browser.tabs.unloadOnLowMemory''' and set its value to '''false''' Then close and restart Firefox.
Was this helpful to you? 1
Quote
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Cor-el and I posted at the same time ......

Cor-el and I posted at the same time ......
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.