X
Tap here to go to the mobile version of the site.

Support Forum

startpage does not come up and also not new webpage

Posted

In homepage under options I have set changed URL for Google, but I get only a blank page. Also a new page is blank instead under options is shown that there should open the Firefox start page. Please answer me in Dutch, but simple English is also right.

In homepage under options I have set changed URL for Google, but I get only a blank page. Also a new page is blank instead under options is shown that there should open the Firefox start page. Please answer me in Dutch, but simple English is also right.
Quote

Additional System Details

Installed Plug-ins

None

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

Question owner

Is this what you mean? And if yes, what do I have to do? I'm not a programmer, just a user.

Is this what you mean? And if yes, what do I have to do? I'm not a programmer, just a user.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
525 solutions 4913 answers

Jessica1950 said

Is this what you mean? And if yes, what do I have to do? I'm not a programmer, just a user.

You don't have to do anything, don't worry.

Cor-el just wanted to see if your new tab page was enabled ....

News : Yet another user reported the same problem with the homepage not opening at startup. I am more and more convinced that this "homepage soap" is a Firefox 67.0 bug.

''Jessica1950 [[#answer-1225889|said]]'' <blockquote> Is this what you mean? And if yes, what do I have to do? I'm not a programmer, just a user. </blockquote> You don't have to do anything, don't worry. Cor-el just wanted to see if your new tab page was enabled .... News : Yet another user reported the same problem with the homepage not opening at startup. I am more and more convinced that this "homepage soap" is a Firefox 67.0 bug.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157447 answers

The prefs that show in the screenshot look OK.

A notice the browser.newtabpage.blocked pref. This prefs stores websites you have removed by clicking Dismiss (X) in the '...' menu of a tile on the new tab page. If you do or have done this frequently then the value of this pref can become quite large. You can check this by hovering the mouse on the value field. If you want to cleanup the list then right-click -> Reset.

Do you get the Firefox Home page with the tiles if you open this page directly?

  • about:newtab or about:home
The prefs that show in the screenshot look OK. A notice the browser.newtabpage.blocked pref. This prefs stores websites you have removed by clicking Dismiss (X) in the '...' menu of a tile on the new tab page. If you do or have done this frequently then the value of this pref can become quite large. You can check this by hovering the mouse on the value field. If you want to cleanup the list then right-click -> Reset. Do you get the Firefox Home page with the tiles if you open this page directly? * about:newtab or about:home
Was this helpful to you?
Quote

Question owner

@ McCoy: Van de uitleg van Cor-El snap ik dus niks; dit gaat boven m'n petje.

@ McCoy: Van de uitleg van Cor-El snap ik dus niks; dit gaat boven m'n petje.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
525 solutions 4913 answers

Jessica1950 said

@ McCoy: Van de uitleg van Cor-El snap ik dus niks; dit gaat boven m'n petje.

Kunt U cor-el (in het Engels) duidelijk maken dat Uw probleem niet de nieuwe tabblad pagina is, maar dezelfde is als dat van de anderen die inmiddels gerapporteerd hebben : het feit dat de startpagina niet meer de home pagina (in Uw geval : Google) toont, maar een blanko pagina, die dus lijkt op de nieuwe tabblad pagina (blank, zonder top sites)  ?

Mocht dit tóch een beetje lastig zijn, dan kunt U wellicht "Google Translate" gebruiken :

https://translate.google.com

Overigens heb ik cor-el een paar uur geleden één en ander uitgelegd in een privé bericht .....

''Jessica1950 [[#answer-1225915|said]]'' <blockquote> @ McCoy: Van de uitleg van Cor-El snap ik dus niks; dit gaat boven m'n petje. </blockquote> Kunt U cor-el (in het Engels) duidelijk maken dat Uw probleem niet de nieuwe tabblad pagina is, maar dezelfde is als dat van de anderen die inmiddels gerapporteerd hebben : het feit dat de startpagina niet meer de home pagina (in Uw geval : Google) toont, maar een blanko pagina, die dus lijkt op de nieuwe tabblad pagina (blank, zonder top sites) ? Mocht dit tóch een beetje lastig zijn, dan kunt U wellicht "Google Translate" gebruiken : https://translate.google.com Overigens heb ik cor-el een paar uur geleden één en ander uitgelegd in een privé bericht .....
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8642 solutions 70717 answers

McCoy said

To tell you the truth : I'm rather hoping that we will get more reports like this, and that somebody will file a bug report.

Wishes really do come true? There were many bug reports filed in recent days. Some key factors users and developers have identified are as follows, but there could be other causes that haven't bubbled up:

Custom home page not shown with this combination of settings:

(1) "Delete cookies and site data when Firefox is closed"

  • set in Options > Privacy & Security > Cookies section

  • about:config => network.cookie.lifetimePolicy => 2 (modified)

(2) "Clear history when Firefox closes"

  • set in Options > Privacy & Security > History section, with "Firefox will: Use custom settings for history" selected to show detailed options

  • about config => privacy.sanitize.sanitizeOnShutdown => true (modified)

If either of those has its default value, the problem does not occur, they need to both be set to cause the problem. Note for anyone testing it: the custom home page may load on the first restart, it stops loading on the second and later restarts.

I think some kind of fix is in development (bug 1554167; dupes: 1554747, 1553239).

''McCoy [[#answer-1225727|said]]'' <blockquote> To tell you the truth : I'm rather hoping that we will get more reports like this, and that somebody will file a bug report. </blockquote> Wishes really do come true? There were many bug reports filed in recent days. Some key factors users and developers have identified are as follows, but there could be other causes that haven't bubbled up: '''Custom home page not shown with this ''combination'' of settings:''' (1) "Delete cookies and site data when Firefox is closed" * set in Options > Privacy & Security > Cookies section<br><br><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-28-15-03-50-21661b.png" width="400"> * '''about:config''' => network.cookie.lifetimePolicy => 2 (modified) (2) "Clear history when Firefox closes" * set in Options > Privacy & Security > History section, with "Firefox will: Use custom settings for history" selected to show detailed options<br><br><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-28-15-03-56-8b9d89.png" width="400"> * '''about config''' => privacy.sanitize.sanitizeOnShutdown => true (modified) If ''either'' of those has its default value, the problem does not occur, they need to both be set to cause the problem. Note for anyone testing it: the custom home page may load on the first restart, it stops loading on the second and later restarts. I think some kind of fix is in development (bug 1554167; dupes: 1554747, 1553239).

Modified by jscher2000

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157447 answers

I installed the Dutch language pack.

"Het tandwiel rechts in de werkbalk" is probably there because you dragged this icon to the toolbar via customize, just like the New Private Window mask and the Zoom controls.

Just a short recap.

Your first screenshot shows the tab title as "Nieuw Tabblad" and that implies that the new tab page is opened (I see about:newtab as the title with the new tab page set to a "Lege pagina"). You did confirm that the new tab page opens correctly and that also the Home page is working

What page code do you get if you press Ctrl+U (right-click > Paginabron bekijken) on the blank startup?

The startup setting in done via "Opties -> Algemeen -> Opstarten" For the "Opstarten" page there are currently only two choices and that is the homepage or "Vorige sessie hestellen". There is a pref present on the about:config page to get an empty page (browser.startup.blankWindow = true), so if you get an blank startup page then you can check this pref.

  • browser.startup.blankWindow = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

I installed the Dutch language pack. "Het tandwiel rechts in de werkbalk" is probably there because you dragged this icon to the toolbar via customize, just like the New Private Window mask and the Zoom controls. Just a short recap. Your first screenshot shows the tab title as "Nieuw Tabblad" and that implies that the new tab page is opened (I see about:newtab as the title with the new tab page set to a "Lege pagina"). You did confirm that the new tab page opens correctly and that also the Home page is working What page code do you get if you press Ctrl+U (right-click > Paginabron bekijken) on the blank startup? The startup setting in done via "Opties -> Algemeen -> Opstarten" For the "Opstarten" page there are currently only two choices and that is the homepage or "Vorige sessie hestellen". There is a pref present on the <b>about:config</b> page to get an empty page (browser.startup.blankWindow = true), so if you get an blank startup page then you can check this pref. *browser.startup.blankWindow = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you?
Quote

Question owner

These are my settings. And as I mailed earlier: I can use a pc not program it.

Further I think it's very important (special for me on my age) that we all use the same names for the procedure. Start-up or Home page is the first page after starting MF. New page is the second or more pages, which is mostly MF search on web.

I still think there is a bug in te software; excuse me for wrong English words.

These are my settings. And as I mailed earlier: I can use a pc not program it. Further I think it's very important (special for me on my age) that we all use the same names for the procedure. Start-up or Home page is the first page after starting MF. New page is the second or more pages, which is mostly MF search on web. I still think there is a bug in te software; excuse me for wrong English words.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
525 solutions 4913 answers

Hello Jessica,

I was determined to stay out of this, but can't help myself ....

In jscher2000's post you'll see two preferences that you will find on the "about:config" page - and jscher2000 says :

"If either of those has its default value, the problem does not
occur" .....

So, would you please go to the about:config page (you know the drill by now) and check the values of these two preferences :

privacy.sanitize.sanitizeOnShutdown (default = false)

network.cookie.lifetimePolicy (default value = 0)


Heel even vlug een summiere vertaling van het belangrijkste (voor het geval het niet duidelijk is) :

Als één van deze twee de standaard-waarde heeft, dan zou het probleem niet moeten optreden ......

Hello Jessica, I was determined to stay out of this, but can't help myself .... In jscher2000's post you'll see two preferences that you will find on the "about:config" page - and jscher2000 says : "If either of those has its default value, the problem does not <BR>occur" ..... So, would you please go to the '''about:config''' page (you know the drill by now) and check the values of these two preferences : '''privacy.sanitize.sanitizeOnShutdown''' (default = false) '''network.cookie.lifetimePolicy''' (default value = 0) ------------------------------------------------------------------------------------------- Heel even vlug een summiere vertaling van het belangrijkste (voor het geval het niet duidelijk is) : Als één van deze twee de standaard-waarde heeft, dan zou het probleem niet moeten optreden ......
Was this helpful to you?
Quote

Question owner

@ McCoy: So, would you please go to the about:config page (you know the drill by now) and check the values of these two preferences :

privacy.sanitize.sanitizeOnShutdown (default = false) My pc is: privacy.sanitize.sanitizeOnShutdown aangepast boolean true

network.cookie.lifetimePolicy (default value = 0) My pc is: network.cookie.lifetimePolicy aangepast integer 2

Hope this helps.

@ McCoy: So, would you please go to the about:config page (you know the drill by now) and check the values of these two preferences : privacy.sanitize.sanitizeOnShutdown (default = false) My pc is: privacy.sanitize.sanitizeOnShutdown aangepast boolean true network.cookie.lifetimePolicy (default value = 0) My pc is: network.cookie.lifetimePolicy aangepast integer 2 Hope this helps.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
525 solutions 4913 answers

and ...... Bingo  ! I will let jscher2000 tell you what he thinks is best for you to do. (I merely wanted to make sure that you checked those prefs).


Ik laat het verder aan jscher2000 over om te zeggen wat U nu moet doen. (ik wilde alleen maar even zeker weten dat U die twee prefs zou checken)

Goed gedaan, hoor  !

and ...... Bingo ! I will let jscher2000 tell you what he thinks is best for you to do. (I merely wanted to make sure that you checked those prefs). ---------------------------------------------------------------------------------------------- Ik laat het verder aan jscher2000 over om te zeggen wat U nu moet doen. (ik wilde alleen maar even zeker weten dat U die twee prefs zou checken) Goed gedaan, hoor !
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8642 solutions 70717 answers

Hi Jessica1950, you have two options, I think:

(1) Turn off one of those data clearing features (2) Wait for a fix

Hi Jessica1950, you have two options, I think: (1) Turn off one of those data clearing features (2) Wait for a fix
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
525 solutions 4913 answers

M.a.w. : verander één van de twee pref-waardes (kies zelf welke van de twee), óf wacht tot het rechtgezet is.

Tenzij U het heel erg vervelend vindt om steeds op de "Home" button te moeten clicken om de Google pagina te krijgen - ik zou rustig wachten, want er wordt heel hard aan gewerkt :

https://bugzilla.mozilla.org/show_bug.cgi?id=1554167

M.a.w. : verander één van de twee pref-waardes (kies zelf welke van de twee), óf wacht tot het rechtgezet is. Tenzij U het heel erg vervelend vindt om steeds op de "Home" button te moeten clicken om de Google pagina te krijgen - ik zou rustig wachten, want er wordt heel hard aan gewerkt : https://bugzilla.mozilla.org/show_bug.cgi?id=1554167
Was this helpful to you?
Quote

Question owner

Finally I'm happy; I did nothing wrong, but that there was a "giant" bug. I'll wait for the fix. Thanks to everyone who has made investigations and has commented on my question.

Finally I'm happy; I did nothing wrong, but that there was a "giant" bug. I'll wait for the fix. Thanks to everyone who has made investigations and has commented on my question.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157447 answers

What items are you removing via "Geschiedenis wissen zodra Firefox sluit" ? It is normally not necessary to remove data this way apart from the disk cache.

What items are you removing via "Geschiedenis wissen zodra Firefox sluit" ? It is normally not necessary to remove data this way apart from the disk cache.
Was this helpful to you?
Quote

Question owner

I really don't know, but it's an option; so I have chosen it. In dont't want anyonde to see what I do on the internet and so I have also placed a mark on clean history when closing MF. I suppose it removes last visited websites and I do that once a 3 months.

I really don't know, but it's an option; so I have chosen it. In dont't want anyonde to see what I do on the internet and so I have also placed a mark on clean history when closing MF. I suppose it removes last visited websites and I do that once a 3 months.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
525 solutions 4913 answers

Dear Jessica,

Would you (just for now, as a test) uncheck it and see if that will make your homepage (Google) appear at startup, like it used to ?

It will help the people who are working on this bug, you see.

Dear Jessica, Would you (just for now, as a test) uncheck it and see if that will make your homepage (Google) appear at startup, like it used to ? It will help the people who are working on this bug, you see.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
525 solutions 4913 answers

Today these two people reported that their problem is solved (and what they did to solve it) :

https://support.mozilla.org/en-US/questions/1260215

https://support.mozilla.org/en-US/questions/1260428

Today these two people reported that their problem is solved (and what they did to solve it) : https://support.mozilla.org/en-US/questions/1260215 https://support.mozilla.org/en-US/questions/1260428
Was this helpful to you?
Quote

Question owner

Yes McCoy that works, but I still want to clear the history. Since clear history is an option in MFF, I like to use all options in the future. I hope the bugfix will appear very soon. Thanks again.

Yes McCoy that works, but I still want to clear the history. Since clear history is an option in MFF, I like to use all options in the future. I hope the bugfix will appear very soon. Thanks again.
Was this helpful to you?
Quote

Question owner

Now I got update 67.0.1 (for 64bits) but the problem for startpage is not solved. The new page is standard FF; so that's ok. Why does FF not read these pages and solve this "problem"?

Now I got update 67.0.1 (for 64bits) but the problem for startpage is not solved. The new page is standard FF; so that's ok. Why does FF not read these pages and solve this "problem"?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.