X
Tap here to go to the mobile version of the site.

Support Forum

Firefox will not download images to save as JPEG- Only save All Files

Posted

When attempting to save pictures from the internet the only option get is save as all files. I am unable to change my default to JPEG in settings.

When attempting to save pictures from the internet the only option get is save as all files. I am unable to change my default to JPEG in settings.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

TyDraniu
  • Top 25 Contributor
310 solutions 1728 answers

Does it happen on every site or on some specific?

Does it happen on every site or on some specific?
Was this helpful to you?
Quote

Question owner

Every site. I do not have this issue with any other browsers. I even had this problem on my work computer as well. I have reinstalled the browser several times and cleared history and cache.

Every site. I do not have this issue with any other browsers. I even had this problem on my work computer as well. I have reinstalled the browser several times and cleared history and cache.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157362 answers

When "All files" is selected then you will have to add the correct file extension yourself to make the OS recognize the file properly.

You can inspect the MIME database key with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F. Be cautious with editing the registry as there is NO UNDO possible: all changes are applied immediately. You can export key(s) in the registry editor before making changes. You can check specific file extension keys (e.g. .jpg) in the registry with the registry editor.

  • HKEY_CLASSES_ROOT\.xxx

You can check a possibly linked MIME type in the MIME Database registry key.

  • HKEY_CLASSES_ROOT\MIME\Database\Content Type\
When "All files" is selected then you will have to add the correct file extension yourself to make the OS recognize the file properly. You can inspect the MIME database key with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F. Be cautious with editing the registry as there is NO UNDO possible: all changes are applied immediately. You can export key(s) in the registry editor before making changes. You can check specific file extension keys (e.g. .jpg) in the registry with the registry editor. * HKEY_CLASSES_ROOT\.xxx You can check a possibly linked MIME type in the MIME Database registry key. * HKEY_CLASSES_ROOT\MIME\Database\Content Type\
Was this helpful to you? 0
Quote

Question owner

This seems very complicated and advanced for my skill set. Is there a step by step process to fix this. I got as far as opening up the regedit and ctrl f and searched "MIME "then I am not sure what to do next. I would send you a screen shot but the screen shot extension does not work as well on firefox browser. I tried several an none work.

This seems very complicated and advanced for my skill set. Is there a step by step process to fix this. I got as far as opening up the regedit and ctrl f and searched "MIME "then I am not sure what to do next. I would send you a screen shot but the screen shot extension does not work as well on firefox browser. I tried several an none work.
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
56 solutions 705 answers

Hi poex,

The All Files option retains the file in it's original file type.

Firefox doesn't afford the option to convert a file type (e.g. save a .png as a .jpg.)

Hope this helps.

Hi poex, The All Files option retains the file in it's original file type. Firefox doesn't afford the option to convert a file type (e.g. save a .png as a .jpg.) Hope this helps.
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.