Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have set Firefox as my default browser, but Yahoo keeps coming up. How do I disable Yahoo and enable Firefox as my default browser?

  • 12 replies
  • 1 has this problem
  • 2691 views
  • Last reply by avatar2

more options

I have set Firefox as my default browser in my Apple preferences, and Firefox preferences, by Yahoo continues to pop up. Please let me know how I can disable Yahoo once and for all and have Firefox be my designated browser. Thanks, Terri

Chosen solution

Firefox is a browser and Yahoo is a search engine. Firefox is still your internet browser, but obviously the search settings in Firefox are set to use Yahoo.

You can Change your default search settings in Firefox and can also remove Yahoo from Firefox. Sometimes Yahoo may also be set as your Firefox home page, but you can set a different home page if you so desire.

If you have changed all of the necessary settings and Yahoo keeps being replaced as your default search engine, it's possible that something has hijacked your search settings. For information on what to do in that situation, please refer to Remove a toolbar that has taken over your Firefox search or home page.

Hope this helps.

Read this answer in context 👍 1

All Replies (12)

more options

Chosen Solution

Firefox is a browser and Yahoo is a search engine. Firefox is still your internet browser, but obviously the search settings in Firefox are set to use Yahoo.

You can Change your default search settings in Firefox and can also remove Yahoo from Firefox. Sometimes Yahoo may also be set as your Firefox home page, but you can set a different home page if you so desire.

If you have changed all of the necessary settings and Yahoo keeps being replaced as your default search engine, it's possible that something has hijacked your search settings. For information on what to do in that situation, please refer to Remove a toolbar that has taken over your Firefox search or home page.

Hope this helps.

more options

Firefox from www.mozilla.org and www.mozilla.org/firefox/all/ has hascompletely removed all of Yahoo search engine ever since Firefox 57.0 and later.

So something else is adding in the Yahoo search engine or changing your Homepage.

What Extensions do you have installed in Firefox?

more options

Thank you for your feedback.

When I clicked on Firefox Preferences and clicked Extensions a window popped up with this message: You don't have any add-ons of this type installed.

Thoughts?

Terri

more options

terrialbanese said

I have set Firefox as my default browser in my Apple preferences, and Firefox preferences, by Yahoo continues to pop up. Please let me know how I can disable Yahoo once and for all and have Firefox be my designated browser. Thanks, Terri

Thanks so much, Wesley. Your suggestion to set a new home page worked. I truly appreciate the time you took to provide me with a solution. Terri

more options

No problem. The homepage was likely just changed by another program then. Sometimes other programs have some fine print checkboxes that allow them to change the homepage.

Glad I could help!

more options

I have a similar problem. However, even though Firefox is my default browser, all I get is Yahoo. I have tried the Mozilla URL but all I get is the support page.

Originally, many years ago I set Yahoo up as my home page. But now I would like to use Firefox as my true default browser and Home Page too. And still keep Yahoo as another home page.

Is that even a possibility? I've been looking through your info for several days and nothing I have asked has ever been addressed in all the many FAQs I have read.

more options

Firefox is your internet browser, regardless of what home page you are using. You can set the home page to be Yahoo if you want. See How to set the home page.

If you want to set multiple pages to open when Firefox starts, separate each one with a pipe | character.

However, I think you are probably getting a "homepage" confused with a "search engine". You can set Yahoo as your default search engine and/or your homepage. See Change your default search settings in Firefox.

Hope this helps.

more options

Wesley Branton said

Firefox is your internet browser, regardless of what home page you are using. You can set the home page to be Yahoo if you want. See How to set the home page. If you want to set multiple pages to open when Firefox starts, separate each one with a pipe | character. However, I think you are probably getting a "homepage" confused with a "search engine". You can set Yahoo as your default search engine and/or your homepage. See Change your default search settings in Firefox. Hope this helps.

Thank you Wesley, I have already checked the links provided, several times before.

However, as indicated in my first post. I already have Yahoo as my home page.

I want to set up Firefox as MY homepage.

And afterwards, set up Yahoo as my home page too. So that's why I asked if it is possible to have 2 home pages.

I'm trying to get rid of Yahoo as my "search engine"

Thank you.

more options

Wesley Branton said

If you want to set multiple pages to open when Firefox starts, separate each one with a pipe | character.
more options

Thank you.

And, HOW do I set up Firefox as MY home page?? When Yahoo is all that comes up when I get online??

more options

Are you referring to Firefox Home, like the page used for new tabs?

If you want just Firefox Home to display without Yahoo, you can change the homepage option from Custom URLs to Firefox Home.

if you want Firefox Home to display along with Yahoo, simply add | about:home to your list of homepages.

Hope this helps.

more options

Wesley Branton said

Are you referring to Firefox Home, like the page used for new tabs? If you want just Firefox Home to display without Yahoo, you can change the homepage option from Custom URLs to Firefox Home. if you want Firefox Home to display along with Yahoo, simply add | about:home to your list of homepages. Hope this helps.

Thank you for the message, Wesley, my apologies for the late reply. That is exactly what I was looking for!

Thank you again, I really appreciate your help. Best :)