X
Tap here to go to the mobile version of the site.

Support Forum

Youtube will NOT autoplay if I am in another tab.

Posted

I've tried all the fixes that I have read online. Added exception for youtube and unchecked the block feature in 'permissions'. None of it works. It's really frustrating having to go back to youtube every time a video ends and a new 'tries' to start. I don't want to leave Firefox as I have been using FF for well over a decade but I will if I can't find a solution to this. I work online and it's a pain in my rear to constantly click out of my window to keep the music flowing.

I've tried all the fixes that I have read online. Added exception for youtube and unchecked the block feature in 'permissions'. None of it works. It's really frustrating having to go back to youtube every time a video ends and a new 'tries' to start. I don't want to leave Firefox as I have been using FF for well over a decade but I will if I can't find a solution to this. I work online and it's a pain in my rear to constantly click out of my window to keep the music flowing.

Chosen solution

Do you see the auto-play icon in the location bar? If you click this icon then you can possibly create an allow exception for the https://youtube.com website.

I would assume that YouTube would auto-play with these settings. If this is only about one YouTube tab then try to tear of this tab and move it to a separate window, so this tab can be visible all the time.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17267 solutions 156041 answers

You can look at this pref on the about:config page.

  • media.block-autoplay-until-in-foreground = false
  • media.autoplay.default = 1 [0:Allowed; 1:Blocked 2:Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false | true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


You can look at this pref on the about:config page. *media.block-autoplay-until-in-foreground = false *media.autoplay.default = 1 [0:Allowed; 1:Blocked 2:Prompt] *media.autoplay.allow-muted = false *media.autoplay.enabled.user-gestures-needed = false | true You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config ---- *https://support.mozilla.org/en-US/kb/block-autoplay
Was this helpful to you?
Quote

Question owner

Thank you for your prompt reply. I've been trying what you said but I'm really a tech illiterate. Here is my config page as of now.

   media.block-autoplay-until-in-foreground = false 
   media.autoplay. integer 0
   media.autoplay.allow-muted = true
   media.autoplay.enabled.user-gestures-needed = false 

But it still is not working unfortunately. I've restarted FF several times. Maybe there is something I've missed that will appear obvious to someone of greater familiarity with this issue. Thank you so much again for your reply.

Thank you for your prompt reply. I've been trying what you said but I'm really a tech illiterate. Here is my config page as of now. media.block-autoplay-until-in-foreground = false media.autoplay. integer 0 media.autoplay.allow-muted = true media.autoplay.enabled.user-gestures-needed = false But it still is not working unfortunately. I've restarted FF several times. Maybe there is something I've missed that will appear obvious to someone of greater familiarity with this issue. Thank you so much again for your reply.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17267 solutions 156041 answers

Chosen Solution

Do you see the auto-play icon in the location bar? If you click this icon then you can possibly create an allow exception for the https://youtube.com website.

I would assume that YouTube would auto-play with these settings. If this is only about one YouTube tab then try to tear of this tab and move it to a separate window, so this tab can be visible all the time.

Do you see the auto-play icon in the location bar? If you click this icon then you can possibly create an allow exception for the https://youtube.com website. I would assume that YouTube would auto-play with these settings. If this is only about one YouTube tab then try to tear of this tab and move it to a separate window, so this tab can be visible all the time.
Was this helpful to you? 1
Quote

Question owner

The other stuff didn't work still but opening a new window did the trick. Thank you for your help. ))

The other stuff didn't work still but opening a new window did the trick. Thank you for your help. ))
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.