Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 66.0.5 on linux reports problem with website certificate

more options

On my website: https://scope-communications.com/

Firefox 66.0.5 on linux reports problem with website certificate. On any other browser, and operating system everything is fine. How come?

Chosen solution

See attachments at the bottom to get this certificate:

Do not set any trust bits when prompted. Trust bits are only required for root certificates (end of the trust chain).

Read this answer in context 👍 1

All Replies (8)

more options

I had no problem with the link.

Please explain the problem in detail. What happens? What is the exact error messages?


Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version 32.0.0171

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

There is an incomplete chain problem. https://www.ssllabs.com/ssltest/analyze.html?d=scope-communications.com

Firefox requires websites to send not just their own site certificate, but any intermediate certificates required to provide a complete chain up to the trusted root certificates that come with Firefox, and which are stored in the cert9.db file. Over time, Firefox adds intermediate certificates that check out to the cert9.db file, so if a website has forgotten to send it, Firefox can fill the gap. However, if your Firefox is encountering that missing certificate for the first time -- first time after installation, or removal of the cert9.db file, or using Firefox Refresh, or launching a new profile -- you'll get an error.

If you are the webmaster, COMODO has a bundle file that goes in the same folder as your site certificate. Or if you bought the cert from your hosting provider, usually they will fix it for you.

more options

jscher2000 said

There is an incomplete chain problem. https://www.ssllabs.com/ssltest/analyze.html?d=scope-communications.com Firefox requires websites to send not just their own site certificate, but any intermediate certificates required to provide a complete chain up to the trusted root certificates that come with Firefox, and which are stored in the cert9.db file. Over time, Firefox adds intermediate certificates that check out to the cert9.db file, so if a website has forgotten to send it, Firefox can fill the gap. However, if your Firefox is encountering that missing certificate for the first time -- first time after installation, or removal of the cert9.db file, or using Firefox Refresh, or launching a new profile -- you'll get an error. If you are the webmaster, COMODO has a bundle file that goes in the same folder as your site certificate. Or if you bought the cert from your hosting provider, usually they will fix it for you.

What bothers me is that the same version of Firefox in windows reports no problem while in Linux Mint (Tara) I get a "Warning: Potential Security Risk Ahead" screen. I get this only of Firefox 66.0.5 on linux. All others, even first time visitors of my site get no warnings.

more options

Click the Advanced button on the warning page and check, if the certificate issuer is the same as on Windows (when clicking on the green lock in the url bar).

more options

TyDraniu said

Click the Advanced button on the warning page and check, if the certificate issuer is the same as on Windows (when clicking on the green lock in the url bar).

Yeap! Exectly the same details. I think this must be a bug of the linux version of the browser.

more options

Firefox caches intermediate certificates send by a server, so if you do not see this error message then it is likely that you have the certificate.

You can try to export and delete this specific intermediate certificate in the Certificate Manager to test this.

  • Options/Preferences -> Privacy & Security
    Certificates: View Certificates
  • COMODO RSA Domain Validation Secure Server CA (Software Security Device).

You may have to close and restart Firefox after removing this certificate in case it is still cached.

Modified by cor-el

more options

Chosen Solution

See attachments at the bottom to get this certificate:

Do not set any trust bits when prompted. Trust bits are only required for root certificates (end of the trust chain).

more options

cor-el said

See attachments at the bottom to get this certificate: Do not set any trust bits when prompted. Trust bits are only required for root certificates (end of the trust chain).

It worked! I have deleted the "COMODO RSA Domain Validation Secure Server CA (Software Security Device). " certificate, restarted firefox and I no longer get that insecure warning.

A great thank you!