X
Tap here to go to the mobile version of the site.

Support Forum

Windows Authentication login box doesn't go away after authentication

Posted

I have developed an Intranet application that uses Windows Authentication. It works correctly in IE, Edge and Chrome. It does the windows authentication properly in Firefox. The only problem is that the login box is displayed, the application loads properly in the background and if you hit Cancel from the login box it goes away until you restart Firefox and there it is again! I have tried all the answers about adding my sites to the trusted uris in the about:config app. To make things even more weird, on my development machine, the login box does not show up, which is the desired behavior. As far as I know, I have duplicated all the appropriate settings to a client machine, but the login box still appears. What am I missing?

I have developed an Intranet application that uses Windows Authentication. It works correctly in IE, Edge and Chrome. It does the windows authentication properly in Firefox. The only problem is that the login box is displayed, the application loads properly in the background and if you hit Cancel from the login box it goes away until you restart Firefox and there it is again! I have tried all the answers about adding my sites to the trusted uris in the about:config app. To make things even more weird, on my development machine, the login box does not show up, which is the desired behavior. As far as I know, I have duplicated all the appropriate settings to a client machine, but the login box still appears. What am I missing?

Chosen solution

DragonDeveloper said

After reviewing the Network Monitor tab, our Corporate Logo is returning a 401 status and does not appear on the web page on my users machines. However, it does not return a 401 from my development machine and it servers up the image correctly. I am calling this web page from the same IIS server in both cases. How do I resolve the 401 error on my client's machines?

Is the Logo on the same host as the app pages, or on a different host that is also listed in the preference we were discussing earlier?

Read this answer in context 0
Quote

Additional System Details

Application

  • Firefox 66.0.5
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0
  • Support URL: https://support.mozilla.org/1/firefox/66.0.5/WINNT/en-US/

Extensions

  • hotfix-update-xpi-intermediate 1.0.6 (hotfix-update-xpi-intermediate@mozilla.com)
  • LastPass: Free Password Manager 4.27.2.10 (support@lastpass.com)
  • Show MyIP 0.93.1-signed.1-signed ({6D1D11DB-3C6C-4db8-96E4-20F4A1088AAC}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon(TM) R5 340X
  • adapterDescription2:
  • adapterDeviceID: 0x6610
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 00831028
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • contentUsesTiling: False
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.17763.168
  • driverDate: 12-7-2017
  • driverDate2:
  • driverVersion: 23.20.806.256
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'available', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'GPU_PROCESS'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Not Nvidia', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}, {u'status': u'available', u'description': u'Advanced Layers', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'ADVANCED_LAYERS'}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'ApzAutoscrollInput': 1, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • lowEndMachine: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 4
  • targetFrameRate: 60
  • usesTiling: False
  • webgl1DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_explicit_context GL_ANGLE_explicit_context_gles1 GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_KHR_parallel_shader_compile GL_KHR_robust_buffer_access_behavior GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object OES_compressed_EAC_R11_signed_texture OES_compressed_EAC_R11_unsigned_texture OES_compressed_EAC_RG11_signed_texture OES_compressed_EAC_RG11_unsigned_texture OES_compressed_ETC2_RGB8_texture OES_compressed_ETC2_RGBA8_texture OES_compressed_ETC2_punchthroughA_RGBA8_texture OES_compressed_ETC2_punchthroughA_sRGB8_alpha_texture OES_compressed_ETC2_sRGB8_alpha8_texture OES_compressed_ETC2_sRGB8_texture
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Google Inc. -- ANGLE (AMD Radeon(TM) R5 340X Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.eff6bfdb1db9)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000009330) EGL_VERSION: 1.4 (ANGLE 2.1.0.eff6bfdb1db9) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_CHROMIUM_sync_control EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization EGL_ANGLE_create_context_extensions_enabled EGL_MOZ_create_context_provoking_vertex_dont_care EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses EGL_KHR_debug EGL_ANGLE_explicit_context
  • webgl2DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_explicit_context GL_ANGLE_explicit_context_gles1 GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_multiview GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_KHR_parallel_shader_compile GL_KHR_robust_buffer_access_behavior GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object OES_compressed_EAC_R11_signed_texture OES_compressed_EAC_R11_unsigned_texture OES_compressed_EAC_RG11_signed_texture OES_compressed_EAC_RG11_unsigned_texture OES_compressed_ETC2_RGB8_texture OES_compressed_ETC2_RGBA8_texture OES_compressed_ETC2_punchthroughA_RGBA8_texture OES_compressed_ETC2_punchthroughA_sRGB8_alpha_texture OES_compressed_ETC2_sRGB8_alpha8_texture OES_compressed_ETC2_sRGB8_texture
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: Google Inc. -- ANGLE (AMD Radeon(TM) R5 340X Direct3D11 vs_5_0 ps_5_0)
  • webgl2Version: OpenGL ES 3.0 (ANGLE 2.1.0.eff6bfdb1db9)
  • webgl2WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000009330) EGL_VERSION: 1.4 (ANGLE 2.1.0.eff6bfdb1db9) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_CHROMIUM_sync_control EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization EGL_ANGLE_create_context_extensions_enabled EGL_MOZ_create_context_provoking_vertex_dont_care EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses EGL_KHR_debug EGL_ANGLE_explicit_context
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11
  • windowUsingAdvancedLayers: True

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Jeremy Sanders 3 solutions 31 answers

What version of FF are you running?

What version of FF are you running?
Was this helpful to you?
Quote

Question owner

I am running Firefox 66.0.5 (64-bit)

I am running Firefox 66.0.5 (64-bit)
Was this helpful to you?
Quote
Jeremy Sanders 3 solutions 31 answers

Are you using simplified login to access the intranet? And is it enabled?

Are you using simplified login to access the intranet? And is it enabled?
Was this helpful to you?
Quote

Question owner

Not sure what you mean by simplified login but I am using Windows Authentication. It is enabled on my IIS Server. Are there settings in Firefox, I should set?

The Authentication works, its just that the credentials login box still appears. I can hit Cancel and it goes away but I would like the box not to appear at all, as the user has been authenticated.

Not sure what you mean by simplified login but I am using Windows Authentication. It is enabled on my IIS Server. Are there settings in Firefox, I should set? The Authentication works, its just that the credentials login box still appears. I can hit Cancel and it goes away but I would like the box not to appear at all, as the user has been authenticated.
Was this helpful to you?
Quote
Jeremy Sanders 3 solutions 31 answers
Have you taken a look at this article? https://support.mozilla.org/en-US/kb/fix-login-issues-on-websites-require-passwords
Was this helpful to you? 0
Quote

Question owner

I tried the suggestions in the article you sent but to no avail.

As I mentioned before, there is no problem with the authentication, the login box just doesn't go away.

I forgot to mention previously, that this is an intranet application, not an internet application.

I tried the suggestions in the article you sent but to no avail. As I mentioned before, there is no problem with the authentication, the login box just doesn't go away. I forgot to mention previously, that this is an intranet application, not an internet application.
Was this helpful to you?
Quote

Question owner

Hi Jeremy,

Is there anything else I can do to prevent the dialog box from appearing? I have tried everything you have suggested but the box still appears.

Hi Jeremy, Is there anything else I can do to prevent the dialog box from appearing? I have tried everything you have suggested but the box still appears.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17165 solutions 155163 answers

Did you compare the Network Settings in "Options/Preferences -> General" ?

You can also look at "network.au" prefs on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Did you compare the Network Settings in "Options/Preferences -> General" ? You can also look at "network.au" prefs on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you?
Quote

Question owner

I just checked out the network.au settings and they are correct. As this is working correctly on my personal machine, is there a way I can view just the modified setting from the about:config? There must be some combination that I have set that is making it work the correct way, but when I deploy the application, it is still asking for the login credentials?

I just checked out the network.au settings and they are correct. As this is working correctly on my personal machine, is there a way I can view just the modified setting from the about:config? There must be some combination that I have set that is making it work the correct way, but when I deploy the application, it is still asking for the login credentials?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8425 solutions 68750 answers

I'm late to this thread, but Firefox needs you to list trusted hosts for automatic authentication. See:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste trusted-uris and pause while the list is filtered

(3) The network.automatic-ntlm-auth.trusted-uris preference is for NTLM authentication.

The preference takes only the host name, no protocol, and you separate the host names using commas and no spaces. For example:

intranet,accounting,cal-mkt,itstuff

(4) The network.negotiate-auth.trusted-uris preference is for whatever the next generation of Windows authentication is called.

I'm late to this thread, but Firefox needs you to list trusted hosts for automatic authentication. See: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''trusted-uris''' and pause while the list is filtered (3) The '''network.automatic-ntlm-auth.trusted-uris''' preference is for NTLM authentication. The preference takes only the host name, no protocol, and you separate the host names using commas and no spaces. For example: intranet,accounting,cal-mkt,itstuff (4) The '''network.negotiate-auth.trusted-uris''' preference is for whatever the next generation of Windows authentication is called.
Was this helpful to you?
Quote

Question owner

Hi,

I have already entered my host name in the network.negotiate-auth.trusted-uris preference. It still shows the dialog box. I'm going to recap what is going on and what I have done.

I am trying to deploy my intranet application on FireFox. It uses Windows Integrated Authentication. If the user is an authenticated user, then no credentials dialog box should appear. This behavior currently works in the Edge, Internet Explorer, Safari and Chrome browsers. However, in Firefox , my application is authenticated because it is displayed on the screen, but so does the dialog box that asks for the username and password. I know the application is authenticated because if you hit cancel from the dialog box the application still runs correctly. All I need is to find out which setting will prevent the dialog box from appearing, if the user is authenticated. By the way. on my development machine, Firefox shows the expected behavior, no dialog box.

I have tried all the settings for network.au and the other suggestions in this thread, to no avail.

So at this point, my application runs perfectly in all browsers including FireFox on my development machine. It runs perfectly in all browsers except FireFox on my users machines. A vast majority of my users prefer FireFox and I need to get this issue resolved.

Thanks!

Hi, I have already entered my host name in the network.negotiate-auth.trusted-uris preference. It still shows the dialog box. I'm going to recap what is going on and what I have done. I am trying to deploy my intranet application on FireFox. It uses Windows Integrated Authentication. If the user is an authenticated user, then no credentials dialog box should appear. This behavior currently works in the Edge, Internet Explorer, Safari and Chrome browsers. However, in Firefox , my application is authenticated because it is displayed on the screen, but so does the dialog box that asks for the username and password. I know the application is authenticated because if you hit cancel from the dialog box the application still runs correctly. All I need is to find out which setting will prevent the dialog box from appearing, if the user is authenticated. By the way. on my development machine, Firefox shows the expected behavior, no dialog box. I have tried all the settings for network.au and the other suggestions in this thread, to no avail. So at this point, my application runs perfectly in all browsers including FireFox on my development machine. It runs perfectly in all browsers except FireFox on my users machines. A vast majority of my users prefer FireFox and I need to get this issue resolved. Thanks!
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8425 solutions 68750 answers

If you open the Network Monitor in the tab before loading your intranet app and look at the requests, can you see a 401 related to a different Windows-auth host that could explain the unexpected dialog?

To open the Network Monitor in the lower part of the tab, you can use either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

When you load the next page, Firefox should start listing all the files it is requesting, along with information about whether the request was successful.

More info: https://developer.mozilla.org/docs/Tools/Network_Monitor

If you open the Network Monitor in the tab before loading your intranet app and look at the requests, can you see a 401 related to a different Windows-auth host that could explain the unexpected dialog? To open the Network Monitor in the lower part of the tab, you can use either: * "3-bar" menu button > Web Developer > Network * (menu bar) Tools > Web Developer > Network * (Windows) Ctrl+Shift+e When you load the next page, Firefox should start listing all the files it is requesting, along with information about whether the request was successful. More info: https://developer.mozilla.org/docs/Tools/Network_Monitor
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17165 solutions 155163 answers

Did you check: signon.autologin.proxy ?

Did you check: signon.autologin.proxy ?
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
425 solutions 3786 answers

Hello DRagonDeveloper,

My apologies for butting in - this may have nothing to do with your problem, but your system details show that you (still) have this extension installed :

"hotfix-update-xpi-intermediate 1.0.6 (hotfix-update-xpi-intermediate@mozilla.com) "

As you no longer need it : would you please remove it  ?

Again : this will probably have nothing to do with it, but one never knows - strange things do happen .....

Maybe you could also disable (for now) "LastPass: Free Password Manager", just to see if that will make a difference - probably won't, but (again) : one never knows .....

Hello DRagonDeveloper, My apologies for butting in - this may have nothing to do with your problem, but your system details show that you (still) have this extension installed : "hotfix-update-xpi-intermediate 1.0.6 (hotfix-update-xpi-intermediate@mozilla.com) " As you no longer need it : would you please remove it ? Again : this will probably have nothing to do with it, but one never knows - strange things do happen ..... Maybe you could also disable (for now) "LastPass: Free Password Manager", just to see if that will make a difference - probably won't, but (again) : one never knows .....
Was this helpful to you?
Quote

Question owner

Hi,

I think we are finally getting somewhere! After reviewing the Network Monitor tab, our Corporate Logo is returning a 401 status and does not appear on the web page on my users machines. However, it does not return a 401 from my development machine and it servers up the image correctly. I am calling this web page from the same IIS server in both cases. How do I resolve the 401 error on my client's machines?

Hi, I think we are finally getting somewhere! After reviewing the Network Monitor tab, our Corporate Logo is returning a 401 status and does not appear on the web page on my users machines. However, it does not return a 401 from my development machine and it servers up the image correctly. I am calling this web page from the same IIS server in both cases. How do I resolve the 401 error on my client's machines?
Was this helpful to you?
Quote

Question owner

Hi McCoy,

The LastPass Manager extension was on my development PC and did not affect the issue on my client's pc's. However, thanks for bringing that to my attention, as I don't use LastPass and I have now removed it.

Hi McCoy, The LastPass Manager extension was on my development PC and did not affect the issue on my client's pc's. However, thanks for bringing that to my attention, as I don't use LastPass and I have now removed it.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8425 solutions 68750 answers

Chosen Solution

DragonDeveloper said

After reviewing the Network Monitor tab, our Corporate Logo is returning a 401 status and does not appear on the web page on my users machines. However, it does not return a 401 from my development machine and it servers up the image correctly. I am calling this web page from the same IIS server in both cases. How do I resolve the 401 error on my client's machines?

Is the Logo on the same host as the app pages, or on a different host that is also listed in the preference we were discussing earlier?

''DragonDeveloper [[#answer-1225855|said]]'' <blockquote> After reviewing the Network Monitor tab, our Corporate Logo is returning a 401 status and does not appear on the web page on my users machines. However, it does not return a 401 from my development machine and it servers up the image correctly. I am calling this web page from the same IIS server in both cases. How do I resolve the 401 error on my client's machines? </blockquote> Is the Logo on the same host as the app pages, or on a different host that is also listed in the preference we were discussing earlier?
Was this helpful to you?
Quote

Question owner

Hi jscher2000,

The logo was on the same host but I had it pointing to the wrong directory. Once I corrected the path, everything is working fine in FireFox. Interesting why Edge and IE resolved the path correctly????

I want to thank you for setting me on the right path to debug this issue! Using the Network Monitor proved to be the key in pointing me in the right direction. Thanks so much for helping me out!

Hi jscher2000, The logo was on the same host but I had it pointing to the wrong directory. Once I corrected the path, everything is working fine in FireFox. Interesting why Edge and IE resolved the path correctly???? I want to thank you for setting me on the right path to debug this issue! Using the Network Monitor proved to be the key in pointing me in the right direction. Thanks so much for helping me out!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.