X
Tap here to go to the mobile version of the site.

Support Forum

Windows 10 settings doesn't list firefox as default for pdf files.

Posted

Firefox (fully up to date, v 66.0.5) will not open pdf files using its default reader on either of my 2 desktop PCs (one with W10 Home, other with W10 Pro). I have tried all suggestions I've come across, including setting 'Portable Document Format (PDF)' to 'Preview in Firefox', and, in about:config, I've confirmed that pdfjs.disabled is set to 'false'. Perhaps the best clue, not discussed in any help articles I've viewed so far, is that Windows 10 Settings > 'Choose default applications by files type' lists only Google Chrome (my previous default browser) and Microsoft Edge - no sign of Firefox! if I set the pdf file default to Chrome, then its coloured circular logo appears to the left hand side of all pdf files listed in any folder I've viewed so far in either PC and pdf files are displayed in Chrome; likewise with Edge, its logo appears instead and it opens and displays pdf files. Thank you

Firefox (fully up to date, v 66.0.5) will not open pdf files using its default reader on either of my 2 desktop PCs (one with W10 Home, other with W10 Pro). I have tried all suggestions I've come across, including setting 'Portable Document Format (PDF)' to 'Preview in Firefox', and, in about:config, I've confirmed that pdfjs.disabled is set to 'false'. Perhaps the best clue, not discussed in any help articles I've viewed so far, is that Windows 10 Settings > 'Choose default applications by files type' lists only Google Chrome (my previous default browser) and Microsoft Edge - no sign of Firefox! if I set the pdf file default to Chrome, then its coloured circular logo appears to the left hand side of all pdf files listed in any folder I've viewed so far in either PC and pdf files are displayed in Chrome; likewise with Edge, its logo appears instead and it opens and displays pdf files. Thank you

Chosen solution

Right click on any pdf file Select Properties Where it says Opens With: click Change In the dialog window look for Firefox

If it isn't there - Scroll to the bottom and select More Apps If it isn't in that list Scroll to the bottom and select Look for another app on this PC In the Open With... window double-click Mozilla Firefox Select Firefox and click Open at the bottom

This will set ALL of your pdf files to open with Firefox.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

My_Cheese_Is_Slippin'
  • Top 10 Contributor
39 solutions 452 answers

Chosen Solution

Right click on any pdf file Select Properties Where it says Opens With: click Change In the dialog window look for Firefox

If it isn't there - Scroll to the bottom and select More Apps If it isn't in that list Scroll to the bottom and select Look for another app on this PC In the Open With... window double-click Mozilla Firefox Select Firefox and click Open at the bottom

This will set ALL of your pdf files to open with Firefox.

Right click on any pdf file Select Properties Where it says Opens With: click Change In the dialog window look for Firefox If it isn't there - Scroll to the bottom and select More Apps If it isn't in that list Scroll to the bottom and select Look for another app on this PC In the Open With... window double-click Mozilla Firefox Select Firefox and click Open at the bottom This will set ALL of your pdf files to open with Firefox.
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Hi Trinilad, I don't know if it's normal for Firefox to appear in Windows 10's list of programs that open PDFs. I think we should focus for now on the internal settings issue.

So Firefox is already set to "Preview in Firefox" and it doesn't work for any PDFs anywhere? Or does it work for some and not for others?

If it doesn't work for any PDFs from anywhere, the problem could be corruption in the settings file that stores download handling preferences. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf.

Start Firefox back up again. Any improvement?

Hi Trinilad, I don't know if it's normal for Firefox to appear in Windows 10's list of programs that open PDFs. I think we should focus for now on the internal settings issue. So Firefox is already set to "Preview in Firefox" and it doesn't work for any PDFs anywhere? Or does it work for some and not for others? <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-15-14-12-38-9f2900.png" width="500"> If it doesn't work for any PDFs from anywhere, the problem could be corruption in the settings file that stores download handling preferences. You can rename the file and have Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''handlers.json''' to something like '''handlersOLD.json'''. If you see a file named '''mimeTypes.rdf''', rename that one to '''mimeTypesOLD.rdf'''. Start Firefox back up again. Any improvement?
Was this helpful to you?
Quote

Question owner

Wow, many thanks to 'My_Cheese_Is Slippin. Your solution worked for me on both my Windows 10 PCs. Incidentally, Firefox is now listed in the 'Choose an application' window in W10's Settings on both PCs and all the pdf files in all folders I've checked so far now have the Firefox icon displayed to the left of the file names. Thank again for your prompt and effective reply.

Wow, many thanks to 'My_Cheese_Is Slippin''. Your solution worked for me on both my Windows 10 PCs. Incidentally, Firefox is now listed in the 'Choose an application' window in W10's Settings on both PCs and all the pdf files in all folders I've checked so far now have the Firefox icon displayed to the left of the file names. Thank again for your prompt and effective reply.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.