Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Win10 wont let me set my default PDF viewer to Firefox!

  • 1 reply
  • 5 have this problem
  • 57 views
  • Last reply by Shadow110

more options

I was trying to open and view a saved PDF file just from my desktop and it always opens with Chrome. I want to be able to view my saved PDFs within Firefox! I went to investigate within Windows Control Panel and I find that when I try to set the default app for opening PDF files, Firefox is not even in the list of possible apps. Thinking I can get around this, I decided to see if I can go into "set defaults by app" and again I am met with disappointment as I see that PDF doesn't show in there. What is a fix for this?

I was trying to open and view a saved PDF file just from my desktop and it always opens with Chrome. I want to be able to view my saved PDFs within Firefox! I went to investigate within Windows Control Panel and I find that when I try to set the default app for opening PDF files, Firefox is not even in the list of possible apps. Thinking I can get around this, I decided to see if I can go into "set defaults by app" and again I am met with disappointment as I see that PDF doesn't show in there. What is a fix for this?

Chosen solution

HI, Is PDF not showing as it should be in there like this : https://support.mozilla.org/en-US/kb/applications-panel-set-how-firefox-handles-files

Maybe set Chrome not to open PDF's, reboot.

Windows 10 Settings --> Apps --> Default Apps then at bottom of window you have 3 options : Choose Apps by File Type, Choose Default Apps by Protocol and Set Default by App

You do not mention any other PDF program. Suggest install Adobe PDF Reader DC https://get.adobe.com/reader/ This will force a PDF component into Applications. You may then be able to switch to Firefox. Then can keep or uninstall it.

A clean install with deleting all Mozilla Firefox folders except your Profile and reinstall with a Full Version Installer : https://www.mozilla.org/en-US/firefox/all/

On a separate note see if can update your Video Card Drivers adapterDescription: Intel(R) HD Graphics 620 driverDate: 4-21-2017

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

HI, Is PDF not showing as it should be in there like this : https://support.mozilla.org/en-US/kb/applications-panel-set-how-firefox-handles-files

Maybe set Chrome not to open PDF's, reboot.

Windows 10 Settings --> Apps --> Default Apps then at bottom of window you have 3 options : Choose Apps by File Type, Choose Default Apps by Protocol and Set Default by App

You do not mention any other PDF program. Suggest install Adobe PDF Reader DC https://get.adobe.com/reader/ This will force a PDF component into Applications. You may then be able to switch to Firefox. Then can keep or uninstall it.

A clean install with deleting all Mozilla Firefox folders except your Profile and reinstall with a Full Version Installer : https://www.mozilla.org/en-US/firefox/all/

On a separate note see if can update your Video Card Drivers adapterDescription: Intel(R) HD Graphics 620 driverDate: 4-21-2017