Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

right click automatically selects & clicks first item in popup menu - FF for Mac

  • 10 replies
  • 1 has this problem
  • 13 views
  • Last reply by pulakiii

more options

This is ONLY happening in FF; not in other browsers, nor in Thunderbird or elsewhere in the system... and it happens about 90% of the time when I right click in FF:

When I right-click, the mouse automatically selects and clicks (executes) the first item in the popup menu. If I immediately (like in a split second) move the mouse to the left (away from the popup menu) after the right click, it does not behave this way and I can calmly select what I want in the popup and click on it.

It only happens when the pointer is on top of the menu after I right click - which is natural. But it is automatically executing a click of whatever item is inadvertently selected when the menu pops up.

Using: SYSTEM: MacBook Air running Mohave (happened running Sierra, as well) MOUSE: Logitech M525 /USB and Logitech M535 /Bluetooth FF: 66.0.4 (64bit)

I have turned off the track pad thinking something may be triggered there, to no success.

Any thoughts? Thank you kindly, anyone who has an idea to offer.

-) Cynthia-

All Replies (10)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Thank you so much, Fred, for the input.  :-) I'll try it and let you know.

more options

So far.... Safe Mode seems to eliminate the problem. I am going to continue in safe mode through today and this will tell me definitively.

If this turns out to be the case, then I am guessing that an extension or plugin is creating the problem. I have very few installed - I am a minimalist when it comes to add-ons and only have the following:

Extension: Adobe Acrobat Plugin: OpenH264 Plugin: Widevine Content Decryption by Google Plugin: Shockwave Flash

The only one in here that seems like it might be a problem is Widevine.

Any thoughts?

Thank you again.  : -)

more options

Hi pulakiii, I don't think any of the plugins would be relevant because Safe Mode only disables extensions, not plugins. And Acrobat shouldn't affect pages until you click its toolbar button. So... what does that leave. Firefox's Safe Mode also temporarily deactivates hardware acceleration, any userChrome.css/userContent.css files, and the JavaScript compilers. ???

more options

Hmmmmm. Would I have created the CSS files explicitly or do they exist standard? I have not created any CSS files or done any customizations in that respect. Nor have I installed any javascript compilers.

I DO, on occasion, use the Web Developer ---> Inspector and it is available all the time at the bottom of the window.

more options

Hi pulakiii, Firefox doesn't come with userChrome.css or userContent.css, you would have had to create or install those. The JavaScript compilers are built-in, however, as is hardware acceleration.

If the problem returns when you're done with Safe Mode and restart normally, this article has the steps to disable hardware acceleration: Firefox's performance settings.

more options

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
more options

UPDATE: Still in safe mode and the behavior has returned. It DOES SEEM to be greatly reduced, but....

more options

Let’s do a full clean re-install;

Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.


Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

more options

OK, great! It's worth a try. Thank you kindly, Fred, for the very thorough instructions. I really appreciate it. I'll report back.