X
Tap here to go to the mobile version of the site.

Support Forum

Private Browsing Not Working

Posted

iMac Running OS El Capitan. Firefox Version 66.0.4, 64 bit.

I can't start a private browsing session. Using the mask in the toolbar, it never changes color to indicate it's in Private Browsing Mode. Nor does it indicate so when choosing the Window menu. I can't start a Private session from the File menu either. All worked on a previous version but alas, I had to upgrade my OS and Firefox upgraded as well, which results in the problem I'm having.

iMac Running OS El Capitan. Firefox Version 66.0.4, 64 bit. I can't start a private browsing session. Using the mask in the toolbar, it never changes color to indicate it's in Private Browsing Mode. Nor does it indicate so when choosing the Window menu. I can't start a Private session from the File menu either. All worked on a previous version but alas, I had to upgrade my OS and Firefox upgraded as well, which results in the problem I'm having.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • Firefox 66.0.4
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:66.0) Gecko/20100101 Firefox/66.0
  • Support URL: https://support.mozilla.org/1/firefox/66.0.4/Darwin/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x9583
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 512, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 512, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • lowEndMachine: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 1
  • targetFrameRate: 60
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shading_language_include GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_vertex_type_2_10_10_10_rev GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_texture_compression_rgtc EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: ATI Technologies Inc. -- ATI Radeon HD 2600 PRO OpenGL Engine
  • webgl1Version: 3.3 ATI-10.0.51
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * WebGL 2 requires support for the following features: transform_feedback2
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Timotax 1 solutions 45 answers

Hello,

Try to reset Firefox go Here

Bye

Hello, Try to reset Firefox go [https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Here] Bye
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
4188 solutions 58471 answers

Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version 32.0.0171

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

'''Separate Security Issue:''' Update your Flash Player or remove it using these links; [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows] {web link} [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac] {web link} '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player '''Version 32.0.0171 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17343 solutions 156777 answers

What do you see if you open the about:privatebrowsing page?

Did you check that you aren't using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History)?

What do you see if you open the <b>about:privatebrowsing</b> page? Did you check that you aren't using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History)? *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history
Was this helpful to you?
Quote

Question owner

Timotax's solution, to reset Firefox, worked!

I'd just upgraded my OS in Mac, that day, and of course Firefox now chose to upgrade to meet the OS. This was likely the cause of the problem.

As to cor-el's suggestion; I looked through the menus and Preferences and can't find the option to Always use Private Browsing mode; Never Remember History, but prior to Timotax's fix, it did appear Firefox wasn't remembering my history.

Thanks for all the responses!

Timotax's solution, to reset Firefox, worked! I'd just upgraded my OS in Mac, that day, and of course Firefox now chose to upgrade to meet the OS. This was likely the cause of the problem. As to cor-el's suggestion; I looked through the menus and Preferences and can't find the option to Always use Private Browsing mode; Never Remember History, but prior to Timotax's fix, it did appear Firefox wasn't remembering my history. Thanks for all the responses!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.