X
Tap here to go to the mobile version of the site.

Support Forum

Firefox disabled legacy extensions and now Roboform and EverSync won't work?

Posted

Interesting that I need to log in here for help...and Roboform has my password..which now I can't use in Firefox. This is ridiculous. All my passwords and log-ins are on Roboform. Not to mention it's my form filler.

Interesting that I need to log in here for help...and Roboform has my password..which now I can't use in Firefox. This is ridiculous. All my passwords and log-ins are on Roboform. Not to mention it's my form filler.

Chosen solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17333 solutions 156710 answers

Helpful Reply

There is a problem with an expired intermediate certificate that is used to sign extensions. This is being worked on by the Add-ons team.

See:

At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail.
Our team is actively working on a fix. We will update as soon as we have more information.
  • Bug 1548973 - (armagadd-on-2.0) All extensions disabled due to expiration of intermediate signing cert

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

There is a problem with an expired intermediate certificate that is used to sign extensions. This is being worked on by the Add-ons team. See: *[[/questions/1257928]] Will the disabling of add-ons be fixed, or is it the new way? *https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 <blockquote><pre>At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail. Our team is actively working on a fix. We will update as soon as we have more information.</pre></blockquote> *[https://bugzilla.mozilla.org/show_bug.cgi?id=1548973 Bug 1548973] - (armagadd-on-2.0) All extensions disabled due to expiration of intermediate signing cert (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
Was this helpful to you? 1
Quote
Chris Ilias
  • Moderator
346 solutions 1913 answers

Chosen Solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17333 solutions 156710 answers
See also: *https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.