X
Tap here to go to the mobile version of the site.

Support Forum

Firefox disabled most of my add-ons claming they aren't signed but they are working in a different firefox profile, what's up?

Posted

Other people have posted about having thier add-ons disabled by Firefox today.

I have the same problem losing all my security add-on (e.g. NoScript). All these add-ons were working earlier in the day.

But another profile (same version of Firefox, same computer) has most of these add-ons and they are working.

In addition the disabled profile could not download any add-on I tried and the working profile couldn't update an add-on when I tried.

All the messages say they were disabled due to not being signed, e.g. HTTPS Everywhere by the| Electronic Frontier Foundation.

"NoScript could not be verified for use in Firefox and has been disabled" "Privacy Badger could not be verified for use in Firefox and has been disabled" etc...

Trying to download the version at Mozilla's site I get the message "There was an error download uBlock Origin"

Other people have posted about having thier add-ons disabled by Firefox today. I have the same problem losing all my security add-on (e.g. NoScript). All these add-ons were working earlier in the day. But another profile (same version of Firefox, same computer) has most of these add-ons and they are working. In addition the disabled profile could not download any add-on I tried and the working profile couldn't update an add-on when I tried. All the messages say they were disabled due to not being signed, e.g. HTTPS Everywhere by the| Electronic Frontier Foundation. "NoScript could not be verified for use in Firefox and has been disabled" "Privacy Badger could not be verified for use in Firefox and has been disabled" etc... Trying to download the version at Mozilla's site I get the message "There was an error download uBlock Origin"

Chosen solution

Hi Luke,

Actually, the team has identified and is starting to roll out a fix. This could take up to a few hours to work.

In order to be able to provide this fix on short notice, we are using the Studies system.

You can check if you have studies enabled by going to Firefox Preferences -> Privacy & Security -> Allow Firefox to install and run studies.

You can disable studies again after your add-ons have been re-enabled.

Cheers, George

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8637 solutions 70667 answers

I don't think forum volunteers yet know the cause or remedy for this problem. However, know that dozens of people are reporting the same thing in recent hours, so it may be due to a rolling update gone wrong.

I don't think forum volunteers yet know the cause or remedy for this problem. However, know that dozens of people are reporting the same thing in recent hours, so it may be due to a rolling update gone wrong.
Was this helpful to you?
Quote

Question owner

jscher2000 said

I don't think forum volunteers yet know the cause or remedy for this problem. However, know that dozens of people are reporting the same thing in recent hours, so it may be due to a rolling update gone wrong.

Thank you for your post

I thought it was some failure on the Firefox, I posted, after seeing several other posts, because I had some data the other posts didn't. i.e. the difference between two profiles on the same computer

''jscher2000 [[#answer-1217902|said]]'' <blockquote> I don't think forum volunteers yet know the cause or remedy for this problem. However, know that dozens of people are reporting the same thing in recent hours, so it may be due to a rolling update gone wrong. </blockquote> Thank you for your post I thought it was some failure on the Firefox, I posted, after seeing several other posts, because I had some data the other posts didn't. i.e. the difference between two profiles on the same computer
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8637 solutions 70667 answers

Helpful Reply

CORRECTION TO THE BELOW: Firefox verifies the signature every 24 hours, but that is on a different schedule from updating, so the below turns out not to be relevant.

Maybe the difference between your two profiles is when they checked for updates?? You could see whether this staves off the problem:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autoup and pause while the list is filtered

(3) Double-click the extensions.update.autoUpdateDefault preference to switch the value from true to false

With this setting, when you go the Add-ons page, from time to time you'll see an "Updates Available" item in the left column below the others.

'''CORRECTION TO THE BELOW: Firefox verifies the signature every 24 hours, but that is on a different schedule from updating, so the below turns out not to be relevant.''' Maybe the difference between your two profiles is when they checked for updates?? You could see whether this staves off the problem: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autoup''' and pause while the list is filtered (3) Double-click the '''extensions.update.autoUpdateDefault''' preference to switch the value from true to false With this setting, when you go the Add-ons page, from time to time you'll see an "Updates Available" item in the left column below the others.

Modified by jscher2000

Was this helpful to you? 2
Quote

Question owner

I think you're correct.

I was using a different computer later last night with all the various add-ons working.

When, at 9:50 PM they were disabled without warning.

I've edited the about:config as you said for the one profile I have which hasn't had its add-ons disabled and will check on it occasionally to see if that remains true

I think you're correct. I was using a different computer later last night with all the various add-ons working. When, at 9:50 PM they were disabled without warning. I've edited the about:config as you said for the one profile I have which hasn't had its add-ons disabled and will check on it occasionally to see if that remains true
Was this helpful to you?
Quote
geroter 1 solutions 8 answers

Helpful Reply

Hi Luke,

We're very sorry for the inconvenience here.

There has been a technical issue with Add-ons that the Firefox team is working on urgently (it affects in the installation of new add-ons and usage of installed add-ons). You can expect a resolution soon.

You can track updates to the issue through this post: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047/

Sorry again, George

Hi Luke, We're very sorry for the inconvenience here. There has been a technical issue with Add-ons that the Firefox team is working on urgently (it affects in the installation of new add-ons and usage of installed add-ons). You can expect a resolution soon. You can track updates to the issue through this post: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047/ Sorry again, George
Was this helpful to you? 1
Quote

Question owner

Thank you

Do you know if jscher2000 idea of turning off auto updating for extensions will prevent this problem?

Thank you Do you know if jscher2000 idea of turning off auto updating for extensions will prevent this problem?
Was this helpful to you?
Quote
geroter 1 solutions 8 answers

Chosen Solution

Hi Luke,

Actually, the team has identified and is starting to roll out a fix. This could take up to a few hours to work.

In order to be able to provide this fix on short notice, we are using the Studies system.

You can check if you have studies enabled by going to Firefox Preferences -> Privacy & Security -> Allow Firefox to install and run studies.

You can disable studies again after your add-ons have been re-enabled.

Cheers, George

Hi Luke, Actually, the team has identified and is starting to roll out a fix. This could take up to a few hours to work. In order to be able to provide this fix on short notice, we are using the Studies system. You can check if you have studies enabled by going to Firefox Preferences -> Privacy & Security -> Allow Firefox to install and run studies. You can disable studies again after your add-ons have been re-enabled. Cheers, George
Was this helpful to you? 1
Quote

Question owner

Just checked and the fix worked for my main profile, add-ons are back

Thank you

Just checked and the fix worked for my main profile, add-ons are back Thank you
Was this helpful to you?
Quote
njbob1949 0 solutions 2 answers

Thank You. I changed the settings for allow studies and the within a few minutes the fixes were added to my system. Without the add-ins enabled my computer was not functional. No add blocking, no tracking blocking, etc.

Thank You. I changed the settings for allow studies and the within a few minutes the fixes were added to my system. Without the add-ins enabled my computer was not functional. No add blocking, no tracking blocking, etc.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.