X
Tap here to go to the mobile version of the site.

Support Forum

After a fresh Windows install Twitter translations font is too small. Everything in FF set exactly as it was before.

Posted

I'm using all the default FF fonts,set all the sizes to 18pt which is how I've always had them,unchecked 'Allow pages to choose own fonts'...etc. Tried unchecking 'hardware acceleration',which made no difference. This wasn't happening an hour ago on the old windows installation,the Twitter translations were the same size as every other font on Twitter. Any idea how I can fix this? I can't read them at this tiny size.

ps: I reinstalled Windows 7 after once again trying the completely useless Win 10 on this pc. The same problem with the font sizes was on the Win 10 installation. On my laptop I have Win 10 and the fonts are fine on twitter translations there,they are more or less the same size as the main fonts.

I'm using all the default FF fonts,set all the sizes to 18pt which is how I've always had them,unchecked 'Allow pages to choose own fonts'...etc. Tried unchecking 'hardware acceleration',which made no difference. This wasn't happening an hour ago on the old windows installation,the Twitter translations were the same size as every other font on Twitter. Any idea how I can fix this? I can't read them at this tiny size. ps: I reinstalled Windows 7 after once again trying the completely useless Win 10 on this pc. The same problem with the font sizes was on the Win 10 installation. On my laptop I have Win 10 and the fonts are fine on twitter translations there,they are more or less the same size as the main fonts.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8583 solutions 70195 answers

Helpful Reply

Did you use your old Firefox profile after the Windows reinstall, or is this a completely fresh Firefox install?

It's usually best to use zoom to resize website fonts (and other content, proportionally) rather than trying to set them manually.

Fonts for: Character Sets

What is the language used in the "too small" text? At the top of the Advanced/Fonts dialog, the "Fonts for" selector probably indicates "Latin." To set sizes for other character sets, select them there and then use the rest of the boxes as usual.

Global Scaling Factor

If you want to globally resize everything in Firefox, there is a preference for that. It will enlarge text on the toolbars as well as web content. Here's how you can try increasing that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button accepting the risk.

(2) In the filter box, type or paste devp and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.5 and click OK. That corresponds to 150% of the classic font size.

Too big? Try 1.25

Too small? Try 2.0

Don't choose a value below 1.0 or above 4.0 or you may find it difficult to get back to a viewable Firefox! If something does go terribly wrong, right-click the preference and then tap the R key to reset to the starting value.

Any improvement?

If the bars become too tall, try using "Compact" density on the Customize screen: Customize Firefox controls, buttons and toolbars.

Did you use your old Firefox profile after the Windows reinstall, or is this a completely fresh Firefox install? It's usually best to use zoom to resize website fonts (and other content, proportionally) rather than trying to set them manually. '''''Fonts for: Character Sets''''' What is the language used in the "too small" text? At the top of the Advanced/Fonts dialog, the "Fonts for" selector probably indicates "Latin." To set sizes for other character sets, select them there and then use the rest of the boxes as usual. '''''Global Scaling Factor''''' If you want to globally resize everything in Firefox, there is a preference for that. It will enlarge text on the toolbars as well as web content. Here's how you can try increasing that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button accepting the risk. (2) In the filter box, type or paste '''devp''' and pause while the list is filtered (3) Double-click '''layout.css.devPixelsPerPx''' and change its value to '''1.5''' and click OK. That corresponds to 150% of the classic font size. Too big? Try '''1.25''' Too small? Try '''2.0''' Don't choose a value below 1.0 or above 4.0 or you may find it difficult to get back to a viewable Firefox! If something does go terribly wrong, right-click the preference and then tap the R key to reset to the starting value. Any improvement? If the bars become too tall, try using "Compact" density on the Customize screen: [[Customize Firefox controls, buttons and toolbars]].
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156811 answers

Helpful Reply

Can you attach a screenshot?


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Can you attach a screenshot? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot ---- You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
Was this helpful to you? 1
Quote

Question owner

Hi,thanks a lot for the reply. I tried that just now but there's no difference. It's a strange thing,it's only the translations on twitter that are small,they look like about 9pt or something. Here's a screenshot. The font settings are the same as my laptop and translations on that are way bigger...not quite as big as the other fonts on twitter,but pretty close.

Hi,thanks a lot for the reply. I tried that just now but there's no difference. It's a strange thing,it's only the translations on twitter that are small,they look like about 9pt or something. Here's a screenshot. The font settings are the same as my laptop and translations on that are way bigger...not quite as big as the other fonts on twitter,but pretty close.
Was this helpful to you?
Quote

Question owner

jscher2000 said

Did you use your old Firefox profile after the Windows reinstall, or is this a completely fresh Firefox install? It's usually best to use zoom to resize website fonts (and other content, proportionally) rather than trying to set them manually. Fonts for: Character Sets What is the language used in the "too small" text? At the top of the Advanced/Fonts dialog, the "Fonts for" selector probably indicates "Latin." To set sizes for other character sets, select them there and then use the rest of the boxes as usual. Global Scaling Factor If you want to globally resize everything in Firefox, there is a preference for that. It will enlarge text on the toolbars as well as web content. Here's how you can try increasing that: (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button accepting the risk. (2) In the filter box, type or paste devp and pause while the list is filtered (3) Double-click layout.css.devPixelsPerPx and change its value to 1.5 and click OK. That corresponds to 150% of the classic font size. Too big? Try 1.25 Too small? Try 2.0 Don't choose a value below 1.0 or above 4.0 or you may find it difficult to get back to a viewable Firefox! If something does go terribly wrong, right-click the preference and then tap the R key to reset to the starting value. Any improvement? If the bars become too tall, try using "Compact" density on the Customize screen: Customize Firefox controls, buttons and toolbars.

Thanks a lot,I'll try these things. The fonts are just the regular FF defaults,with Latin at the top and 'Default for current locale' at the bottom.

''jscher2000 [[#answer-1217739|said]]'' <blockquote> Did you use your old Firefox profile after the Windows reinstall, or is this a completely fresh Firefox install? It's usually best to use zoom to resize website fonts (and other content, proportionally) rather than trying to set them manually. '''''Fonts for: Character Sets''''' What is the language used in the "too small" text? At the top of the Advanced/Fonts dialog, the "Fonts for" selector probably indicates "Latin." To set sizes for other character sets, select them there and then use the rest of the boxes as usual. '''''Global Scaling Factor''''' If you want to globally resize everything in Firefox, there is a preference for that. It will enlarge text on the toolbars as well as web content. Here's how you can try increasing that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button accepting the risk. (2) In the filter box, type or paste '''devp''' and pause while the list is filtered (3) Double-click '''layout.css.devPixelsPerPx''' and change its value to '''1.5''' and click OK. That corresponds to 150% of the classic font size. Too big? Try '''1.25''' Too small? Try '''2.0''' Don't choose a value below 1.0 or above 4.0 or you may find it difficult to get back to a viewable Firefox! If something does go terribly wrong, right-click the preference and then tap the R key to reset to the starting value. Any improvement? If the bars become too tall, try using "Compact" density on the Customize screen: [[Customize Firefox controls, buttons and toolbars]]. </blockquote> Thanks a lot,I'll try these things. The fonts are just the regular FF defaults,with Latin at the top and 'Default for current locale' at the bottom.
Was this helpful to you?
Quote

Question owner

Haruna said

jscher2000 said
Did you use your old Firefox profile after the Windows reinstall, or is this a completely fresh Firefox install? It's usually best to use zoom to resize website fonts (and other content, proportionally) rather than trying to set them manually. Fonts for: Character Sets What is the language used in the "too small" text? At the top of the Advanced/Fonts dialog, the "Fonts for" selector probably indicates "Latin." To set sizes for other character sets, select them there and then use the rest of the boxes as usual. Global Scaling Factor If you want to globally resize everything in Firefox, there is a preference for that. It will enlarge text on the toolbars as well as web content. Here's how you can try increasing that: (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button accepting the risk. (2) In the filter box, type or paste devp and pause while the list is filtered (3) Double-click layout.css.devPixelsPerPx and change its value to 1.5 and click OK. That corresponds to 150% of the classic font size. Too big? Try 1.25 Too small? Try 2.0 Don't choose a value below 1.0 or above 4.0 or you may find it difficult to get back to a viewable Firefox! If something does go terribly wrong, right-click the preference and then tap the R key to reset to the starting value. Any improvement? If the bars become too tall, try using "Compact" density on the Customize screen: Customize Firefox controls, buttons and toolbars.

Thanks a lot,I'll try these things. The fonts are just the regular FF defaults,with Latin at the top and 'Default for current locale' at the bottom.

It's a completely fresh install.

''Haruna [[#answer-1217849|said]]'' <blockquote> ''jscher2000 [[#answer-1217739|said]]'' <blockquote> Did you use your old Firefox profile after the Windows reinstall, or is this a completely fresh Firefox install? It's usually best to use zoom to resize website fonts (and other content, proportionally) rather than trying to set them manually. '''''Fonts for: Character Sets''''' What is the language used in the "too small" text? At the top of the Advanced/Fonts dialog, the "Fonts for" selector probably indicates "Latin." To set sizes for other character sets, select them there and then use the rest of the boxes as usual. '''''Global Scaling Factor''''' If you want to globally resize everything in Firefox, there is a preference for that. It will enlarge text on the toolbars as well as web content. Here's how you can try increasing that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button accepting the risk. (2) In the filter box, type or paste '''devp''' and pause while the list is filtered (3) Double-click '''layout.css.devPixelsPerPx''' and change its value to '''1.5''' and click OK. That corresponds to 150% of the classic font size. Too big? Try '''1.25''' Too small? Try '''2.0''' Don't choose a value below 1.0 or above 4.0 or you may find it difficult to get back to a viewable Firefox! If something does go terribly wrong, right-click the preference and then tap the R key to reset to the starting value. Any improvement? If the bars become too tall, try using "Compact" density on the Customize screen: [[Customize Firefox controls, buttons and toolbars]]. </blockquote> Thanks a lot,I'll try these things. The fonts are just the regular FF defaults,with Latin at the top and 'Default for current locale' at the bottom. </blockquote> It's a completely fresh install.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156811 answers

You can check the font used for selected text in the Font tab in the right pane of the Inspector. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

You can check the font used for selected text in the Font tab in the right pane of the Inspector. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts
Was this helpful to you? 1
Quote

Question owner

Thanks I'll try to check that. By the way,this is what it looks like on my laptop...all fonts settings exactly the same on both pc's.

Thanks I'll try to check that. By the way,this is what it looks like on my laptop...all fonts settings exactly the same on both pc's.
Was this helpful to you?
Quote

Question owner

cor-el said

You can check the font used for selected text in the Font tab in the right pane of the Inspector. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

Changing things there doesn't seem to do anything about the difference in sizes between main fonts and translations fonts. The 'weight' option makes everything more bold etc,but the sizes are the same. Increasing the px setting just seems to increase the line height or something,the font sizes stay the same.

''cor-el [[#answer-1217853|said]]'' <blockquote> You can check the font used for selected text in the Font tab in the right pane of the Inspector. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts </blockquote> Changing things there doesn't seem to do anything about the difference in sizes between main fonts and translations fonts. The 'weight' option makes everything more bold etc,but the sizes are the same. Increasing the px setting just seems to increase the line height or something,the font sizes stay the same.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8583 solutions 70195 answers

Try "Other Writing Systems." I just experimented with ridiculous fonts until I discovered that. (See attached screenshot.)

And now my fonts are all messed...

Try "Other Writing Systems." I just experimented with ridiculous fonts until I discovered that. (See attached screenshot.) And now my fonts are all messed...
Was this helpful to you? 1
Quote

Question owner

Haruna said

cor-el said
You can check the font used for selected text in the Font tab in the right pane of the Inspector. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

Changing things there doesn't seem to do anything about the difference in sizes between main fonts and translations fonts. The 'weight' option makes everything more bold etc,but the sizes are the same. Increasing the px setting just seems to increase the line height or something,the font sizes stay the same.

A couple of the fonts used on Twitter according to that 'Element Inspector' are actually different to what's being used on the laptop though for some reason. I think this must be something to do with it,but I can't see how to change them?

''Haruna [[#answer-1217869|said]]'' <blockquote> ''cor-el [[#answer-1217853|said]]'' <blockquote> You can check the font used for selected text in the Font tab in the right pane of the Inspector. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts </blockquote> Changing things there doesn't seem to do anything about the difference in sizes between main fonts and translations fonts. The 'weight' option makes everything more bold etc,but the sizes are the same. Increasing the px setting just seems to increase the line height or something,the font sizes stay the same. </blockquote> A couple of the fonts used on Twitter according to that 'Element Inspector' are actually different to what's being used on the laptop though for some reason. I think this must be something to do with it,but I can't see how to change them?
Was this helpful to you?
Quote

Question owner

Excellent! Thanks a lot,that totally fixed it! My fonts are not messed up at all as far as I can see :)

Excellent! Thanks a lot,that totally fixed it! My fonts are not messed up at all as far as I can see :)
Was this helpful to you?
Quote

Question owner

jscher2000 said

Try "Other Writing Systems." I just experimented with ridiculous fonts until I discovered that. (See attached screenshot.) And now my fonts are all messed...
''jscher2000 [[#answer-1217873|said]]'' <blockquote> Try "Other Writing Systems." I just experimented with ridiculous fonts until I discovered that. (See attached screenshot.) And now my fonts are all messed... </blockquote>
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8583 solutions 70195 answers

Haruna said

Excellent! Thanks a lot,that totally fixed it! My fonts are not messed up at all as far as I can see :)

Yes, you wisely chose to stick with normal fonts. :-D

''Haruna [[#answer-1217882|said]]'' <blockquote> Excellent! Thanks a lot,that totally fixed it! My fonts are not messed up at all as far as I can see :) </blockquote> Yes, you wisely chose to stick with normal fonts. :-D
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.