X
Tap here to go to the mobile version of the site.

Support Forum

Sites including MSN.com and Bing.com are being blocked by Firefox?

Posted

After a FireFox update many sites including MSN.com and Bing.com and my bank are being blocked or did not connect due to a potential security issue. I have tried to accept and continue the risk for MSN.Com but it's still not loading. I have the same version of Firefox on my work computer and this is not happening on that one. I'm using Windows defender as my antivirus on both computers. Need some help resolving. I have attached some screen shots.

Thank you

After a FireFox update many sites including MSN.com and Bing.com and my bank are being blocked or did not connect due to a potential security issue. I have tried to accept and continue the risk for MSN.Com but it's still not loading. I have the same version of Firefox on my work computer and this is not happening on that one. I'm using Windows defender as my antivirus on both computers. Need some help resolving. I have attached some screen shots. Thank you
Attached screenshots

Chosen solution

Try to rename the cert9.db (cert9.db.old) file and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has stored.

If this has helped to solve the problem then you can remove the renamed cert9.db.old file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:preferences page.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155234 answers

Chosen Solution

Try to rename the cert9.db (cert9.db.old) file and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has stored.

If this has helped to solve the problem then you can remove the renamed cert9.db.old file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:preferences page.

Try to rename the cert9.db (cert9.db.old) file and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has stored. *https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean If this has helped to solve the problem then you can remove the renamed cert9.db.old file. Otherwise you can undo the rename and restore cert9.db. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:preferences</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Was this helpful to you? 1
Quote

Question owner

Thank you. I renamed the Cert9 to Cert9Old. This worked and fixed the issue!! Do I need to do anything else or can I leave it like this?

Thanks for your quick help :)

Thank you. I renamed the Cert9 to Cert9Old. This worked and fixed the issue!! Do I need to do anything else or can I leave it like this? Thanks for your quick help :)
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155234 answers

Helpful Reply

You're welcome.

Thanks for reporting that this was an issue with the cert9.db database. There have recently been more report with similar issues. Hopefully it will last and you do not have to repeat this rename/delete action.

You're welcome. Thanks for reporting that this was an issue with the cert9.db database. There have recently been more report with similar issues. Hopefully it will last and you do not have to repeat this rename/delete action.
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
4116 solutions 57480 answers

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.