Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I turn notifications for twitter back on

  • 10 replies
  • 1 has this problem
  • 34 views
  • Last reply by mike10dude

more options

earlier today I clicked on the site information button while on twitters website and pressed the x beside send notifications but I want to turn notifications for the site back on and I can not find any way to do that

Chosen solution

You can try to toggle the Twitter setting off and on again to see if that triggers a new request.

Did you already try to create a cookie allow exception because that might be required especially if you let cookies expire when you close Firefox (Delete cookies and site data when Firefox is closed)?

Read this answer in context 👍 0

All Replies (10)

more options

You can open a Twitter tab and check the "Tools -> Page Info -> Permissions" window. You can also check the notification settings in "Options/Preferences -> Privacy & Security -> Permissions -> Notifications".

more options

yeah I already tried that and twitter is not listed in there

more options

Did you also look in "Options/Preferences -> Privacy & Security" ? Note that there is a checkbox in the Settings window to block further notifications.

Is this about 'push' type notification to show a notification even if you do not have a Twitter tab open?

You may have to create a cookie allow exception for the Twitter website. You can check the Web Console for notification related messages.

more options

(deleted, wrong thread)

Modified by cor-el

more options

yeah it is about push notifications

and the Block new requests asking to allow notifications box is not ticked

also I opened up the web console and could not find anything to help with this

more options

I assume that you need to be logged in to receive notifications. Did you check the settings in your Twitter account?

more options

yeah all the correct stuff is turned on in the twitter settings and I can get them on my phone

more options

Chosen Solution

You can try to toggle the Twitter setting off and on again to see if that triggers a new request.

Did you already try to create a cookie allow exception because that might be required especially if you let cookies expire when you close Firefox (Delete cookies and site data when Firefox is closed)?

more options

Note that Push notification use service workers, so maybe recheck the Web Console.

You can see all registered service workers on these pages:

  • about:serviceworkers and about:debugging#workers

You can check WebSockets via this page: about:networking#websockets

See also serviceworker.txt in the profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:preferences page.

more options

not really sure what happenned but I opened up about:serviceworkers and about:debugging#workers and right away the option to turn twitter push notifications became available again

thank you for the help