Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why won't your so-called "awesome bar" work as a normal bar???

  • 23 replies
  • 1 has this problem
  • 26 views
  • Last reply by thestilow

more options

The address bar is a simple concept. You type an address in, you hit <Return>, and the browser takes you there.

Not in Firefox 66.0.3!

In 66.0.3 you type in an address (meanwhile the bar is giving you random crap to "help" you and there's no way to turn this off), you hit return, and....nothing!

The only way to actually go where you want to go is to type the address, *click or tab OUT of the bar*, and then *re-enter the bar*. Then and ONLY then will <Return> actually do something.

Based on other questions, this has happened before too.

Why can't you just have an address bar that works as an address bar?

Chosen solution

FIXED!!

Evidently around Firefox 64 or 65 is (probably) when the issue started.

I use CSS style sheets for the classic "tabs not on top" look plus a few other "classic" looks. I had not updated those files in a while so when the profile test (and "safe mode" test) seemed to point to the CSS sheets not working properly I checked the new ones out.

Turns out that new code had to be written for the "tabs not on top" look starting in Firefox 65, and there were some search and autocomplete stuff that were redone in 64.

So...the verdict is...Firefox did change *something*, which invalidated my CSS sheets, so I needed to update those.

Anyway, I downloaded the new versions, made my edits, and now everything seems to work properly.

Thanks everyone for the help!

Read this answer in context 👍 0

All Replies (3)

more options

Any luck with the

New Profile Test

This takes about 3 minutes, plus the time to test the URL bar.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like May2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Does the URL bar work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile.

more options

jscher2000 said

Any luck with the New Profile Test This takes about 3 minutes, plus the time to test the URL bar. Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it. Click the "Create a New Profile" button, then click Next. Assign a name like May2019, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the Launch profile in new browser button. Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test. Does the URL bar work any better in the new profile? When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile.

I was able to find time to get to the computer for this...

The "clean profile" test did work. The URL bar worked the way it's supposed to. (Of course since I normally use CSS code the new window looked like...well, it didn't look like I prefer. :) )

Added note...when I installed my normal CSS directory (chrome) into the test profile and restarted the new profile, the URL bar stopped working properly again.

So...looks like something new in Firefox is not playing nicely with the CSS scripts.

Modified by thestilow

more options

Chosen Solution

FIXED!!

Evidently around Firefox 64 or 65 is (probably) when the issue started.

I use CSS style sheets for the classic "tabs not on top" look plus a few other "classic" looks. I had not updated those files in a while so when the profile test (and "safe mode" test) seemed to point to the CSS sheets not working properly I checked the new ones out.

Turns out that new code had to be written for the "tabs not on top" look starting in Firefox 65, and there were some search and autocomplete stuff that were redone in 64.

So...the verdict is...Firefox did change *something*, which invalidated my CSS sheets, so I needed to update those.

Anyway, I downloaded the new versions, made my edits, and now everything seems to work properly.

Thanks everyone for the help!

  1. 1
  2. 2