X
Tap here to go to the mobile version of the site.

Support Forum

Google calendar header (Today, arrows, Month, search, settings, etc) not displaying in Firefox

Posted

Worked fine last night when I shut down. Now this morning my google calendar header is gone and I can't figure out how to get it back. It's there using Brave browser for another (different) gmail account so I'm thinking it's a Firefox display issue. Any ideas on how to fix? Using the far upper left arrow keys to change month does not change the main display calendar either so this problem makes google calendar essentially useless using Firefox. Thanks for any and all help!

Worked fine last night when I shut down. Now this morning my google calendar header is gone and I can't figure out how to get it back. It's there using Brave browser for another (different) gmail account so I'm thinking it's a Firefox display issue. Any ideas on how to fix? Using the far upper left arrow keys to change month does not change the main display calendar either so this problem makes google calendar essentially useless using Firefox. Thanks for any and all help!

Chosen solution

I notice a notch on the Control Center 'i' icon. This indicates that you made changes to permissions from the default. You can click this icon to see what changes this is about.

You can possibly clear the Site Preferences to remove this data, but this resets the permissions for all websites.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

Adblock Plus, Blur, Eno, CanvasBlocker, Smart Https, Disconnect, Decentraleyes, Smart Referer

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

Question owner

See attached Firefox and Brave images of Google Calendar for example of what is missing in Firefox (note these are two different Google accounts).

See attached Firefox and Brave images of Google Calendar for example of what is missing in Firefox (note these are two different Google accounts).
Was this helpful to you?
Quote
WestEnd
  • Top 25 Contributor
61 solutions 5340 answers

Helpful Reply

Do a remove and then close the browser and reopen the browser and reinstall the Addon again? And did you make sure your not using a older version of the addon.

Do a remove and then close the browser and reopen the browser and reinstall the Addon again? And did you make sure your not using a older version of the addon.

Modified by WestEnd

Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8583 solutions 70213 answers

Helpful Reply

Hmm, Google does conduct UI experiments on its users, but if this is one of those, it's not very useful!

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hmm, Google does conduct UI experiments on its users, but if this is one of those, it's not very useful! If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: '''Double-check content blockers:''' Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Content Blocking]]. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data" * (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8583 solutions 70213 answers

WestEnd said

Did remove and then close the browser and reopen the browser and reinstall the Addon again? And did you make sure your not using a older version of the addon.

I think the issue is with the built-in website features at

https://calendar.google.com/calendar/r

They are loaded by a script a split second after the main controls, so there may be a content blocking, cache, or cookie issue.

''WestEnd [[#answer-1215527|said]]'' <blockquote> Did remove and then close the browser and reopen the browser and reinstall the Addon again? And did you make sure your not using a older version of the addon. </blockquote> I think the issue is with the built-in website features at https://calendar.google.com/calendar/r They are loaded by a script a split second after the main controls, so there may be a content blocking, cache, or cookie issue.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17348 solutions 156811 answers

Chosen Solution

I notice a notch on the Control Center 'i' icon. This indicates that you made changes to permissions from the default. You can click this icon to see what changes this is about.

You can possibly clear the Site Preferences to remove this data, but this resets the permissions for all websites.

I notice a notch on the Control Center 'i' icon. This indicates that you made changes to permissions from the default. You can click this icon to see what changes this is about. You can possibly clear the Site Preferences to remove this data, but this resets the permissions for all websites.
Was this helpful to you? 1
Quote

Question owner

Hello everyone and thanks for all replies and help. As I've been really busy since posting I've not had time to act on any of the generous and thoughtful suggestions - THANK YOU ALL for your contributions.

However, yesterday, the problem resolved it self - just as mysteriously as it presented. I have no idea why...Crazy!

But thank you all again for your time and suggestions!

Hello everyone and thanks for all replies and help. As I've been really busy since posting I've not had time to act on any of the generous and thoughtful suggestions - THANK YOU ALL for your contributions. However, yesterday, the problem resolved it self - just as mysteriously as it presented. I have no idea why...Crazy! But thank you all again for your time and suggestions!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.