Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google searches did open in new tab today open in google tab I've searched & tried no luck

  • 10 replies
  • 1 has this problem
  • 114 views
  • Last reply by McCoy

more options

new computer 2wks Dell Inspiron 13 Windows 10 Firefox 66.0.3 64 bit until today links on Google search page would open in new tab, today the link opens in the search result window. I've searched for solutions but no luck. Firefox options to "open selected links in new tab instead of new window" is STILL selected-Search I have search box in toolbar - various solutions direct me to steps that I can't find-I have an extension that is supposed to open searches in new tabs, it doesn't, I'm not sure where that is. As you can guess I need step by step instructions

Chosen solution

You may have lost the Google settings that are stored in a special PREF cookie.

Google has a checkbox on its settings page to open links in a new window that Firefox can divert to a new tab. See "Where results open":

Read this answer in context 👍 1

All Replies (10)

more options

Hello ray611,

I took a look at that extension that is listed in your Options => Add-ons => Extensions :

"Open search results in a new tab 0.3 "

I would advice you to remove it - there is no "About this extension", no support site or email support, plus the extension hasn't been updated since May 2018.

When you want search results to open in a new tab, all you have to do is :

Press the Ctrl key on your keyboard, and then click on the search result you want to open.

more options

Chosen Solution

You may have lost the Google settings that are stored in a special PREF cookie.

Google has a checkbox on its settings page to open links in a new window that Firefox can divert to a new tab. See "Where results open":

more options

McCoy

Thanks for the suggestion, but removing that extension (which was one of the solutions I found when searching). I can always open a new tab just by right clicking on the link. But I'm spoiled, because I used to be able to just click on the link to have it open in a new tab. The new tab would then be the opened, I didn't have to select the new tab.

more options

cor-el

That did it. I don't know what caused it to change, but this solved it. Thanks ray611

more options

You're welcome.

Google stores its settings in a cookie on your computer, so you need to make sure to keep this cookie and possibly create a cookie allow exception.

more options

@ ray611,

Would you be so kind as to mark cor-el's post as Chosen Solution ? ("Solved the problem" button to the right)

Thank you in advance  !


In case this happens again .....

What will also make sure that search results open in a new tab :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.search.openintab

and make sure its value is set to true

If you had to change the value, then close and restart Firefox.

more options

McCoy

I thought I did mark cor-el's solution as the Chosen Solution.

I think I saw the "preference" suggestion in one of my searched, but I don't believe I was able to get to the place where I could find "browser.search.openintab and make sure its value is set to true"

I'll keep this information in case I need it in the future Thanks ray611

more options

ray611 said

I thought I did mark cor-el's solution as the Chosen Solution.

When I asked you to mark cor-el's post as Chosen Solution, you had marked it as "Helpful" - but you have marked it as Chosen Solution now; thank you  !

more options

The browser.search.openintab pref is used when you use the Firefox search bar to do a search and it won't have effect when you search on the Google website.

more options

cor-el said

The browser.search.openintab pref is used when you use the Firefox search bar to do a search and it won't have effect when you search on the Google website.

Works when I have it set to "true" .....

As we're talking about Google : that's the site I tried it on (numerous times, to make sure).