X
Tap here to go to the mobile version of the site.

Support Forum

how to stop firefox defaulting to czech currency and language when I want GB pounds and UK English

Posted

Using the address bar, I type in a search criterion and the answers or shortcuts shown always contain czech prices or language. How can I default to English and GBP, please. My chosen settings are for English and I cannot see a setting that allows you to choose preferred country (used to be available in older versions).

Using the address bar, I type in a search criterion and the answers or shortcuts shown always contain czech prices or language. How can I default to English and GBP, please. My chosen settings are for English and I cannot see a setting that allows you to choose preferred country (used to be available in older versions).

Chosen solution

Maybe this will explain it better :

  1. Got to google.com or google.co.uk,
  2. At the bottom (right side) click on 'Settings',
  3. Click on 'Search settings',
  4. Scroll down to 'Region Settings',
  5. Choose either 'Current Region' or 'United Kingdom',
  6. Click on the blue 'Save' button at the bottom of the page.
Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

McCoy
  • Top 10 Contributor
466 solutions 4252 answers

Hello Maren22,

You can download Firefox in your preferred language from here :

www.mozilla.org/firefox/all

Also : if you use Google as your search engine, when you're on google.com (or google.co.uk) go to Settings (at the bottom right) => Search Settings => Region Settings => click either 'Current Region' or 'United Kingdom' (and click the blue 'Save' button at the bottom of the page).

Hello Maren22, You can download Firefox in your preferred language from here : www.mozilla.org/firefox/all Also : if you use Google as your search engine, when you're on google.com (or google.co.uk) go to Settings (at the bottom right) => Search Settings => Region Settings => click either 'Current Region' or 'United Kingdom' (and click the blue 'Save' button at the bottom of the page).
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17273 solutions 156141 answers

What languages are reported on the "Help -> Troubleshooting Information" (about:support) page in the "Internationalization & Localization" section?

What languages are reported on the "Help -> Troubleshooting Information" (about:support) page in the "Internationalization & Localization" section?
Was this helpful to you? 0
Quote

Question owner

McCoy said

Hello Maren22, You can download Firefox in your preferred language from here : www.mozilla.org/firefox/all Also : if you use Google as your search engine, when you're on google.com (or google.co.uk) go to Settings (at the bottom right) => Search Settings => Region Settings => click either 'Current Region' or 'United Kingdom' (and click the blue 'Save' button at the bottom of the page).

I downloaded firefox as you suggested, it made no difference.

''McCoy [[#answer-1215247|said]]'' <blockquote> Hello Maren22, You can download Firefox in your preferred language from here : www.mozilla.org/firefox/all Also : if you use Google as your search engine, when you're on google.com (or google.co.uk) go to Settings (at the bottom right) => Search Settings => Region Settings => click either 'Current Region' or 'United Kingdom' (and click the blue 'Save' button at the bottom of the page). </blockquote> I downloaded firefox as you suggested, it made no difference.
Was this helpful to you? 0
Quote

Question owner

cor-el said

What languages are reported on the "Help -> Troubleshooting Information" (about:support) page in the "Internationalization & Localization" section?

Maren22 said

McCoy said
Hello Maren22, You can download Firefox in your preferred language from here : www.mozilla.org/firefox/all Also : if you use Google as your search engine, when you're on google.com (or google.co.uk) go to Settings (at the bottom right) => Search Settings => Region Settings => click either 'Current Region' or 'United Kingdom' (and click the blue 'Save' button at the bottom of the page).

I downloaded firefox as you suggested, it made no difference.

The settings are: Internationalisation & Localisation Application Settings Requested Locales ["en-GB"] Available Locales ["en-GB","en-US"] App Locales ["en-GB","en-US"] Regional Preferences ["en-GB"] Default Locale "en-GB" Operating System System Locales ["en-US"] Regional Preferences ["en-GB"]

However I still get Czech currency in the Google responses.

''cor-el [[#answer-1215248|said]]'' <blockquote> What languages are reported on the "Help -> Troubleshooting Information" (about:support) page in the "Internationalization & Localization" section? </blockquote> ''Maren22 [[#answer-1215266|said]]'' <blockquote> ''McCoy [[#answer-1215247|said]]'' <blockquote> Hello Maren22, You can download Firefox in your preferred language from here : www.mozilla.org/firefox/all Also : if you use Google as your search engine, when you're on google.com (or google.co.uk) go to Settings (at the bottom right) => Search Settings => Region Settings => click either 'Current Region' or 'United Kingdom' (and click the blue 'Save' button at the bottom of the page). </blockquote> I downloaded firefox as you suggested, it made no difference. </blockquote> The settings are: Internationalisation & Localisation Application Settings Requested Locales ["en-GB"] Available Locales ["en-GB","en-US"] App Locales ["en-GB","en-US"] Regional Preferences ["en-GB"] Default Locale "en-GB" Operating System System Locales ["en-US"] Regional Preferences ["en-GB"] However I still get Czech currency in the Google responses.
Was this helpful to you? 0
Quote

Question owner

These are the setting on my computer: Internationalisation & Localisation Application Settings Requested Locales ["en-GB"] Available Locales ["en-GB","en-US"] App Locales ["en-GB","en-US"] Regional Preferences ["en-GB"] Default Locale "en-GB" Operating System System Locales ["en-US"] Regional Preferences ["en-GB"]

These are the setting on my computer: Internationalisation & Localisation Application Settings Requested Locales ["en-GB"] Available Locales ["en-GB","en-US"] App Locales ["en-GB","en-US"] Regional Preferences ["en-GB"] Default Locale "en-GB" Operating System System Locales ["en-US"] Regional Preferences ["en-GB"]
Was this helpful to you? 0
Quote
McCoy
  • Top 10 Contributor
466 solutions 4252 answers

Maren22 said

However I still get Czech currency in the Google responses.

Have you checked the Google Search settings, like I suggested  ?

''Maren22 [[#answer-1215269|said]]'' <blockquote> However I still get Czech currency in the Google responses. </blockquote> Have you checked the Google Search settings, like I suggested ?
Was this helpful to you? 0
Quote

Question owner

I have and they are: Internationalisation & Localisation Application Settings Requested Locales ["en-GB"] Available Locales ["en-GB","en-US"] App Locales ["en-GB","en-US"] Regional Preferences ["en-GB"] Default Locale "en-GB" Operating System System Locales ["en-US"] Regional Preferences ["en-GB"]

I have and they are: Internationalisation & Localisation Application Settings Requested Locales ["en-GB"] Available Locales ["en-GB","en-US"] App Locales ["en-GB","en-US"] Regional Preferences ["en-GB"] Default Locale "en-GB" Operating System System Locales ["en-US"] Regional Preferences ["en-GB"]
Was this helpful to you? 0
Quote
McCoy
  • Top 10 Contributor
466 solutions 4252 answers

Maren22 said

I have and they are: Internationalisation & Localisation Application Settings Requested Locales ["en-GB"] Available Locales ["en-GB","en-US"] App Locales ["en-GB","en-US"] Regional Preferences ["en-GB"] Default Locale "en-GB" Operating System System Locales ["en-US"] Regional Preferences ["en-GB"]

Those are not Google Search Settings .....  :(

Would you please read the second part of my first post again  ?

''Maren22 [[#answer-1215278|said]]'' <blockquote> I have and they are: Internationalisation & Localisation Application Settings Requested Locales ["en-GB"] Available Locales ["en-GB","en-US"] App Locales ["en-GB","en-US"] Regional Preferences ["en-GB"] Default Locale "en-GB" Operating System System Locales ["en-US"] Regional Preferences ["en-GB"] </blockquote> Those are not Google Search Settings ..... :( Would you please read the second part of my first post again ?
Was this helpful to you? 1
Quote
McCoy
  • Top 10 Contributor
466 solutions 4252 answers

Chosen Solution

Maybe this will explain it better :

  1. Got to google.com or google.co.uk,
  2. At the bottom (right side) click on 'Settings',
  3. Click on 'Search settings',
  4. Scroll down to 'Region Settings',
  5. Choose either 'Current Region' or 'United Kingdom',
  6. Click on the blue 'Save' button at the bottom of the page.
Maybe this will explain it better : # Got to google.com or google.co.uk, # At the bottom (right side) click on 'Settings', # Click on 'Search settings', # Scroll down to 'Region Settings', # Choose either 'Current Region' or 'United Kingdom', # Click on the blue 'Save' button at the bottom of the page.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17273 solutions 156141 answers

You can try to clear the Cache and remove the Cookies from websites (Google) that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
You can try to clear the Cache and remove the Cookies from websites (Google) that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
Was this helpful to you? 1
Quote

Question owner

It took several attempts but now things are back to normal. Thank you for your help, it's much appreciated.

It took several attempts but now things are back to normal. Thank you for your help, it's much appreciated.
Was this helpful to you? 0
Quote
McCoy
  • Top 10 Contributor
466 solutions 4252 answers

Maren22 said

It took several attempts but now things are back to normal.

I'm glad you got things back the way should be - well done  !

''Maren22 [[#answer-1215344|said]]'' <blockquote> It took several attempts but now things are back to normal. </blockquote> I'm glad you got things back the way should be - well done !
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.