X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

How do I restore default fonts and colors?

Posted

I was trying out various custom fonts and colors while checking my email. Now I am not happy with the choices I made. My email is almost impossible to read. I tried checking the box which says something like "allow website to choose own colors" but nothing changed. I really want to restore the default fonts (and size) and the color. What should I do?

I was trying out various custom fonts and colors while checking my email. Now I am not happy with the choices I made. My email is almost impossible to read. I tried checking the box which says something like "allow website to choose own colors" but nothing changed. I really want to restore the default fonts (and size) and the color. What should I do?

Chosen solution

Hi Muffers, where did you make the changes? If you were using Firefox's own Colors dialog, the default text color is black and the default background color is white.

Firefox has a separate fonts dialog -- the button is labeled Advanced -- where you can restore default sizes. Actually, it may be hard to recognize default sizes, so here's another way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste font*size and pause while the list is filtered (the * allows for any number of characters in between the words font and size)

(3) Any bolded preferences are customized, so to restore those to their default value, right-click > Reset

And also, just in case:

(4) In the search box above the list, type or paste fonts and pause while the list is filtered

(5) If the browser.display.use_document_fonts preference is bolded and "modified", you can right-click > Reset to restore the default value (which is, use the fonts assigned by the page)

And also, for good measure:

(6) In the search box above the list, type or paste color and pause while the list is filtered

(7) The browser.display.document_color_use preference can have these values (I recommend either the default of 0 or 1, if your system theme is bleeding into pages in a way you don't like) -- double-click to edit if needed:

  • 0 = use the page's colors, except in high contrast mode ("Only with high contrast themes" override the page) -- default setting
  • 1 = use the page's colors ("Never" override the page)
  • 2 = use the user's colors ("Always" override the page)

Does email look more normal after that??

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8315 solutions 68040 answers

Chosen Solution

Hi Muffers, where did you make the changes? If you were using Firefox's own Colors dialog, the default text color is black and the default background color is white.

Firefox has a separate fonts dialog -- the button is labeled Advanced -- where you can restore default sizes. Actually, it may be hard to recognize default sizes, so here's another way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste font*size and pause while the list is filtered (the * allows for any number of characters in between the words font and size)

(3) Any bolded preferences are customized, so to restore those to their default value, right-click > Reset

And also, just in case:

(4) In the search box above the list, type or paste fonts and pause while the list is filtered

(5) If the browser.display.use_document_fonts preference is bolded and "modified", you can right-click > Reset to restore the default value (which is, use the fonts assigned by the page)

And also, for good measure:

(6) In the search box above the list, type or paste color and pause while the list is filtered

(7) The browser.display.document_color_use preference can have these values (I recommend either the default of 0 or 1, if your system theme is bleeding into pages in a way you don't like) -- double-click to edit if needed:

  • 0 = use the page's colors, except in high contrast mode ("Only with high contrast themes" override the page) -- default setting
  • 1 = use the page's colors ("Never" override the page)
  • 2 = use the user's colors ("Always" override the page)

Does email look more normal after that??

Hi Muffers, where did you make the changes? If you were using Firefox's own Colors dialog, the default text color is black and the default background color is white. Firefox has a separate fonts dialog -- the button is labeled Advanced -- where you can restore default sizes. Actually, it may be hard to recognize default sizes, so here's another way: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''font*size''' and pause while the list is filtered (the * allows for any number of characters in between the words ''font'' and ''size'') (3) Any bolded preferences are customized, so to restore those to their default value, right-click > Reset ''And also, just in case:'' (4) In the search box above the list, type or paste '''fonts''' and pause while the list is filtered (5) If the '''browser.display.use_document_fonts''' preference is bolded and "modified", you can right-click > Reset to restore the default value (which is, use the fonts assigned by the page) ''And also, for good measure:'' (6) In the search box above the list, type or paste '''color''' and pause while the list is filtered (7) The '''browser.display.document_color_use''' preference can have these values (I recommend either the default of 0 or 1, if your system theme is bleeding into pages in a way you don't like) -- double-click to edit if needed: * 0 = use the page's colors, except in high contrast mode ("Only with high contrast themes" override the page) -- default setting * 1 = use the page's colors ("Never" override the page) * 2 = use the user's colors ("Always" override the page) Does email look more normal after that??
Was this helpful to you? 1
Quote
the-edmeister
  • Top 25 Contributor
  • Moderator
5386 solutions 39975 answers

Muffers said

I was trying out various custom fonts and colors while checking my email. Now I am not happy with the choices I made. My email is almost impossible to read. I tried checking the box which says something like "allow website to choose own colors" but nothing changed. I really want to restore the default fonts (and size) and the color. What should I do?

You posted in the Firefox support fora queue. Firefox doesn't do email, it's strictly a web browser.

If you are using Firefox to access your mail, you are using "web-mail" such as Yahoo!Mail or Gmail. You should seek support from your "web mail" service provider or a forum for that service.

If your problem is with Thunderbird, let us know and we can move this thread to the Thunderbird support queue.

https://support.mozilla.org/en-US/kb/problems-with-email-how-to-find-help

''Muffers [[#question-1256726|said]]'' <blockquote> I was trying out various custom fonts and colors while checking my email. Now I am not happy with the choices I made. My email is almost impossible to read. I tried checking the box which says something like "allow website to choose own colors" but nothing changed. I really want to restore the default fonts (and size) and the color. What should I do? </blockquote> You posted in the Firefox support fora queue. Firefox doesn't do email, it's strictly a web browser. If you are using Firefox to access your mail, you are using "web-mail" such as Yahoo!Mail or Gmail. You should seek support from your "web mail" service provider or a forum for that service. If your problem is with Thunderbird, let us know and we can move this thread to the Thunderbird support queue. https://support.mozilla.org/en-US/kb/problems-with-email-how-to-find-help
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17087 solutions 154328 answers

Can you attach a screenshot to see what changes this is about?

Does this affect all web pages?

Can you attach a screenshot to see what changes this is about? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot Does this affect all web pages?
Was this helpful to you?
Quote
Pj
  • Top 25 Contributor
44 solutions 868 answers

Helpful Reply

More on Fonts and Colors:

I have the SWPC (Space Weather Prediction Center) Product Subscription Service, and the text is quite small (with gMail). I made an adjustment with the Monospace Font to 18. That worked. Also, you can hold the Control key down while tapping the +/- keys to zoom in/out of pages.

I uploaded some images of my FF Font/Color setup.

Here's an article about Fonts and Colors in FireFox:

Change the fonts and colors websites use.



~Pj

More on Fonts and Colors: I have the SWPC (Space Weather Prediction Center) Product Subscription Service, and the text is quite small (with gMail). I made an adjustment with the Monospace Font to 18. That worked. Also, you can hold the Control key down while tapping the +/- keys to zoom in/out of pages. I uploaded some images of my FF Font/Color setup. Here's an article about Fonts and Colors in FireFox: '''[https://support.mozilla.org/en-US/kb/change-fonts-and-colors-websites-use <u>Change the fonts and colors websites use</u>]'''. ~Pj
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.