X
Tap here to go to the mobile version of the site.

Support Forum

Taskbar tile shows "Firefox (3)". Why the 3? I can't get rid of it.

Posted

I am a novice. I have a desktop with 12GB RAM running Windows 10.

When I open Firefox, I get the expected tile on my taskbar that says Firefox. Anytime I want to open an additional Firefox window instead of a new tab, I right click this tile and a small pop-up menu appears as follows:

Open new tab Open new window New private window Firefox Unpin from taskbar Close window

From this menu, I select Firefox, I get a new window, and I am on my way, no problem.

However, several months back, this menu started showing "Firefox (2)". I don't know what I did, but it soon turned into "Firefox (3)" and has stayed there. Lately, my computer has been slowing down and I'm now trying to see if this is a factor. Here's what I now always see in the pop-up menu:

Open new tab Open new window New private window Firefox (3) Unpin from taskbar Close window

Even though the number is 3 in my taskbar tile menu, to open even one tab of Firefox makes Task Manager show Firefox (5). Perhaps that higher quantity had been there all along and I just never noticed. Ending task on any one or all of them makes no difference as they will re-happen when I close and reopen Firefox. Maybe this is unrelated to my "Firefox (3)" problem, I dunno.

(Hovering my mouse over this Firefox tile, I see only the one thumbnail that I purposely opened so it's not like I can X out extra ones there.)

Assuming it WAS related, I uninstalled Firefox several times, no change. I refreshed it, no change. I turned off something called e10s, still no change to my tile menu. Somehow in all this, I finally turned off the multiple instances of Firefox in Task Manager and now only have one instance listed there PER FIREFOX WINDOW, not one for each tab contained in each window. Maybe this is the e10s thing I turned off. I'm sorry that I can't recall how I accomplished that but one must close out all tabs each time to test what changes, and I forgot to write down what I did here. It was some option I toggled in the about:config page.

So far, I know I've done this: browser.tabs.remote.autostart - changed from true to false. It is still false.

In about:config: Multiprocess windows now shows 0/2 Disabled. It started out today as 1/1 and at one point shows 2/2 (I think).

Yet, after all of this, my taskbar tile menu still says "Firefox (3)".

Can anyone who recognizes this tile menu problem help me? Perhaps along the way you can tell me whether or not the multiple instances of Task Manager has anything to do with it.

Thank you.

I am a novice. I have a desktop with 12GB RAM running Windows 10. When I open Firefox, I get the expected tile on my taskbar that says Firefox. Anytime I want to open an additional Firefox window instead of a new tab, I right click this tile and a small pop-up menu appears as follows: Open new tab Open new window New private window Firefox Unpin from taskbar Close window From this menu, I select Firefox, I get a new window, and I am on my way, no problem. However, several months back, this menu started showing "Firefox (2)". I don't know what I did, but it soon turned into "Firefox (3)" and has stayed there. Lately, my computer has been slowing down and I'm now trying to see if this is a factor. Here's what I now always see in the pop-up menu: Open new tab Open new window New private window Firefox (3) Unpin from taskbar Close window Even though the number is 3 in my taskbar tile menu, to open even one tab of Firefox makes Task Manager show Firefox (5). Perhaps that higher quantity had been there all along and I just never noticed. Ending task on any one or all of them makes no difference as they will re-happen when I close and reopen Firefox. Maybe this is unrelated to my "Firefox (3)" problem, I dunno. (Hovering my mouse over this Firefox tile, I see only the one thumbnail that I purposely opened so it's not like I can X out extra ones there.) Assuming it WAS related, I uninstalled Firefox several times, no change. I refreshed it, no change. I turned off something called e10s, still no change to my tile menu. Somehow in all this, I finally turned off the multiple instances of Firefox in Task Manager and now only have one instance listed there PER FIREFOX WINDOW, not one for each tab contained in each window. Maybe this is the e10s thing I turned off. I'm sorry that I can't recall how I accomplished that but one must close out all tabs each time to test what changes, and I forgot to write down what I did here. It was some option I toggled in the about:config page. So far, I know I've done this: browser.tabs.remote.autostart - changed from true to false. It is still false. In about:config: Multiprocess windows now shows 0/2 Disabled. It started out today as 1/1 and at one point shows 2/2 (I think). Yet, after all of this, my taskbar tile menu still says "Firefox (3)". Can anyone who recognizes this tile menu problem help me? Perhaps along the way you can tell me whether or not the multiple instances of Task Manager has anything to do with it. Thank you.

Chosen solution

Hi, this bug happens when you have pinned and unpinned, then re-pinned in a different way - such as from the Start Menu then from a Desktop shortcut, and if you do this, unpinning does not remove the icon from the User Pinned file, so there are now 2 (or more) copies.

To fix this, first you need to show hidden files and folders: Control Panel > Appearance - Folder options > Show hidden files and folders > View tab > Show hidden files, folders, and drives.

Now in This PC, double click the C drive to open it, > Users > (your name) > App Data > Roaming > Microsoft > Internet Explorer > Quick Launch > User Pinned > Taskbar, then right click and Delete Firefox.

Now right click on the Taskbar icon and remove it, then open Firefox from the Start Menu A-Z programs, and right click Pin to Taskbar on the running icon.

The number should now have gone.

Finally, go back and hide hidden files and folders again: Control Panel > Appearance - Folder options > Show hidden files and folders > View tab > Don't show hidden files, folders, and drives.

Note: This works on Win7 but I haven't tested on Win10, although the procedure should be similar.

It is nothing to do with the number of running processes which you can change if you wish, as mentioned by cor-el.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

Helpful Reply

Weird, OP did not display tile menu correctly,let me try again:

Open new tab Open new window New private window Firefox (3) Unpin from taskbar Close window

Weird, OP did not display tile menu correctly,let me try again: Open new tab Open new window New private window Firefox (3) Unpin from taskbar Close window
Was this helpful to you? 1
Quote

Question owner

It is only the Firefox icon that I "pin to taskbar" that brings up the "Firefox (3)" in its menu list when right-click on it. The individual Firefox taskbar tiles do not do this. I wish I could edit my OP to have made this clear, sorry.

I reinstalled Firefox again this morning with Refresh option and the (3) is still there. At this point, the only thing I have modified in about:config is "browser.tabs.insertRelatedAfterCurrent" to get my new tabs to open on the far right.

Also, FWIW, at this moment I have only only one Firefox window/open, no additional windows or tabs, and Task Manager indicates Firefox (5). From other reading, this may be unrelated to my taskbar's (3), I dunno, but there you are.

It is only the Firefox icon that I "pin to taskbar" that brings up the "Firefox (3)" in its menu list when right-click on it. The individual Firefox taskbar tiles do not do this. I wish I could edit my OP to have made this clear, sorry. I reinstalled Firefox again this morning with Refresh option and the (3) is still there. At this point, the only thing I have modified in about:config is "browser.tabs.insertRelatedAfterCurrent" to get my new tabs to open on the far right. Also, FWIW, at this moment I have only only one Firefox window/open, no additional windows or tabs, and Task Manager indicates Firefox (5). From other reading, this may be unrelated to my taskbar's (3), I dunno, but there you are.

Modified by seattleuser

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155209 answers

This is about other processes that Firefox opens like content processes and processes for a possible Flash plugin.

It is quite normal to see three or more Firefox processes running.

  • one process for the main Firefox thread (user interface)
  • one or more content processes set via:
    Options/Preferences -> General -> Performance
    to inspect details, remove checkmark:
    [ ] "Use recommended performance settings"
  • one process for the compositor thread (Windows; graphics)

You can find the current multi-process state on the Troubleshooting Information (about:support) page.

  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Web Content Processes
This is about other processes that Firefox opens like content processes and processes for a possible Flash plugin. *https://support.mozilla.org/en-US/kb/performance-settings It is quite normal to see three or more Firefox processes running. *one process for the main Firefox thread (user interface) *one or more content processes set via:<br>Options/Preferences -> General -> Performance<br>to inspect details, remove checkmark:<br>[ ] "Use recommended performance settings" *one process for the compositor thread (Windows; graphics) You can find the current multi-process state on the Troubleshooting Information (about:support) page. *"Help -> Troubleshooting Information" -> "Application Basics":<br>Multiprocess Windows<br>Web Content Processes
Was this helpful to you?
Quote

Question owner

Hi cor-el,

May I ask you this? :

First, close all of your Firefox windows. Next, if you have a Firefox shortcut on your desktop, can you right-click on it then select "pin to taskbar"? Then, once the Firefox icon appears on the taskbar, and with NO Firefox windows yet open, can you right-click on that taskbar icon and tell me if there is a number in parentheses on the menu that appears, after the word Firefox? Mine shows Firefox (3).

Thanks.

Hi cor-el, May I ask you this? : First, close all of your Firefox windows. Next, if you have a Firefox shortcut on your desktop, can you right-click on it then select "pin to taskbar"? Then, once the Firefox icon appears on the taskbar, and with NO Firefox windows yet open, can you right-click on that taskbar icon and tell me if there is a number in parentheses on the menu that appears, after the word Firefox? Mine shows Firefox (3). Thanks.
Was this helpful to you?
Quote
Scribe 719 solutions 3440 answers

Chosen Solution

Hi, this bug happens when you have pinned and unpinned, then re-pinned in a different way - such as from the Start Menu then from a Desktop shortcut, and if you do this, unpinning does not remove the icon from the User Pinned file, so there are now 2 (or more) copies.

To fix this, first you need to show hidden files and folders: Control Panel > Appearance - Folder options > Show hidden files and folders > View tab > Show hidden files, folders, and drives.

Now in This PC, double click the C drive to open it, > Users > (your name) > App Data > Roaming > Microsoft > Internet Explorer > Quick Launch > User Pinned > Taskbar, then right click and Delete Firefox.

Now right click on the Taskbar icon and remove it, then open Firefox from the Start Menu A-Z programs, and right click Pin to Taskbar on the running icon.

The number should now have gone.

Finally, go back and hide hidden files and folders again: Control Panel > Appearance - Folder options > Show hidden files and folders > View tab > Don't show hidden files, folders, and drives.

Note: This works on Win7 but I haven't tested on Win10, although the procedure should be similar.

It is nothing to do with the number of running processes which you can change if you wish, as mentioned by cor-el.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Hi, this bug happens when you have pinned and unpinned, then re-pinned in a different way - such as from the Start Menu then from a Desktop shortcut, and if you do this, unpinning does not remove the icon from the User Pinned file, so there are now 2 (or more) copies. To fix this, first you need to '''show''' hidden files and folders: Control Panel > Appearance - Folder options > Show hidden files and folders > View tab > Show hidden files, folders, and drives. Now in This PC, double click the C drive to open it, > Users > (your name) > App Data > Roaming > Microsoft > Internet Explorer > Quick Launch > User Pinned > Taskbar, then right click and Delete Firefox. Now right click on the Taskbar icon and remove it, then open Firefox from the Start Menu A-Z programs, and right click Pin to Taskbar on the running icon. The number should now have gone. Finally, go back and '''hide''' hidden files and folders again: Control Panel > Appearance - Folder options > Show hidden files and folders > View tab > Don't show hidden files, folders, and drives. Note: This works on Win7 but I haven't tested on Win10, although the procedure should be similar. It is nothing to do with the number of running processes which you can change if you wish, as mentioned by cor-el. ''If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!''
Was this helpful to you?
Quote

Question owner

Hi Scribe.

It worked! The (3) is finally gone!

Windows 10 had a different route to Show hidden files and folders, as explained here:

https://support.microsoft.com/en-us/help/14201/windows-show-hidden-files

When I got to your step to right-click and delete Firefox, I saw TWO entries: Firefox (2) Firefox

Both said they were shortcuts but only one had the red Firefox logo next to it. Can't recall as I write this what the other one had for a picture, some white square box perhaps.

I assumed deleting just the "Firefox (2)" would fix it but all that did was change my menu from (3) to (2) and that deleted entry soon reappeared (maybe because I had fiddled with pinning/unpinning, didn't expect it so didn't pay attention). Anyway, next I deleted the one without the (2) and magically it removed BOTH entries. I pinned again and voila, problem solved.

Yeah, I now see it's separate from the multiple processes thing.

Thank you, Scribe for showing me how to fix this annoying thing and thank you, cor-el, for helping me to fine-tune my question which had I written it that way in the beginning would have solved this problem sooner had I not confused it with the other thing, but at least I also know they are two different things.

I hope the way I titled this thread is enough to bring others here who have this same specific problem.

Thank you.

Hi Scribe. It worked! The (3) is finally gone! Windows 10 had a different route to Show hidden files and folders, as explained here: https://support.microsoft.com/en-us/help/14201/windows-show-hidden-files When I got to your step to right-click and delete Firefox, I saw TWO entries: Firefox (2) Firefox Both said they were shortcuts but only one had the red Firefox logo next to it. Can't recall as I write this what the other one had for a picture, some white square box perhaps. I assumed deleting just the "Firefox (2)" would fix it but all that did was change my menu from (3) to (2) and that deleted entry soon reappeared (maybe because I had fiddled with pinning/unpinning, didn't expect it so didn't pay attention). Anyway, next I deleted the one without the (2) and magically it removed BOTH entries. I pinned again and voila, problem solved. Yeah, I now see it's separate from the multiple processes thing. Thank you, Scribe for showing me how to fix this annoying thing and thank you, cor-el, for helping me to fine-tune my question which had I written it that way in the beginning would have solved this problem sooner had I not confused it with the other thing, but at least I also know they are two different things. I hope the way I titled this thread is enough to bring others here who have this same specific problem. Thank you.

Modified by seattleuser

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.