X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Youtube freezes my entire browser when I start to play a video.

Posted

For about the last 6 months, whenever I bring up Youtube, or even if a Youtube video starts to play on any other site, it completely freezes the entire browser and I can't do anything except close everything and bring everything up again, this time making sure no Youtube videos pop up anywhere, or the same thing happens. It's unfortunate, because Firefox is by far the best browser, but I've had to use Microsoft Edge for Youtube, which is verrrrrrry slow, but it doesn't freeze like Firefox does. I've tried reinstalling adobe flash player, resinstalling Firefox, and I can't go on to Youtube to change anything because, as I said, as soon as video starts to play (i.e. when Youtube first comes up), it freezes, so I can't access the site at all. I would love to go back to Firefox for Youtube, but I can't figure out how to stop it from freezing everything. Any help is appreciated.

For about the last 6 months, whenever I bring up Youtube, or even if a Youtube video starts to play on any other site, it completely freezes the entire browser and I can't do anything except close everything and bring everything up again, this time making sure no Youtube videos pop up anywhere, or the same thing happens. It's unfortunate, because Firefox is by far the best browser, but I've had to use Microsoft Edge for Youtube, which is verrrrrrry slow, but it doesn't freeze like Firefox does. I've tried reinstalling adobe flash player, resinstalling Firefox, and I can't go on to Youtube to change anything because, as I said, as soon as video starts to play (i.e. when Youtube first comes up), it freezes, so I can't access the site at all. I would love to go back to Firefox for Youtube, but I can't figure out how to stop it from freezing everything. Any help is appreciated.

Chosen solution

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

Wesley Branton
  • Top 25 Contributor
523 solutions 4561 answers

Chosen Solution

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

'''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.
Was this helpful to you? 1
Quote

Question owner

That worked! Thank you very much!

That worked! Thank you very much!
Was this helpful to you?
Quote
Wesley Branton
  • Top 25 Contributor
523 solutions 4561 answers

Do you mind sharing more information on what exactly to had to do to fix the issue? Did you disable hardware acceleration? Was there an add-on causing an issue?

The threads posted here are often viewed by other people experiencing similar issues. By providing more information, you are potentially helping other people solve their problem.

Thanks.

Do you mind sharing more information on what exactly to had to do to fix the issue? Did you disable hardware acceleration? Was there an add-on causing an issue? The threads posted here are often viewed by other people experiencing similar issues. By providing more information, you are potentially helping other people solve their problem. Thanks.
Was this helpful to you?
Quote

Question owner

I disabled hardware acceleration. Youtube works perfectly now.

I disabled hardware acceleration. Youtube works perfectly now.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.