X
Tap here to go to the mobile version of the site.

Support Forum

The info I was emailed about "block autoplay" is confusing. Why do I have to download Firefox again to get it? I just want to add it.

Posted

I received the email from Firefox about adding "AutoPlay Block" which I want as these irritate me. Since I already have Firefox why can't I just add the blocking extension itself. Why do I have to download Firefox again as it says? States "download Firefox with autoblock".

I received the email from Firefox about adding "AutoPlay Block" which I want as these irritate me. Since I already have Firefox why can't I just add the blocking extension itself. Why do I have to download Firefox again as it says? States "download Firefox with autoblock".

Chosen solution

This is probably merely about a hotfix to flip the media.autoplay.default pref from 0 (allowed) to 1 (blocked) with the result of disabling auto-play by default.

You can instead modify the pref yourself on the about:config page.

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Bug 1535667 - Gradual rollout of block autoplay on release 66

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

FredMcD
  • Top 10 Contributor
4192 solutions 58521 answers

Helpful Reply

Are you sure that came from Mozilla?

. Whenever you get a message / popup that software / files need to be updated;

DO NOT USE ANY OF THE PROVIDED LINKS

While this may be a legitimate message, it could also be Malware or a Virus. Anytime you want or need to check for upgrades, go to the website of the True Owner of the program in question. For example, to check out Firefox, go to https://www.mozilla.org {web link}

You can report such a site at; Google Report Phishing Page {web link} which is the same when done while on site by going to Help > Report Web Forgery

Help us safeguard Mozilla’s trademarks by reporting misuse {web link}

For over a year, an epidemic of Fake Update Notices have been popping up all over the place. https://support.mozilla.org/en-US/kb/forum-response-i-found-fake-firefox-update

Are you sure that came from Mozilla? . '''Whenever you get a message / popup that''' '''software / files need to be updated;''' <u>'''DO NOT USE ANY OF'''</u> <u>'''THE PROVIDED LINKS'''</u> While this may be a legitimate message, it could also be <u>'''Malware or a Virus'''</u>. Anytime you want or need to check for upgrades, go to the website of the <u>'''True Owner'''</u> of the program in question. For example, to check out Firefox, go to '''https://www.mozilla.org''' {web link} You can report such a site at; '''[http://www.google.com/safebrowsing/report_phish/ Google Report Phishing Page]''' {web link} which is the same when done while on site by going to '''Help > Report Web Forgery''' '''[http://www.mozilla.org/en-US/legal/fraud-report/ Help us safeguard Mozilla’s trademarks by reporting misuse]''' {web link} For over a year, an epidemic of '''Fake Update Notices''' have been popping up all over the place. https://support.mozilla.org/en-US/kb/forum-response-i-found-fake-firefox-update
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156783 answers

Chosen Solution

This is probably merely about a hotfix to flip the media.autoplay.default pref from 0 (allowed) to 1 (blocked) with the result of disabling auto-play by default.

You can instead modify the pref yourself on the about:config page.

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Bug 1535667 - Gradual rollout of block autoplay on release 66

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

This is probably merely about a hotfix to flip the media.autoplay.default pref from 0 (allowed) to 1 (blocked) with the result of disabling auto-play by default. You can instead modify the pref yourself on the <b>about:config</b> page. You can look at these prefs on the about:config page to see if these values work for you. *media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt] *media.autoplay.allow-muted = false *media.autoplay.enabled.user-gestures-needed = false For user-gestures-needed you can try false and true to see what works for you. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config ---- [https://bugzilla.mozilla.org/show_bug.cgi?id=1535667 Bug 1535667] - Gradual rollout of block autoplay on release 66 (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)

Modified by cor-el

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.