X
Tap here to go to the mobile version of the site.

Support Forum

Want to get rid of "- visit" and magnifying glass in URL bar drop down options

Posted

I **USED** to be able to just type a and have FF go to Amazon. Or f and have FF go to Facebook. Now, since update, I type a and get a globe icon with http://a/ - Visit as the first drop down; and Magnifying Glass with a after it, THEN the third suggestion is Amazon.com. Screenshot attached.

I don't like having to mouse down through three suggestions and click when I used to just be able to hit "a + Return" to go to Amazon or "f + Return" to go to FB. (Chrome still does this the way I like, but FF stopped after recent update._

I've tried setting various urlbar configs to "false," but have had no luck getting rid of the first two suggestions.

Any help greatly appreciated.

I **USED** to be able to just type a and have FF go to Amazon. Or f and have FF go to Facebook. Now, since update, I type a and get a globe icon with http://a/ - Visit as the first drop down; and Magnifying Glass with a after it, THEN the third suggestion is Amazon.com. Screenshot attached. I don't like having to mouse down through three suggestions and click when I used to just be able to hit "a + Return" to go to Amazon or "f + Return" to go to FB. (Chrome still does this the way I like, but FF stopped after recent update._ I've tried setting various urlbar configs to "false," but have had no luck getting rid of the first two suggestions. Any help greatly appreciated.
Attached screenshots

Chosen solution

Is it possible you turned off autofill, the feature that guesses top-level domains in the address bar as you type? You can check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) If the browser.urlbar.autoFill preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

That feature isn't perfect, it may take more than one letter to match, but it might be closer to what you're looking for.

Also, you can hide the top blue bar using a custom style rule in a userChrome.css file, but hiding it won't make the cursor move down to the next result, so I won't trouble you with the messy details on that.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

McCoy
  • Top 10 Contributor
520 solutions 4893 answers

Hello winmorgan,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar browser.urlbar.

Look for the preference :

browser.urlbar.maxRichResults

And set its value to 0 (= zero)

Then close and restart Firefox.

Should this not be what you want, then change the value back to 10 (= default)

Hello winmorgan, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''browser.urlbar.''' Look for the preference : '''browser.urlbar.maxRichResults''' And set its value to '''0''' (= zero)''' Then close and restart Firefox. Should this not be what you want, then change the value back to '''10''' (= default)
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Chosen Solution

Is it possible you turned off autofill, the feature that guesses top-level domains in the address bar as you type? You can check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) If the browser.urlbar.autoFill preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

That feature isn't perfect, it may take more than one letter to match, but it might be closer to what you're looking for.

Also, you can hide the top blue bar using a custom style rule in a userChrome.css file, but hiding it won't make the cursor move down to the next result, so I won't trouble you with the messy details on that.

Is it possible you turned off autofill, the feature that guesses top-level domains in the address bar as you type? You can check here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''URLB''' and pause while the list is filtered (3) If the '''browser.urlbar.autoFill''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true That feature isn't perfect, it may take more than one letter to match, but it might be closer to what you're looking for. Also, you can ''hide'' the top blue bar using a custom style rule in a userChrome.css file, but hiding it won't make the cursor move down to the next result, so I won't trouble you with the messy details on that.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157344 answers

There is a setting in "Options/Preferences -> Search" to hide search suggestions in the location bar that you can try to disable.

There is a setting in "Options/Preferences -> Search" to hide search suggestions in the location bar that you can try to disable.
Was this helpful to you?
Quote

Question owner

Thanks for all the suggestions...greatly appreciated!

It was browser.urlbar.autofill set to false. Changed it to true and back in business. Again, thank you for the help!

Thanks for all the suggestions...greatly appreciated! It was browser.urlbar.autofill set to false. Changed it to true and back in business. Again, thank you for the help!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.