X
Tap here to go to the mobile version of the site.

Support Forum

disable "search with" drop down

Posted

Using Firefox 55.0.2

When I start to type an address in the URL bar, I get a drop down box directly below the url/address bar. The dropdown, which is as wide as my firefox window, contains a little magnifying glass icon and the text "Search with Yahoo" where Yahoo is my default, and only, search engine.

I don't want this drop down box at all but I can't seem to disable it.

I tried setting browser.urlbar.oneoffsearches to false On the about:preferences#search page, I have unchecked Show search suggestions in location bar results On the about:preferences#search page under One Click Search Engines, I have Yahoo listed as the only engine and can not remove it.

Any help getting rid of this drop down would be appreciated.

Thanks

Using Firefox 55.0.2 When I start to type an address in the URL bar, I get a drop down box directly below the url/address bar. The dropdown, which is as wide as my firefox window, contains a little magnifying glass icon and the text "Search with Yahoo" where Yahoo is my default, and only, search engine. I don't want this drop down box at all but I can't seem to disable it. I tried setting browser.urlbar.oneoffsearches to false On the about:preferences#search page, I have unchecked Show search suggestions in location bar results On the about:preferences#search page under One Click Search Engines, I have Yahoo listed as the only engine and can not remove it. Any help getting rid of this drop down would be appreciated. Thanks

Chosen solution

Hmm, in that case the sledgehammer is:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.autocomplete.enabled preference to switch the value from true to false

Read this answer in context 3
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

More Information

FredMcD
  • Top 10 Contributor
3160 solutions 42648 answers

This sounds like the search bar action. Did you merge the address and search bars?

This sounds like the search bar action. Did you merge the address and search bars?
Was this helpful to you?
Quote

Question owner

I did not knowingly merge the address and search bars.

I have attached a small section of a screen shot. The 'thing' that I am trying to get rid of is the redundant blue bar with the magnifying glass in it.

Any ideas would be greatly appreciated.

I did not knowingly merge the address and search bars. I have attached a small section of a screen shot. The 'thing' that I am trying to get rid of is the redundant blue bar with the magnifying glass in it. Any ideas would be greatly appreciated.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3160 solutions 42648 answers

That action is normal in the search box. I think you combined the two boxes together.

That action is normal in the search box. I think you combined the two boxes together.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
6579 solutions 53777 answers

Firefox 55 has four categories of data that might appear in that autocomplete drop-down. If all four are disabled, then you do not get that informational row, either. One of them is a little tricky.

Three of the settings are under "Privacy" and one is under "Search", all on the Options/Preferences page.

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • or type or paste about:preferences in the address bar and press Enter

In the left column, click Search.

Make sure there's no checkmark next to "Show search suggestions in location bar results". If it's grayed but you can see that it's checked, click the checkbox for "Provide search suggestions" temporarily. Then uncheck the lower box first, and then uncheck the upper one.

In the left column, click Privacy.

Then uncheck each of the boxes in the Location Bar section (History, Bookmarks, Open tabs).

After that, you should not see the drop-down again.

Success?

Firefox 55 has four categories of data that might appear in that autocomplete drop-down. If ''all four'' are disabled, then you do not get that informational row, either. One of them is a little tricky. Three of the settings are under "Privacy" and one is under "Search", all on the Options/Preferences page. * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * ''or type or paste'' about:preferences ''in the address bar and press Enter'' In the left column, click '''Search'''. Make sure there's no checkmark next to "Show search suggestions in location bar results". <u>If it's grayed but you can see that it's checked</u>, click the checkbox for "Provide search suggestions" temporarily. Then uncheck the lower box first, and then uncheck the upper one. In the left column, click '''Privacy'''. Then uncheck each of the boxes in the '''Location Bar''' section (History, Bookmarks, Open tabs). After that, you should not see the drop-down again. Success?
Was this helpful to you?
Quote

Question owner

To Fred McGee: How would I un-merge the address and search bars, of indeed they have become merged?

To Fred McGee: How would I un-merge the address and search bars, of indeed they have become merged?
Was this helpful to you?
Quote

Question owner

To Jscher2000: Thank you for taking the time to write the detailed response. Unfortunately my options are already set as you suggest, but the problem persists

To Jscher2000: Thank you for taking the time to write the detailed response. Unfortunately my options are already set as you suggest, but the problem persists
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
6579 solutions 53777 answers

Chosen Solution

Hmm, in that case the sledgehammer is:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.autocomplete.enabled preference to switch the value from true to false

Hmm, in that case the sledgehammer is: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''URLB''' and pause while the list is filtered (3) Double-click the '''browser.urlbar.autocomplete.enabled''' preference to switch the value from true to false
Was this helpful to you? 3
Quote
FredMcD
  • Top 10 Contributor
3160 solutions 42648 answers

Helpful Reply

Type about:customizing<enter> in the address bar. In the new window, look for the icon. When you find it, hold down the left button on it, and move it to where you want it to be. You can move any of the icons you want from here, but; some icons are locked in place.

There is also a Restore Defaults button at the bottom middle.

Note: about:customizing is no longer present in Firefox 47+ releases.

  • Press Alt or F10 to bring up the toolbar.
    Then View > Toolbars > Customize.
  • Right-click on a blank spot in the toolbar and
    select Customize.

++++++++++++++++++++++++++++++++++++++++++++++++++ Put something between the address box and the search box.

This is what my toolbars look like.

Type '''about:customizing'''<enter> in the address bar. In the new window, look for the icon. When you find it, hold down the left button on it, and move it to where you want it to be. You can move any of the icons you want from here, but; '''some icons are locked in place. ''' There is also a '''Restore Defaults''' button at the bottom middle. Note: '''about:customizing''' is no longer present in Firefox 47+ releases. * Press '''Alt''' or '''F10''' to bring up the toolbar.<br>Then '''View > Toolbars > Customize. ''' * Right-click on a blank spot in the toolbar and<br>select '''Customize. ''' ++++++++++++++++++++++++++++++++++++++++++++++++++ Put something between the address box and the search box. This is what my toolbars look like.

Modified by FredMcD

Was this helpful to you? 1
Quote

Question owner

To Jscher2000:

That did it. Thank you so much for your help. While Firefox is infinitely customizable, I have not take the time to investigate and learn all of the intricacies.


To FredMcD: Thank you for taking the time to provide a detailed reply.

To Jscher2000: That did it. Thank you so much for your help. While Firefox is infinitely customizable, I have not take the time to investigate and learn all of the intricacies. To FredMcD: Thank you for taking the time to provide a detailed reply.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.