X
Tap here to go to the mobile version of the site.

Support Forum

Why do links work when a page starts to load but then disable when it's done loading?

Posted

I have the issue with some sites where they have links, even pointing to the same site but the browser doesn't allow me to select them. I know they are working links because I can click them while the page is busy loading but when it is done, they are no longer accessible. I've tried using Safe Mode, restarting, refreshing, and even adjusting the performance settings but nothing works. It seems to be an issue with filtering "mixed content" on a particular site or at least a particular set of pages on a given site. When I do try and set the site to allow cookies or "disable protection for now" the options don't come up for the site. It has worked in previous versions of Firefox, so it is a little frustrating - especially if some links work on the site while others don't. I don't really want to refresh the page every time just to access the links, so any suggestions or fixes would be welcome.

An example site is this one: http://dnd5e.wikidot.com/spells:warlock

I have the issue with some sites where they have links, even pointing to the same site but the browser doesn't allow me to select them. I know they are working links because I can click them while the page is busy loading but when it is done, they are no longer accessible. I've tried using Safe Mode, restarting, refreshing, and even adjusting the performance settings but nothing works. It seems to be an issue with filtering "mixed content" on a particular site or at least a particular set of pages on a given site. When I do try and set the site to allow cookies or "disable protection for now" the options don't come up for the site. It has worked in previous versions of Firefox, so it is a little frustrating - especially if some links work on the site while others don't. I don't really want to refresh the page every time just to access the links, so any suggestions or fixes would be welcome. An example site is this one: http://dnd5e.wikidot.com/spells:warlock

Chosen solution

If the above does not help: There is a way for you to remove that block. Load the web page. After, right click on the page. From the Firefox option list, select Inspect Element. Then IMMANENTLY move the mouse off the screen. A sub-window should now open. One of the entries should be highlighted. Mouse on top of that entry. Now you should see a colored block on the page. Right-click on the entry. From the menu, select Delete Node.

Most of the time, that should uncover the page. But sometimes, there is another block under that one. Just repeat the above.

If you should make a mistake, do not worry. Just reload the page.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

FredMcD
  • Top 10 Contributor
4126 solutions 57598 answers

Helpful Reply

I had no problem with the link. But I use ad blocking.

Sometimes when a page is loaded, an invisible 'film' or overlay covers part or all of the page.

This might help: https://addons.mozilla.org/en-US/firefox/addon/behind_the_overlay/ Behind The Overlay

As I said above, I had no problem.

Go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) and search for a good ad / pop-up blocker.

I had no problem with the link. But I use ad blocking. Sometimes when a page is loaded, an invisible 'film' or overlay covers part or all of the page. This might help: https://addons.mozilla.org/en-US/firefox/addon/behind_the_overlay/ Behind The Overlay As I said above, I had no problem. Go to the [https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page] {web Link} (There’s a lot of good stuff here) and search for a good ad / pop-up blocker.
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
4126 solutions 57598 answers

Chosen Solution

If the above does not help: There is a way for you to remove that block. Load the web page. After, right click on the page. From the Firefox option list, select Inspect Element. Then IMMANENTLY move the mouse off the screen. A sub-window should now open. One of the entries should be highlighted. Mouse on top of that entry. Now you should see a colored block on the page. Right-click on the entry. From the menu, select Delete Node.

Most of the time, that should uncover the page. But sometimes, there is another block under that one. Just repeat the above.

If you should make a mistake, do not worry. Just reload the page.

If the above does not help: There is a way for you to remove that block. Load the web page. After, right click on the page. From the Firefox option list, select '''Inspect Element. ''' Then IMMANENTLY move the mouse off the screen. A sub-window should now open. One of the entries should be highlighted. Mouse on top of that entry. Now you should see a colored block on the page. Right-click on the entry. From the menu, select '''Delete Node. ''' Most of the time, that should uncover the page. But sometimes, there is another block under that one. Just repeat the above. If you should make a mistake, do not worry. Just reload the page.
Was this helpful to you? 1
Quote

Question owner

Thank you, FredMcD, for your prompt responses. Both responses worked but in the first one, I found that "Behind the Overlay" did not solve my problem. Although, "Ghostery" did seem to remove the invisible ad. I had no add-ons installed, so I was perplexed as that is often what causes issues. I chose your second suggestion to "inspect element" simply because it'll probably be the quickest solution, without add-ons, for future users who might come across the same issue.

Thank you once again for the help!

Thank you, FredMcD, for your prompt responses. Both responses worked but in the first one, I found that "Behind the Overlay" did not solve my problem. Although, "Ghostery" did seem to remove the invisible ad. I had no add-ons installed, so I was perplexed as that is often what causes issues. I chose your second suggestion to "inspect element" simply because it'll probably be the quickest solution, without add-ons, for future users who might come across the same issue. Thank you once again for the help!
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4126 solutions 57598 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.