X
Tap here to go to the mobile version of the site.

Support Forum

Why is FF suddenly running 11 processes instead of 7?

Posted

This has slowed FF down enormously. I think it began one or two updates ago. I'm currently running v66.0.2, 64-bit Win7.

This has slowed FF down enormously. I think it began one or two updates ago. I'm currently running v66.0.2, 64-bit Win7.
Attached screenshots

Chosen solution

You can reduce the maximum number of content processes on the Options page. See: Firefox's performance settings.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8693 solutions 71058 answers

Chosen Solution

You can reduce the maximum number of content processes on the Options page. See: Firefox's performance settings.

You can reduce the maximum number of content processes on the Options page. See: [[Firefox's performance settings]].

Question owner

That worked. I read the 66.0 release notes and it says, "Improved performance and reduced crash rates by doubling web content loading processes from 4 to 8." So it wasn't just me. That change would be fine if I had 8GB of RAM -- which is a good idea anyway -- but with just 4GB, I was thrashing hard.

Under Preferences/Basic, I reduced "Content process limit" from its default of 8 to 6. I thought the 8 was strange, since I was seeing 11 processes. FF didn't spontaneously reduce the number of processes, so I closed and reopened, and things got stranger. This time there were 9 processes. Huh?? So I reduced "Content process limit" again, to 4. Closed, reopened, and this time there were 7 processes, which is what I had before.

So I don't get how 8=11, 6=9, and 4=7. But my problem is fixed, so oh well. Thank you!

That worked. I read the 66.0 release notes and it says, "Improved performance and reduced crash rates by doubling web content loading processes from 4 to 8." So it wasn't just me. That change would be fine if I had 8GB of RAM -- which is a good idea anyway -- but with just 4GB, I was thrashing hard. Under Preferences/Basic, I reduced "Content process limit" from its default of 8 to 6. I thought the 8 was strange, since I was seeing 11 processes. FF didn't spontaneously reduce the number of processes, so I closed and reopened, and things got stranger. This time there were 9 processes. Huh?? So I reduced "Content process limit" again, to 4. Closed, reopened, and this time there were 7 processes, which is what I had before. So I don't get how 8=11, 6=9, and 4=7. But my problem is fixed, so oh well. Thank you!
jscher2000
  • Top 10 Contributor
8693 solutions 71058 answers

Helpful Reply

The setting in Options is for "content" processes, meaning where web pages are run. There is a main process and there may be a couple other processes for plugins or things I don't follow closely.

The setting in Options is for "content" processes, meaning where web pages are run. There is a main process and there may be a couple other processes for plugins or things I don't follow closely.

Question owner

Right you are. dom.ipc.processCount.webLargeAllocation sets the maximum number of processes. Default value is 10; I guess the 11th one is a master process. That matches up with the one process that only uses about 15,000 KB. I lowered the value to 6 and all is well.

Thanks again.

Right you are. ''dom.ipc.processCount.webLargeAllocation'' sets the maximum number of processes. Default value is 10; I guess the 11th one is a master process. That matches up with the one process that only uses about 15,000 KB. I lowered the value to 6 and all is well. Thanks again.