X
Tap here to go to the mobile version of the site.

Support Forum

Since upgrading to FF 66 Netflix videos don't play.

Posted

I had no problem playing Netflix videos before FF 66. I'm now on FF 66.0.1. I disabled all add-ons, restarted FF to no avail. This issue MIGHT be DRM related since preview vids play correctly in Netflix. They aren't DRM controlled. The full videos, which are DRM controlled, do not play. 'Play DRM-Controlled Content' is checked in my FF settings. I can play full videos as expected in Chrome. I prefer not to for obvious reasons. The NF error code is F7701-1003. The msg is 'There appears to be a problem with Firefox which is preventing Netflix from starting playback'. I've gone through the steps that NF suggest for this issue. Doing that doesn't resolve the issue.

I had no problem playing Netflix videos before FF 66. I'm now on FF 66.0.1. I disabled all add-ons, restarted FF to no avail. This issue MIGHT be DRM related since preview vids play correctly in Netflix. They aren't DRM controlled. The full videos, which are DRM controlled, do not play. 'Play DRM-Controlled Content' is checked in my FF settings. I can play full videos as expected in Chrome. I prefer not to for obvious reasons. The NF error code is F7701-1003. The msg is 'There appears to be a problem with Firefox which is preventing Netflix from starting playback'. I've gone through the steps that NF suggest for this issue. Doing that doesn't resolve the issue.

Chosen solution

Do you have history to be remembered?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

TyDraniu
  • Top 25 Contributor
301 solutions 1684 answers

Chosen Solution

Do you have history to be remembered?

Do you have history to be remembered?
Was this helpful to you? 1
Quote

Question owner

TyDraniu said

Do you have history to be remembered?

I had History disabled. After reading your question I enabled it and restarted FF. NF videos are playing properly now. Thank you!

''TyDraniu [[#answer-1208501|said]]'' <blockquote> Do you have history to be remembered? </blockquote> I had History disabled. After reading your question I enabled it and restarted FF. NF videos are playing properly now. Thank you!

Modified by HLMSPL

Was this helpful to you?
Quote

Question owner

p.s. it seems odd that Remember History has to be enabled for this. I seem to remember having it disabled in pre-66 releases. Maybe I'm wrong. :) Thanks again.

p.s. it seems odd that Remember History has to be enabled for this. I seem to remember having it disabled in pre-66 releases. Maybe I'm wrong. :) Thanks again.

Modified by HLMSPL

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.