Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website uses alt commands as shortcut. Firefox 65.0.2 just opens menu now

  • 9 replies
  • 2 have this problem
  • 125 views
  • Last reply by jscher2000

more options

Firefox 65.0.2 no longer supports my service desk context menus. Firefox 64.0.2 worked fine.

The service desk webpage we use has context based alt+<q,w,s,letters> commands that now dont work. The alt+s should save and instead now opens the bookmarks instead. It didnt used to.

theres also a time additon button that tabbing now jumps over when it used to stop on it.

Ive tried the nightly build same issues. Ive tried changing alt to ctrl for menu access in firefox same issue. Ive done a full uninstall and a full package download and install for FF65.0.2

Can anyone suggest anything else?

Chosen solution

Hi Mike, I was looking at a related issue and noticed there is a preference to exempt websites that suffer from this change. Did you already notice that before I did?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste hack and pause while the list is filtered

(3) Double-click the dom.keyboardevent.keypress.hack.dispatch_non_printable_keys preference to display a dialog where you can list sites that should have the old behavior and enter the host name, then click OK

So for example, if the site address was https://service.desk.com/ you would enter just the hostname portion

service.desk.com

If you need to list more than one host name, separate them with commas but no spaces.

If you try it, does it make any difference?

Read this answer in context 👍 1

All Replies (9)

more options

Hi Mike, are these implemented through "access keys"? In Firefox, to trigger an access key, you add the Shift key:

Alt+Shift+key

However, if the keyboard shortcuts are implemented through a script, the problem could be the following change:

https://www.fxsitecompat.com/en-CA/docs/2018/non-printable-keys-no-longer-fire-keypress-event/

When a key is pressed, scripts can listen for a keydown, keypress, and/or keyup event. After the above changed in Firefox 65, Alt+s still generates a keydown event, but not the keypress event. This was supposed to make Firefox more consistent with other browsers.

The site will need to be updated. You might be able to "hack" the page so that the old code still works, but I suggest trying their support first.

Related thread: https://support.mozilla.org/questions/1252519

more options

Chosen Solution

Hi Mike, I was looking at a related issue and noticed there is a preference to exempt websites that suffer from this change. Did you already notice that before I did?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste hack and pause while the list is filtered

(3) Double-click the dom.keyboardevent.keypress.hack.dispatch_non_printable_keys preference to display a dialog where you can list sites that should have the old behavior and enter the host name, then click OK

So for example, if the site address was https://service.desk.com/ you would enter just the hostname portion

service.desk.com

If you need to list more than one host name, separate them with commas but no spaces.

If you try it, does it make any difference?

more options

THIS!!!! THIS A THOUSAND TIMES!!!!! Thanks man this fixed my issue and returned full functionality to the webpage. Thanks so much.


jscher2000 said

Hi Mike, I was looking at a related issue and noticed there is a preference to exempt websites that suffer from this change. Did you already notice that before I did? (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste hack and pause while the list is filtered (3) Double-click the dom.keyboardevent.keypress.hack.dispatch_non_printable_keys preference to display a dialog where you can list sites that should have the old behavior and enter the host name, then click OK So for example, if the site address was https://service.desk.com/ you would enter just the hostname portion service.desk.com If you need to list more than one host name, separate them with commas but no spaces. If you try it, does it make any difference?
more options

As a follow up to this - the fix when applied does indeed resolve the alt+ options, but it breaks auto complete on dropdown menus.

Where you have a list that you can select using the first letter, if you start to type in the box it doesn't recognize the key press.

more options

Did the autocomplete work before adding the site to the hack preference, or is it broken in Firefox 66 with either setting?

I don't know how the roll-back triggered by this preference works; maybe it needs further testing on example sites.

more options

Hmm, now that I mention Firefox 66, there was another change, and now there is another hack preference you could try adding a site to:

(1) In a new tab, type about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste hack and pause while the list is filtered

(3) The dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode preference should have this new value as of Firefox 66.0.2, if not immediately, then after the first restart:

*.collabserv.com,*.gov.online.office365.us,*.officeapps-df.live.com,*.officeapps.live.com,*.online.office.de,*.partner.officewebapps.cn,*.scniris.com

You could add your site to this list, either at the beginning, followed by a comma (no spaces) or at the end, after a comma. As with the other "hack" this roll-back should take effect after you reload the page.

Ref. https://www.fxsitecompat.com/en-CA/docs/2018/support-for-window-event-and-event-returnvalue-has-been-added-again/

more options

Its broken with and without the setting and My firefox just updated to 66.2 for my sins. In the attached image I was trying to type S, and the a wouldnt overtype and nor would it offer me software from the list when in 64 and 65 I think it did.

more options

YOUR A GENIUS

fixed my issue again.

thanks

more options

It sounds as though that application has a lot of special code to handle weird old proprietary Firefox behaviors, and isn't tolerant of any changes to those behaviors. I have no idea whether the vendor will be updating it any time soon, but if you could escalate the question to them, that would be great. Ideally, they should try to update before the next Extended Support Release which is used by more enterprises. And/or they could publish a support article about the hacks in the meantime.