Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot set an application to handle nxm links.

  • 5 replies
  • 1 has this problem
  • 46 views
  • Last reply by gutless

more options

I am trying to configure Firefox for Linux to handle nxm links from https://www.nexusmods.com/skyrimspecialedition/ to be handled by Vortex, but keep getting "The address wasn’t understood".

Things I have tried:

1) Going to the Applications setting of Preferences and changing the application associated with nxm. nxm does not appear in this area.

2) Creating a boolean named network.protocol-handler.expose.nxm in about:config and setting it to false, then trying to open an nxm link and hope I receive a prompt asking me what application I would like to use.

3) Number 2 but with network-protocol-handler.expose-all

4) Executing the following commands after creating a file ~/.local/share/applications/vortex.desktop and making it executable:

$ xdg-mime default vortex.desktop x-scheme-handler/nxm

$ xdg-mime default vortex.desktop x-scheme-handler/nxm-protocol

$ gconftool-2 -s /desktop/gnome/url-handlers/nxm/command '~/.local/share/applications/vortex.desktop %s' --type String

$ gconftool-2 -s /desktop/gnome/url-handlers/nxm/enabled --type Boolean true

5) Restarting my computer.

I have tried to open nxm links in both Firefox 65.0.1 and 67.0b2 Developer Edition (installed ten minutes ago with no add-ons) with the same result. Please help me.

I am trying to configure Firefox for Linux to handle nxm links from https://www.nexusmods.com/skyrimspecialedition/ to be handled by Vortex, but keep getting "The address wasn’t understood". Things I have tried: 1) Going to the Applications setting of Preferences and changing the application associated with nxm. nxm does not appear in this area. 2) Creating a boolean named network.protocol-handler.expose.nxm in about:config and setting it to false, then trying to open an nxm link and hope I receive a prompt asking me what application I would like to use. 3) Number 2 but with network-protocol-handler.expose-all 4) Executing the following commands after creating a file ~/.local/share/applications/vortex.desktop and making it executable: $ xdg-mime default vortex.desktop x-scheme-handler/nxm $ xdg-mime default vortex.desktop x-scheme-handler/nxm-protocol $ gconftool-2 -s /desktop/gnome/url-handlers/nxm/command '~/.local/share/applications/vortex.desktop %s' --type String $ gconftool-2 -s /desktop/gnome/url-handlers/nxm/enabled --type Boolean true 5) Restarting my computer. I have tried to open nxm links in both Firefox 65.0.1 and 67.0b2 Developer Edition (installed ten minutes ago with no add-ons) with the same result. Please help me.

Modified by gutless

All Replies (5)

more options

Since this is a registered site and loaded from their site you should contact their support team on how to launch the software.

more options

WestEnd said

Since this is a registered site and loaded from their site you should contact their support team on how to launch the software.

I'm running Vortex through WINE and they don't officially support Linux, so their support team wouldn't have any response other than "we do not support Linux". Here is a post from the developer of Vortex on Linux support:

https://forums.nexusmods.com/index.php?/topic/7024131-vortex-for-linux/?p=63934436

However, I am looking for a solution that is protocol-agnostic. Is there no way for me to add a new association to Firefox?

more options

So this is a 14-year-old bug in Firefox.

https://bugzilla.mozilla.org/show_bug.cgi?id=312953

Someone posted a workaround 7 years ago, but it does not work for me. I have no idea where to go from here.

more options

I think that this still holds:

Did you remove a possible existing network.protocol-handler.app.nxm pref?

Did you get a prompt when you created network.protocol-handler.expose.nxm = false ?

When you create a network.protocol-handler.expose.<protocol> [pref and set its value to false then Firefox should prompt for an application to handle this protocol and create the network.protocol-handler.app pref.

more options

cor-el said

I think that this still holds: Did you remove a possible existing network.protocol-handler.app.nxm pref? Did you get a prompt when you created network.protocol-handler.expose.nxm = false ? When you create a network.protocol-handler.expose.<protocol> [pref and set its value to false then Firefox should prompt for an application to handle this protocol and create the network.protocol-handler.app pref.

This is what is described in number 2) of my original post. I do not get a prompt.

Edit: There is actually a link to the bug I posted at the bottom of that page.

Modified by gutless