Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why are Instagram videos not now displaying in Firefox 52 ESR?

  • 6 replies
  • 1 has this problem
  • Last reply by Dave-H

more options

Instagram videos have stopped displaying for me in Firefox 52 ESR. It happened suddenly a day or two ago. There isn't even a placeholder there for them on the page any longer, just the text that goes with them with nothing where the video should be. If I try to view one from someone's IG page, it just shows as a black box. Static images are still displaying fine, just not the videos.

This is on my old Windows XP machine, where I have to use FF 52.9.0 ESR as it's the last XP compatible version. The videos are fine in FF65 on my Windows 10 machine needless to say. I've tried spoofing different user agent strings, but no difference.

The strange thing is that on Google Chrome 49, again the last version which works on XP, the videos still display fine, and that is much older than FF 52 ESR! Also, if I right click on the IG page in FF 52 ESR, and select the "View Page Info" option, the videos still appear in the list on the "Media" tab, and if selected, they still display and can be played in the preview pane below, so they're obviously not being actually blocked, and the browser can still play them, they are just not displaying inline in the pages as they should!

Anyone any idea what's happening here? There's no point in me asking Instagram, as I know they will just say that they no longer support Firefox 52 ESR! Thanks, Dave.

All Replies (6)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

more options

Thanks, unfortunately I had already tried that as I thought maybe an add-on was causing the problem (especially Adblock Plus can cause that sort of issue of course) but it made no difference.

more options

Hi Dave-H, as you may know, Firefox on Windows XP cannot decode H.264/MP4 video because it relies on Windows Media Foundation and Microsoft never released that for XP. If the Instagram videos are only served in that format, Firefox will not be able to decode them. I don't know whether that is the issue, but you could look for an error message in Firefox's Web Console.

You can open the Web Console in the lower part of the tab using either:

  • "3-bar" menu button > Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console
  • (Windows) Ctrl+Shift+k

Then reload Instagram in the upper part of the tab and watch for error or security messages. (The lines with blue triangles generally are not significant unless you suspect a style rule problem.) Anything that sounds like it could be relevant?

more options

Did you possibly use the refresh feature in Firefox and created a new profile that doesn't have a tweak to play MP4 media files on Windows XP? If that is the case then look at your desktop for the "Old Firefox Data" folder and look for 'gmp' folders.

You can try if the solution posted here to add support for playing MP4 files works for you.

more options

You can see the limits of what Windows XP supports at with HTML5 players.

Youtube and many other sites now days use HTML5 players for video, audio and games instead of Flash Player Plugin to be more cross platform compared to Flash.

Dave-H said

The strange thing is that on Google Chrome 49, again the last version which works on XP, the videos still display fine, and that is much older than FF 52 ESR!

Chrome kind of cheats by coming with its own codecs. Chrome, Chromium, and Opera has not supported the EOL WinXP and Vista since April 2016.

A way to fully support HTML5 players and to run current versions of Firefox is to perhaps dual boot with a light 32-bit Linux distro with a light desktop like LXDE or XFCE.

more options

I know that Google Chrome has its own built-in codecs and does not rely on the operating system for support, which is almost certainly why the IG videos still work there. I do however have the Adobe Primetime plugin installed on FF52ESR which allows the HTML5 videos on Facebook and YouTube to work, and they are both still working fine. I assume that IG also used the same plugin to play its videos, and as I said earlier, they do still play fine in the "Page Info" window "Media" tab, so I don't think that the failure is because of any problem with FF being able to play the videos, the problem is with them actually appearing on the IG pages. There aren't even non-functional placeholders there in the pages for the videos, they just don't appear at all!