X
Tap here to go to the mobile version of the site.

Support Forum

Firefox quantum 65.0.2 uploads are all of a sudden extremely slow

Posted

I noticed a few months back that Firefox quantum 65.0.2 (64 bit) uploads are extremely slow. A 186kb image that is uploaded instantly in Chrome or Firefox developer edition (65.0b11 64 bit) takes about 30-45 seconds in quantum, a 900kb image jumps to 14% when I hit upload, then super slowly climbs up by 2%-4% at a time, finally finishing the upload 3 minutes later, and by the time the upload finishes the google captcha I entered has expired and it tells me to retry the upload. The same 900kb image uploads in 2 seconds on chrome and firefox dev. Also some websites like twitch.tv are super slow to load, not even a video stream, the homepage takes about 20 seconds to load, then another 30 seconds for the video to start playing, while the site loads and starts playing the homepage video within a few seconds on chrome and firefox dev. I've tried everything, launching firefox in safe mode, reinstalling firefox and trying with no plugins, switching between system proxy settings and no proxy. Is there anything else I can try? Super annoying having to launch chrome every time I need to upload something.

Thanks

I noticed a few months back that Firefox quantum 65.0.2 (64 bit) uploads are extremely slow. A 186kb image that is uploaded instantly in Chrome or Firefox developer edition (65.0b11 64 bit) takes about 30-45 seconds in quantum, a 900kb image jumps to 14% when I hit upload, then super slowly climbs up by 2%-4% at a time, finally finishing the upload 3 minutes later, and by the time the upload finishes the google captcha I entered has expired and it tells me to retry the upload. The same 900kb image uploads in 2 seconds on chrome and firefox dev. Also some websites like twitch.tv are super slow to load, not even a video stream, the homepage takes about 20 seconds to load, then another 30 seconds for the video to start playing, while the site loads and starts playing the homepage video within a few seconds on chrome and firefox dev. I've tried everything, launching firefox in safe mode, reinstalling firefox and trying with no plugins, switching between system proxy settings and no proxy. Is there anything else I can try? Super annoying having to launch chrome every time I need to upload something. Thanks

Chosen solution

That means one of the other programs on your system may be causing the issue.

As a test, disable your protection programs.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

FredMcD
  • Top 10 Contributor
4220 solutions 58909 answers

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

FredMcD said

Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Just tried doing that again, and nope it didn't fix it.

''FredMcD [[#answer-1204017|said]]'' <blockquote> [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> Just tried doing that again, and nope it didn't fix it.
FredMcD
  • Top 10 Contributor
4220 solutions 58909 answers

Helpful Reply

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia


This download manager works separately from the browser. The browser tells it what to download, and off it goes.

http://www.freedownloadmanager.org It is a powerful modern download accelerator and organizer for Windows and Mac.

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia --------------- This download manager works separately from the browser. The browser tells it what to download, and off it goes. http://www.freedownloadmanager.org It is a powerful modern download accelerator and organizer for Windows and Mac.

Question owner

FredMcD said

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

This download manager works separately from the browser. The browser tells it what to download, and off it goes.

http://www.freedownloadmanager.org It is a powerful modern download accelerator and organizer for Windows and Mac.

When starting in safe mode the problem is gone (the 900kb image uploads instantly).

''FredMcD [[#answer-1204086|said]]'' <blockquote> Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia --------------- This download manager works separately from the browser. The browser tells it what to download, and off it goes. http://www.freedownloadmanager.org It is a powerful modern download accelerator and organizer for Windows and Mac. </blockquote> When starting in safe mode the problem is gone (the 900kb image uploads instantly).
FredMcD
  • Top 10 Contributor
4220 solutions 58909 answers

Chosen Solution

That means one of the other programs on your system may be causing the issue.

As a test, disable your protection programs.

That means one of the other programs on your system may be causing the issue. As a test, disable your protection programs.

Question owner

FredMcD said

That means one of the other programs on your system may be causing the issue. As a test, disable your protection programs.

Removed everything from startup, killed every process in task manager besides stuff that wouldn't let me terminate it like csrss.exe, dwm.exe, winlogon.exe, etc. and the problem is still there.

Any idea why the problem only occurs on regular Firefox but not for Firefox Developer Edition?

''FredMcD [[#answer-1204413|said]]'' <blockquote> That means one of the other programs on your system may be causing the issue. As a test, disable your protection programs. </blockquote> Removed everything from startup, killed every process in task manager besides stuff that wouldn't let me terminate it like csrss.exe, dwm.exe, winlogon.exe, etc. and the problem is still there. Any idea why the problem only occurs on regular Firefox but not for Firefox Developer Edition?
FredMcD
  • Top 10 Contributor
4220 solutions 58909 answers

I called for more help.

I called for more help.

Question owner

I figured it out, it was my firewall (NetLimiter) limiting the output on firefox.exe to 5KB/s and even when the firewall process wasn't running, the service was still running in the background after startup. I think I enabled it to test the limit feature and then just forgot about it lol

Thanks for your help FredMcD!

I figured it out, it was my firewall (NetLimiter) limiting the output on firefox.exe to 5KB/s and even when the firewall process wasn't running, the service was still running in the background after startup. I think I enabled it to test the limit feature and then just forgot about it lol '''Thanks for your help FredMcD!'''
FredMcD
  • Top 10 Contributor
4220 solutions 58909 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.
n5mx 2 solutions 15 answers

without a real proxy a going to sys proxy has no effect.

without a real proxy a going to sys proxy has no effect.