Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Ctrl +D not working as it did

  • 2 replies
  • 1 has this problem
  • 325 views
  • Last reply by jscher2000

more options

I always used Ctrl +D to bookmark a page; Firefox would offer up an option for me to select where I wanted to bookmark be placed.

Now when I use Ctrl +D Firefox is automatically placing the bookmark for me (states 'Saved in Library') and I'm having to open up 'All Bookmarks', selecting the recently added bookmark and moving it to where I want it stored.

This is very annoying and I can't find a solution to correct it.

Maybe you know how to?

Chosen solution

You probably need to turn on the "show the editor" setting. After adding a bookmark, the star in the address bar should turn blue. Click the star, then find the "show editor when saving" setting. Here is a screenshot from a couple versions back for reference:

<center></center>

Does that work?

Read this answer in context 👍 0

All Replies (2)

more options

Press <Control> D again. This should open a window with that bookmark's data inside. From here you can edit the data.

more options

Chosen Solution

You probably need to turn on the "show the editor" setting. After adding a bookmark, the star in the address bar should turn blue. Click the star, then find the "show editor when saving" setting. Here is a screenshot from a couple versions back for reference:

<center></center>

Does that work?