Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search function won't work in a web site

  • 6 replies
  • 1 has this problem
  • 10 views
  • Last reply by etienne53

more options

When I fill in the search bar for the fitchratings.com web site, the search won't process. This didn't happen in the piro version of Firefox and I can find no options that I've checked differently. I now use Internet Explorer when I have to search this site.

Attached screenshots

Chosen solution

Hi etienne53, is your Firefox set for automatic private browsing? That's set here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll down to the History section. What do you have here? Either of these will trigger automatic private browsing mode:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

In that mode, Firefox automatically applies content blocking (the source of the "shield" icon at the left end of the address bar in your screenshot) and certain data clearing options are redudant, since private sessions do not save data to disk. This mode also disables the password manager.

Read this answer in context 👍 0

All Replies (6)

more options

"prior" version, not "piro" version. Sorry.

more options

I'm having other problems as well. Many of the Firefox options are greyed out so I can't change them. These include "Always check if Firefox is your default browser", "Delete cookies when Firefox closes", and "Ask to save logins and passwords".

more options

Chosen Solution

Hi etienne53, is your Firefox set for automatic private browsing? That's set here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll down to the History section. What do you have here? Either of these will trigger automatic private browsing mode:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

In that mode, Firefox automatically applies content blocking (the source of the "shield" icon at the left end of the address bar in your screenshot) and certain data clearing options are redudant, since private sessions do not save data to disk. This mode also disables the password manager.

more options

Okay, I fixed MOST of the problems. Apparently when I loaded Firefox on my new computer it was set to private browsing. I certainly don't remember doing this. After a lot of research, I finally found an article indicating this might be the problem and where to find the setting in Options.

Now the search functions and other options work on my web sites.

Oddly, the "Check if Firefox is your default browser" option is STILL greyed out.

more options

etienne53 said

Oddly, the "Check if Firefox is your default browser" option is STILL greyed out.

Yes, I think that's normal once the box is checked and Firefox is the default. If you don't want Firefox to check, you can change the setting a different way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste shell and pause while the list is filtered

(3) Double-click the browser.shell.checkDefaultBrowser preference to switch the value from true to false

more options

Thanks to everyone for your useful and very quick responses.