Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The newest version of Firefox won't load. I keep getting a "patch apply Failed" message.

  • 3 replies
  • 1 has this problem
  • 16 views
  • Last reply by James

more options

I have tried numerous times to download the newest version of Firefox. It appears to download OK but when I close it and then open again it still asks to download the newest version. When I look at the download history it shows a constant "patch apply failed" message.

All Replies (3)

more options

It doesn't do "patch apply" when I installed newer version it says "upgrade".

more options

Hi trkychsr57, could you try this way:

Clean Reinstall

This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

It only takes a few minutes.

(A) Download a fresh installer for Firefox to a convenient location:

https://www.mozilla.org/firefox/all/

(B) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer temporarily before the next step.

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement at your next startup?

more options

WestEnd said

It doesn't do "patch apply" when I installed newer version it says "upgrade".

The message is "The Update could not be installed (patch apply failed)" because the update failed.