Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't remove master password or allow "ask to save logins and passwords"

  • 4 replies
  • 1 has this problem
  • 19 views
  • Last reply by cor-el

more options

First I couldn't allow "Ask to save logins and passwords for websites" at the Privacy & Security settings. It's just a grey box I can't check. So I thought of trying to use a master password, set it up and gave it a try. It didn't work. Now, I have a couple of problems: When I open Firefox, it prompts me for the master password, and when I enter it, it prompts me again. And again. And it keeps going until I click on "cancel" instead of actually entering the password. I can't change my master password. It starts the same loop as above. I can't disable the "Use a master password" box. When I click it, it asks for my master password, but I can't click on the "Remove" button - it's grey. Has anyone experienced this? Thanks!

All Replies (4)

more options

Are you using any password add-ons/programs?

Change the Master Password to nothing (no password).

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

That disabled the master password. Thanks! I still have the issue with saving logins and passwords, though - checkbox's still grey.

more options

FredMcD said

Are you using any password add-ons/programs?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Are you using Sync as that is a possible reason to ask for the MP?

What happens if you try to open the Password Manager?

  • Options/Preferences -> Privacy & Security: Forms & Passwords: "Saved Logins" -> "Show Passwords"

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

See also:

You can rename/remove logins.json and key4.db in the Firefox profile folder with Firefox closed if you can't use other ways to recover from this.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.